Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Feb 2002
    Location
    Auckland, New Zealand
    Posts
    552
    Thanks
    57
    Thanked 0 Times in 0 Posts

    VBA Automation error

    Hi
    Have a spreadsheet for recording staff training that is saved as a excel binary file (.xlsb) that works fine under MSO 2010 but will not load properly under MSO 2013.
    Whenever we try open the file an "Automation Error" message is displayed and we get put in an endless loop and have to use Task Manager to exit.

    Anyone have any clues?
    cheers

    Phil Carter

  2. #2
    WS Lounge VIP
    Join Date
    Mar 2002
    Location
    Newcazzle, UK
    Posts
    3,128
    Thanks
    149
    Thanked 573 Times in 545 Posts
    Hi Phil

    As a first step, try first saving the .xlsb file as .xlsm, then see if that loads OK into MSO 2013.

    zeddy

  3. #3
    Gold Lounger Maudibe's Avatar
    Join Date
    Aug 2010
    Location
    Pa, USA
    Posts
    2,754
    Thanks
    129
    Thanked 692 Times in 628 Posts
    Bonriki,

    Try holding down the shift key while opening the workbook. This will bypass any macros and may allow the workbook to load. Then you may be able to troubleshoot or try Zeddy's solution. Once open, you may want to check to make sure all your libraries are referenced (VB Editor > Tools > References...)

    HTH,
    Maud
    Last edited by Maudibe; 2015-04-20 at 06:02.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •