Results 1 to 14 of 14
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Ontario Canada
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts

    DNS keeps changing on startup

    Whenever I boot up my Win 7 computer I have to wait for internet connection while DNS keeps changing and finally it connects. I have been able to document the changes from 192.168.2.1 to feeO:0:0:0ffff::1 then to feeO:0:0:0ffff::2 and then to feeO:0:0:0ffff::3. In a later boot it does the same routine only in reverse.

    I have a Qualcomm Atheros AR946X wireless network adapter installed. Anyone any ideas as to what is taking place here and how I might fix it so that I don't have to wait and wait for an internet connection. All drivers are up to date.

    TIA
    Fanleaf

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    What are the DNS settings in the router - are they your ISP's and greyed out ?

    You could try any of these in your computer's network adapter's Properties/(TCP/IPv4) Properties after pinging each to see which is the best http://public-dns.tk/nameserver/ca.html or use DNS Jumper to do it for you with it's selection of best DNS servers. http://www.sordum.org/7952/dns-jumper-v1-0-6/

    Generally as a test, people use either Google's 8.8.8.8 / 8.8.4.4 or Open DNS 208.67.222.222 / 208.67.220.220 either in their computer or router, but if you change them in your router, then the computer must be set to auto DNS servers.
    Last edited by Sudo15; 2015-04-21 at 12:00.

  3. #3
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,172
    Thanks
    47
    Thanked 981 Times in 911 Posts
    Your DNS should be set by DHCP along with your IP. The DHCP server is generally in you router. Is this your set up?

    cheers, Paul

  4. #4
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    Just wondering if power cycling the router would sort it.

    Also in IE - Tools - Internet options under the Connections tab/LAN settings, is just the top box checked and nothing for the Proxy Server one ?

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Ontario Canada
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Sudo 15 - Thanks for this. I have tried setting up both of Google's DNS and also open DNS on my router but none will work. I'll try the TCP/IPv4 ( on my computer)tonight and let you know
    Thanks,
    fanleaf

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Ontario Canada
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks Paul T. DHCP is set up in my router to assign IP addresses to LAN DHCP clients. The router/modem is a bell2wire and seems very picky about any changes.

    Fanleaf

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Ontario Canada
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Sudo 15 Have power cycled my router many times but same result. Nothing in the proxy area of IE. Do you have any idea what feeO:0:0:0ffff::1 refers to. (See my original post)
    Fanleaf

  8. #8
    jwoods
    Guest
    Quote Originally Posted by fanleaf View Post
    Sudo 15 Have power cycled my router many times but same result. Nothing in the proxy area of IE. Do you have any idea what feeO:0:0:0ffff::1 refers to. (See my original post)
    Fanleaf
    It looks like an IPv6 address.

    Check you network adapter settings and see if IPv6 is on and IPv4 is off...

  9. The Following User Says Thank You to jwoods For This Useful Post:

    Fascist Nation (2015-04-22)

  10. #9
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,486
    Thanks
    284
    Thanked 574 Times in 478 Posts
    Also check whether your ISP actually supports IPv6 yet.

  11. #10
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    Sometimes when IPv6 is enabled it can conflict with IPv4 and you end up with no connection as you get an IP address conflict.

    Routers tend to have IPv6 unchecked by default but you can check that on your own router and unchecking IPv6 in the computer's adapter's Properties can also help, but being default checked along with IPv4 only rarely causes problems.

    Can you open a command prompt and enter ipconfig /all > 0 & notepad 0 then copy & paste the Notepad file and post the output.

    When DHCP starts having problems and everything else seems to check out, checking for and updating the router's firmware will normally resolve but save the existing config first should there be a firmware update available.

    If there isn't a firmware update then factory resetting the router would be the next best step, but I'd also check Event Viewer to see if any associated services are having problems starting.

  12. #11
    New Lounger
    Join Date
    Dec 2009
    Location
    Ontario Canada
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Sudo 15 Well i checked event viewer and there are a ton of warnings as follows:
    Name resolution for the name dns.msftncsi.com timed out after none of the configured DNS servers responded.

    Also there were a ton of Errors as follows:
    Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0x260A642AE96B. The following error occurred: 0x79. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

    I presume they are all connected as they have the same date/timestamp. I cannot find anything on my Bell2wire modem/router referring to IPv6.

    Here is the info from ipconfig (I entered * for host name):
    Windows IP Configuration

    Host Name . . . . . . . . . . . . : ***********
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Broadcast
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : gateway.2wire.net

    Ethernet adapter Bluetooth Network Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network) #2
    Physical Address. . . . . . . . . : 24-0A-64-1D-40-07
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
    Physical Address. . . . . . . . . : 26-0A-64-2A-E9-6B
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : gateway.2wire.net
    Description . . . . . . . . . . . : Qualcomm Atheros AR946x Wireless Network Adapter
    Physical Address. . . . . . . . . : 24-0A-64-2A-E9-6B
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::e824:5294:9842:cdcb%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.2.15(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Wednesday, April 22, 2015 11:41:41 AM
    Lease Expires . . . . . . . . . . : Saturday, April 25, 2015 11:41:43 AM
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1
    DHCPv6 IAID . . . . . . . . . . . : 606341732
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-6E-9A-E2-D8-50-E6-52-8F-87
    DNS Servers . . . . . . . . . . . : 192.168.2.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : gateway.2wire.net
    Description . . . . . . . . . . . : Intel(R) Ethernet Connection I217-V
    Physical Address. . . . . . . . . : D8-50-E6-52-8F-87
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 10:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:1c2d:3023:b9e4:40c7(Preferred)
    Link-local IPv6 Address . . . . . : fe80::1c2d:3023:b9e4:40c7%17(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.gateway.2wire.net:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : gateway.2wire.net
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{AEC75EF1-B21B-4C54-AE85-A830408488DA}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{A5BCB975-F7ED-4C8D-A690-309707C488C5}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes


    Hope the above might be of use to you as you obviously have much more experience than I.
    Thanks kindly for your help.
    Fanleaf

  13. #12
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    I see what's happening - it's trying to assign an IP address to the WiFi Miniport adapters.

    Open a command prompt as an admin and enter netsh wlan set hostednetwork mode=disallow and this will uninstall the WiFi Miniports.

    To reinstate them just redo the command and change disallow to allow.

    If you ever reinstall the Atheros wireless driver you will have to repeat the command as that auto reinstates them - at least it does with my Realtek.

    You can also delete those incremented MS ISATAP Adapters (as you only need the original), by going into Device Manager/View/Show hidden devices and expand Network adapters - Windows creates a new one whenever it has problems connecting.

    Right click on each, select Uninstall and confirm.
    Last edited by Sudo15; 2015-04-22 at 13:51.

  14. The Following User Says Thank You to Sudo15 For This Useful Post:

    fanleaf (2015-04-24)

  15. #13
    New Lounger
    Join Date
    Dec 2009
    Location
    Ontario Canada
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks Sudo 15. That worked perfectly. I would not have been able to figure that out on my own.
    Fanleaf

  16. #14
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    Glad that worked for you and thanks for the update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •