Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Morganville, New Jersey, USA
    Posts
    318
    Thanks
    25
    Thanked 3 Times in 3 Posts

    PhotoSmart S20 installation

    I had an HP PhotoSmart S20 scanner attached to my PC, and it worked fine under Win Me. After reformatting the disk and installing Win XP, however, I have not been able to get it to work (I knew from the pre-install scan that it would not be automatic, unlike my HP flatbed scanner). I first tried installing the updated driver from HP's web site, and that did nothing. I then ordered from HP the updated, XP-compatible scanner software and installed it. The software starts, but then says that the scanner is not visible. Any clues? Should I uninstall the software, remove the scanner from the PC, reinstall the software, and then connect the scanner? Some other approach?

    Thanks.

    globalist

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: PhotoSmart S20 installation

    If this is a USB scanner did you install the twain driver?

    Also go to system properties and see if there is a hardware problem.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Morganville, New Jersey, USA
    Posts
    318
    Thanks
    25
    Thanked 3 Times in 3 Posts

    Re: PhotoSmart S20 installation

    It is a USB connection, and the hardware "details" listing shows a problem. The error message in the USB listing is "Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)". This could come from my having installed the updated driver before I had the program installed. In fact, the driver always installs (if I delete and reinstall) at the C:/ps803 directory level, rather than with the other system drivers. [The window that might give an option goes by so quickly that I cannot even be sure what it says.]

    Is this enough to give an indication as to what I should try next?

    HP has responded to absolutely none of my e-mails or other inputs, so they clearly don't care about their small customers. So I need people like you to guide me here.

    Thanks.

    globalist

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: PhotoSmart S20 installation

    Some of the newer USB devices like scanners and printers need the driver and software to be installed before the hardware. Remove all of the drivers and then remove the hardware. Reboot the machine, install the sotware and then plug in the scanner and windows should find new hardware.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  5. #5
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Morganville, New Jersey, USA
    Posts
    318
    Thanks
    25
    Thanked 3 Times in 3 Posts

    Re: PhotoSmart S20 installation

    Dave,

    Thanks for your advice. I had tried the removal and reinstall in software > hardware order, but I still cannot get the USB link between PC and the HP PhotoSmart S20 scanner working.

    Everything seems to be going fine, until I get a message that communication with the scanner was lost (I doubt that it was ever there, since my XP upgrade). If I go to the device manager, the USB link to this scanner (but not any other device) is highlighted. Double-clicking or looking at properties tells me that "Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory (Code 38)" If I ask that the driver be upgraded, the "upgrade" starts but stops with an error message "There was a problem installing this hardware: HP PhotoSmart C5101A - S20. An error occurred during the installation of this device. The name is already in use as either a service name or a service display name." Checking the device driver properties now says that the driver is not installed. Reinstalling it from the file HP provides for the upgrade to Win XP returns me to the prior situation (with the earlier error message).

    Initially I tried this with the USB link through a 4:1 bridge. However, I retried all of this using a direct USB link, with precisely the same results.

    Any further thoughts?

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •