Results 1 to 7 of 7
  1. #1
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    262
    Thanks
    0
    Thanked 0 Times in 0 Posts

    attrib set to read only

    Somehow when I transferred all my files to a new computer (using Xcopy and Zip disks) they all got set to read only. Is there some way I can change these thousands of file back? They are in various subdirs, but are all on a single drive which only has data files on it. Thanks!

  2. #2
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: attrib set to read only

    Since you're running 98, do it in DoS (or Dos-in-Windows) From the root of the disk in question type 'attrib -h -r *.* ' (without the quotes). This will remove all attributes from all files in the root, except system files (for that you need -h -r -s). You need to remove the h(idden) attribute or DoS won't find them. If you really feel you need hidden files, put it back on those that require it.

    Rgds

  3. #3
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    262
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thx but that doesn't really help...

    There are hundreds of subdirs -- I need a way to sweep thru all of them w/ the attrib command -- or another way to operate on all files at once.

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Thx but that doesn't really help...

    Hi Randy:
    Do you have File Manager, from Win 3x? Go to Start/Run & type winfile & press <enter>. If you have it, you can select directories & change their attributes in one fell swoop by selecting the directories & going to File/Properties & then ticking or unticking the read-only attribute. And you thought Windows Explorer was an improvement. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

  5. #5
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Thx but that doesn't really help...

    ..sorry. Missed the subdirectories. I think that Power Desk (freeware) should do what you want, if winfile.exe is not an option.

    Rgds

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Thx but that doesn't really help...

    Attrib will quite happily act on all the sub directories.
    <pre> attrib -r /s *.*
    </pre>

    StuartR

  7. #7
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Thx but that doesn't really help...

    Didn't know that. Many thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •