Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Jul 2013
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Printer not installed message on wifi

    Was not sure if this should be a hardware question or OS. We have a Epson XP-322, which has been working via wifi for the PC( running XP) and for my ipad and phones. Yesterday it failed to print a very short, simple Word document from the PC, with the error messages saying that no printer was installed. Looking from the start menu to Printers and Faxes, the printer is shown there, with a tick showing it to be the default. When I tried again and followed through to the properties box, it first of all showed no default, then listed the printer, which I tried to get to set as the as default, but it would not stay there when the dialogue box is shut. The printer was set up ( automatically) from the beginning to work over wifi (ie has never linked to the PC via cable as it is in an awkward position , though near the wifi router.) If I tried to print from Word,or Outlook or a web page, it kept showing that there was no printer installed.

    It continued to print perfectly well on wifi from my ipad, either via Airprint or the Epson iprint app. The wifi signal is strong and consistent and is working well for my ipad and for my samsung phone.

    The PC is otherwise working well.



    I did the following:

    Checked whether it would print from Notepad - yes
    Checked the software and firmware update for the printer
    Cleaned the head (helped the print quality)
    Uninstalled and reinstalled the driver.

    It is recognised it somehow over wifi because it it gave the command to the printer to do a nozzle check and to print the test sentence from Notepad.

    I then found the never previously linked cable, set the port as USB001 and plugged into the USB1 and hurrah, it printed form word and from Outlook. Not a permanent solution because the PC and the printer are in the only places they can be (space constraints) and the cable is threatening to strangle me....!

    If I unplug the cable and try and print now on the PC, it is saying it is offline and is showing that way on the start menu. I seem to have made matters worse, as it will now not print from Notepad via wifi.

    Any thoughts ?

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,175
    Thanks
    47
    Thanked 982 Times in 912 Posts
    Most likely the printer has changed IP address and your machine has not caught up.
    Look i Control Panel at the Printer Properties (right click on the printer) and check the Ports.
    You will see a port with a tick and this will have an IP address.
    Put the IP address in the browser address box and press Enter.
    If you get no response the IP address of the printer is not the same as it was when you first installed the printer.
    Delete the port, select FILE: Print to File and click OK.
    Now delete the printer.
    Re-install the printer and all should be well.

    cheers, Paul

  3. #3
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,610
    Thanks
    147
    Thanked 870 Times in 832 Posts
    Not sure why it's no longer recognised but have you tried re-entering the WiFi password into the printer's control panel or assigning a static IP address to the printer ?

    On the odd occasion when I've had problems with my Epson SX425W I've reinstalled the drivers so it may be worth reinstalling the Network and driver package for yours.

    http://www.epson.co.uk/gb/en/viewcon.../support/13671
    Last edited by Sudo15; 2015-05-22 at 06:31.

  4. #4
    New Lounger
    Join Date
    Jul 2013
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you both for taking the time to respond. Rather than repeatjust the driver reinstall that I did before, I completely reinstalled everything from the CD and this time it appears to have worked - faster response than before, in fact. I am hoping that the reinstall of the scanner driver may also improve that (works ok via the Epson iprint app but via the pc it was clunky) . I am not uncrossing my fingers yet that everything is permanently solved as, during the firmware update section, the 'you are not connected' dialogue box came up - worked on a retry.

  5. #5
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,610
    Thanks
    147
    Thanked 870 Times in 832 Posts
    It could still be worth assigning the printer with a static IP but if the printer's NIC is playing up, it could eventually fail to pick that up and you'll get the "not connected" again.

    EDIT - If your router has an USB port you could try wiring the printer directly to the router, if practical but if a hardware problem is developing on the printer then it may still fail to communicate with your pc.

    It's advised when naming your computer that it's best to use an alphanumeric name as printers find that easier to ID the target computer.
    Last edited by Sudo15; 2015-05-22 at 12:46.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •