Results 1 to 3 of 3
  1. #1
    5 Star Lounger Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    620
    Thanks
    166
    Thanked 77 Times in 68 Posts

    Formatting longer numbers as text gives the 'E' expression

    Seems to happen with longer numbers--my test says for over 11 digits. Clearly it makes sense for very long numbers, but it's not behavior I want. How do I disable it?

    "the 'E' expression" meaning something like...
    9.87654E+12
    Last edited by Lugh; 2015-07-02 at 02:13. Reason: getting E expression to show

  2. #2
    Bronze Lounger
    Join Date
    Jan 2001
    Location
    La Jolla, CA
    Posts
    1,470
    Thanks
    30
    Thanked 62 Times in 58 Posts
    You can change the number with lots of digits to text (e.g., begin with a single quote).
    You can still calculate using the long number, but the answer will possibly show up again in scientific notation.

    You cannot turn off scientific notation as far as I know.
    However, you can right-click the cell and format it as a NUMBER and the scientific notation will go away.

  3. #3
    5 Star Lounger Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    620
    Thanks
    166
    Thanked 77 Times in 68 Posts
    Thank you again kweaver. I'd tried the single quote but it didn't work as expected. I since discovered it's because of different formats in the source columns of numbers. Once I found and cleaned that up, the single quote works just fine.

    "scientific notation" Yes that's it, couldn't remember what it's called. Formatted as a table in my post at first after pasting, that's why the expression example didn't show until I edited it just now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •