Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Oct 2013
    Location
    UK
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Long time opening WiFi connection at startup

    Hi
    I am running 64 bit Windows 7 Sp1 on a three year old Acer laptop - which has been reloaded on two or three occasions.

    Even though I have removed quite a number of entries from Startup, the laptop takes an inordinate time to boot - up to 8 minutes.

    However, recently I have noticed that for a considerable portion of this time, the WiFi network icon in the system tray shows as being unavailable and is overlaid with the spinning 'waiting' cursor. During normal operation I have a very fast connection and experience no issues, so I do not think this is a network problem as such.

    Does any Lounge member know whether this network unavailability may be causing this long wait, or does Windows simply delay opening the connection until the boot process is largely completed?
    Thanks
    Dave

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Do you have any network disk drives or other computers which are not available when you boot?

    Have you tried a clean boot?

    Joe

  3. #3
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,607
    Thanks
    147
    Thanked 869 Times in 831 Posts
    You could check Event Viewer to see if there are any DHCP or related errors.

    The delay could be because of your ISPs DNS servers or it could be because DHCP is trying to assign an IP address to the MS Virtual Miniports.

    If you don't use VPN then you don't need the Miniports and to check if you have them, go Start - type devmgmt.msc and press enter.

    Click on View/Show hidden devices and expand Network adapters.

    I forget now what the error would be in Event Viewer if it was trying to assign an IP address to the Miniport but if you have it listed and want to get rid of it to see if that is the cause, run a command prompt as an admin by going Start - type cmd then right click on cmd and select Run as administrator - accept the UAC then enter -

    netsh wlan set hostednetwork mode=disallow

    and you can use allow to re-enable it if needed.

    As for the DNS servers, go Start - type ncpa.cpl - press enter then right click on the Wireless adapter and select Properties.

    Click on (TCP/IPv4) then on Properties.

    Click on the lower DNS button and in the top row of boxes enter 8.8.8.8 and 8.8.4.4 in the lower row.

    Click on Validate upon exit - OK - Close and if the trouble shooter says it can't find anything wrong, then you are good to go.

    Reboot after disabling the Miniport and then after changing the DNS servers to see if either make any difference.

    Sometimes it takes a driver refresh to resolve which you can do by going into Device Manager/Network adapters - right click on the wireless driver and select Uninstall - but do not check the box to include software, otherwise you will need to download the driver afresh.

    Click on Action/Scan for hardware changes or close Device Manager up and reboot where the driver will be reinstated.

  4. #4
    5 Star Lounger
    Join Date
    Oct 2013
    Location
    Phoenix, AZ
    Posts
    926
    Thanks
    554
    Thanked 137 Times in 128 Posts

  5. #5
    New Lounger
    Join Date
    Oct 2013
    Location
    UK
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thanks for your replies - it will take me a little time to go through them before I give you an update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •