Results 1 to 6 of 6
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    Bethesda, MD, USA
    Posts
    57
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Outlook 2007 can't send on Comcast (Worked fine on Verizon)

    I have a friend who has had to switch to Comcast (poor girl!) from FiOS, and she cannot get Outlook 2007 to send email—it worked fine on Verizon’s network. She can receive, but can’t send. She has gone over and over the settings with Comcast’s “tech support” to no avail.


    The error message she gets is:

    "The server you are connected to is using a certificate that cannot be verified.
    The target principal name is incorrect. [certificate = mail.comcast.net]
    Do you want to continue using this server? yes/no"

    Anyone know of a solution (other than upgrading)?
    Henry S. Winokur
    PC .HLP Computer Consulting -- Supporting family & SOHO Windows users in the DC area since 1990
    Bethesda, MD

  2. #2
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,078
    Thanks
    0
    Thanked 259 Times in 248 Posts
    An issue when connected to an ISP but the sending address in Outlook or any other E-Mail Client has to be the same as for the logged in service, i.e. must be joe@comcast.net instead of joe@verizon.net, those are just examples but it's called Relaying [sending from one account when logged in to a different service], prohibited by most ISPs. One issue that nearly drove me bonkers was the lady's poor monitor, hard to tell that she had typed a comma instead of the required period.

  3. #3
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,795
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Try setting your outgoing mail server to smtp.comcast.net rather than mail.comcast.net If that doesn't work, contact Comcast support.

    Jerry

  4. #4
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,752
    Thanks
    171
    Thanked 650 Times in 573 Posts
    Sounds like a Comcast redirection issue to me. It should be possible to click Yes each time until they get their act together though.

    I use Outlook 2007 through Comcast, set up in accordance with their instructions here: Configure Outlook 2007 for Comcast Email
    Last edited by BruceR; 2015-07-24 at 22:15. Reason: url

  5. #5
    Star Lounger
    Join Date
    Dec 2009
    Location
    Bethesda, MD, USA
    Posts
    57
    Thanks
    0
    Thanked 0 Times in 0 Posts
    We have followed all of Comcast's instructions. They don't seem to be able to answer where one gets the referred to certificate or how to install it.... ;-(
    Henry S. Winokur
    PC .HLP Computer Consulting -- Supporting family & SOHO Windows users in the DC area since 1990
    Bethesda, MD

  6. #6
    Star Lounger
    Join Date
    Dec 2009
    Location
    Bethesda, MD, USA
    Posts
    57
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Did that.

    Comcast's "tech support" has been given ample opportunity to fix the issue. They CAN'T. Their "tech support" is some of the worst out there. They can't seem to find their way out of a wet paper bag and they don't care.......
    Henry S. Winokur
    PC .HLP Computer Consulting -- Supporting family & SOHO Windows users in the DC area since 1990
    Bethesda, MD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •