Results 1 to 14 of 14
  1. #1
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Word punctuation problem

    Hi forum members.

    I have a very strange problem with a few word documents. At the end of the sentences, there are full stops, commas or semi colons normally followed by a space.

    But some (not all) sentences have these punctuation reversed. That is, word space punctuation but if I move the cursor step by step with the keyboard arrows, it jumps at the correct sequence, though it shows reversed (and prints reversed)!!!


    Find/replace does not correct obviously, the problem. I have to place the cursor on letter from the end of a word, write that leeter and the following puncuation and then delete the offending characters manually.

    Any ideas?

    Ioannis

  2. #2
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,049
    Thanks
    124
    Thanked 119 Times in 116 Posts
    It isn't obvious to me that find and replace does not fix the problem.
    Replace " ." with ". " and so forth.
    Charles Kyle Kenyon
    Madison, Wisconsin

  3. #3
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Charles Kenyon View Post
    It isn't obvious to me that find and replace does not fix the problem.
    Replace " ." with ". " and so forth.
    No it does not work, because the sequence is "right" but it displays wrong.

    Do the Find/Replace really does not see the space-dot. It sees the dot-space, but the screen shows space-dot.

    Also, the cursor (moving it with the arrows) also jumps right then left then to the next word!

    Ioannis

  4. #4
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    Is this related to a language setting with a document language that runs right-to-left instead of the english left-to-right?
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  5. #5
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Andrew Lockton View Post
    Is this related to a language setting with a document language that runs right-to-left instead of the english left-to-right?

    I really can't say because the system and the text are left-to-right and only few dit-space or comma-space (and few others) are reversed viewed and printed. It is very strange indeed. The funny thing is that using the arrows on the keyboard, the cursor jumps first to the correct character then back to space then to te one next to the space character (back and forth, that is).

    As I stated above, if I correct them manually than all is good.

    I attach a small portion of the document to review it.

    Ioannis
    Attached Files Attached Files
    Last edited by Ioannis; 2015-08-03 at 02:57.

  6. #6
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Ioannis,

    Not sure if this addresses your issue but... can you simply copy and paste the two characters from your document into find and replace, then replace with the characters you want? You don't have to know what they are, but hopefully Word will.

    I take it back... Word doesn't seem to know what it is, but I think it must have something to do with the right-to-left setting in the document. Backspace and Delete work the opposite to what they normally do on my left-to-right settings. Still, if your computer is set to handle this language, then my suggestion may still work. If it doesn't, perhaps the "space" is another non-printing character altogether?
    Kim
    Last edited by kmurdock; 2015-08-03 at 12:30. Reason: Additional comment

  7. #7
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    Well ain't that a weird one. Without determining what causes the problem it looks easy enough to fix. If I copy that paragraph and then do a Paste Special as Unformatted text then I get a paragraph that behaves normally and flips those characters to the way they should be.

    We can probably work out what is the cause if we examine the html, xml or rtf versions of the document but the quick fix is going to get around it so you can move on. I note that the default paste format is html so that might be a clue as to where the issue is coming from.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  8. #8
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    I had a further look at the problem content and it is definitely language related. If I select those two characters I can see in the status bar that it is spell checked in Hebrew but the words around them are spell checked in Greek. The quick fix of paste special as text only seems to be the best way to solve the problem since the other things I'm doing don't seem particularly successful perhaps because I don't have the relevant languages loaded on my machine.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  9. #9
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Andrew. Yes, now I see that the specific characters are in Hebrew. Unfortunately te Find/Replace cannot find this specific lanquage! So, replace cannot find it...

    The copy and special paste is a fix, but I loose all formating that way. I'd rather find another solution.

    Thanks to all that replied.

    Ioannis

  10. #10
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    This seems to work

    Select your content
    Open the VBA Editor by pressing Alt-F11
    Open the Immediate Window in the VBA Editor by pressing Ctrl-G
    Type the following line in the Immediate Window and then press Enter
    Selection.LtrRun
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  11. #11
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Andrew.

    Did that and it works!

    Thanks again,
    Ioannis

  12. #12
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Where can one find what what functions do in VBA?

    I really like and want to learn how to use such tools.

    Thanks again Andrew, you were very helpful,
    Ioannis

  13. #13
    New Lounger
    Join Date
    Aug 2003
    Location
    Canton, Michigan, USA
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Glad you found a solution!

    This article
    https://en.wikipedia.org/wiki/Bi-directional_text
    may give a bit more insight into the LTR vs. RTL conflict.

  14. #14
    New Lounger
    Join Date
    Jun 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I opened the doc and got something interesting

    Quote Originally Posted by Ioannis View Post
    I really can't say because the system and the text are left-to-right and only few dit-space or comma-space (and few others) are reversed viewed and printed. It is very strange indeed. The funny thing is that using the arrows on the keyboard, the cursor jumps first to the correct character then back to space then to te one next to the space character (back and forth, that is).

    As I stated above, if I correct them manually than all is good.

    I attach a small portion of the document to review it.

    Ioannis
    I just wanted to let you know that I opened the doc and the text I saw was in, I think, Greek. I used Libre to do it. Is it possible that your font is corrupted? Just my penny and a half.




    Cheers, Bob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •