Results 1 to 12 of 12
  1. #1
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Security Update .NET KB2894854 (W2k8R2) insistently returns

    Esteemed readers
    After updating multiple times a server with W2k8R2, the Security Update for .NET KB2894854 becomes available over and over again in WU (control panel). Why is this happening?
    Apparantly .NET version installed is 4.5.52022.

    Thanks for your time.

    Faithfully,
    Ivan

  2. #2
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,752
    Thanks
    171
    Thanked 650 Times in 573 Posts

  3. #3
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Arrow My apologies

    Esteemed experts
    Sorry, it didn't pass on my mind it should be avoided to post same topic on multiple boards. Are these applicable to other forums as well or just windowssecrets ? I really didn't realize I would take away some time and effort from people who try to answer, as excelguru states. I will try to delete the others posts. all right and also, if we can work this out, here is the link to first post.

    Best

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Sounds like a corrupted .NET install. If you don't need .NET 4.5 uninstall it and block the updates.

    Joe

  5. #5
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Arrow .NET, Server Manager - Features

    I can't see a row with .NET in Programs and Features, except for 'Microsoft .NET Framework 4.5.1 Hotfix Rollup (KB2925382)' and viewing Features node in Server Manager, I find '.NET Framework 3.5.1'.

    Checking the Registry keys, I find .NET version installed is 4.5.52022.

    This is odd, doesn't it?

    Joe, I use .NET, so can't uninstall it.

  6. #6
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Which version do you use?

    .NET 4.5 is relatively recent. Not much requires it.

    Joe

  7. #7
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I use .NET 4.5.
    What it has to do if it requires or not the newest version?
    I use it here for database class generation.
    Shall we back to my problem ?

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

  9. #9
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Arrow

    Isn't odd Microsoft .NET 4.5 isn't listed anywhere in Program and Features (control panel) and Features (server manager) ?

  10. #10
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 986 Times in 916 Posts
    Try a repair installation of .NET.

    cheers, Paul

  11. #11
    New Lounger
    Join Date
    Aug 2015
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Arrow

    Actually it has 'Microsoft .NET Framework 4.5.1 Hotfix Rollup (KB2925382)' in Program and Features and '.NET Framework 3.5.1' in Server Manager Features node.
    How to repair/uninstall if I can't see it?

  12. #12
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 986 Times in 916 Posts
    As you only have 3.5 the hotfix is probably confused. You can hide the update by right clicking on it.

    cheers, Paul

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •