Results 1 to 14 of 14
  1. #1
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,421
    Thanks
    124
    Thanked 5 Times in 5 Posts

    Microsoft Excel has stopped working

    When running a large macro in Excel , that copies data into several folders, I get a message "Excel has stopped working"


    I never had this problem with Windows 7, but this happens on Windows 10. I have 12GB of Ram


    It would be appreciated if someone could kindly advise on how to resolve this

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,171
    Thanks
    19
    Thanked 99 Times in 88 Posts
    Not much to go on.

    Are you certain that it's frozen? Windows will often report that a program is "Not Responding" if it's busy doing something.

    When you say, "copies data into several folders", what do you mean by that? I assume you are using some kind of VB script, is it using a utility or strictly DOS commands?

    Are you positive that the folders you are copying to actually exist? Even a typo can create a problem.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  3. #3
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,421
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Hi Graham

    Thanks for the reply

    I am using VB script to copy CSV Files into their respective folders. Never had a problem before upgrading to Windows 10. I closed excel completely and re-ran the macro and then it worked

    When running the macro the first time, the excel file closed down completely after getting the message "Excel has stopped working"

  4. #4
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,171
    Thanks
    19
    Thanked 99 Times in 88 Posts
    How strange, but it wouldn't be the first time I've encountered strange. Some days, strange is my middle name.

    Just out of curiosity, why 12GB of memory? I wouldn't think anything could use that much RAM - even a memory hog like Excel.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  5. #5
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,421
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Hi Graham

    I have done some research and Office 2010 32 bit, can only use a max of 2GB of Ram and 64 bit can use a lot more

    See link below

    http://www.pcstats.com/NewsView.cfm?NewsID=115767

  6. #6
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,171
    Thanks
    19
    Thanked 99 Times in 88 Posts
    It rather sounds like Excel is one of the few programs that can really make use of that much memory. Seems strange to me since I routinely work with huge databases that work just fine with 4GB.

    But then Excel was always gobbling up everything it could lay hands on. Guess if you are going to work with big spreadsheets the extra memory is going to be helpful.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  7. #7
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,421
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Hi Graham


    I will let you know the outcome once I have installed the 64 bit version of Office


    This will be done next Friday


    Regards


    Howard

  8. #8
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,171
    Thanks
    19
    Thanked 99 Times in 88 Posts
    Thanks Howard. Interested to hear what you find out.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  9. #9
    Gold Lounger Maudibe's Avatar
    Join Date
    Aug 2010
    Location
    Pa, USA
    Posts
    2,639
    Thanks
    115
    Thanked 650 Times in 592 Posts
    Windows will often report that a program is "Not Responding" if it's busy doing something
    Howard,

    As long as you have a 64bit OS and a relatively modern motherboard to accommodate it, the more RAM the merrier. More RAM enables you to have more background processes and applications running simultaneously from within RAM without the need to tap into your hard drive as virtual memory. However, one pitfall with having a battalion of applications running simultaneously is that the chances of one of these apps using an area of memory that Excel wants to use increases. An example is TeamViewer or some background antivirus functions that do not play well with a macro-intensive Excel Spreadsheets. If you are receiving repeated non-code errors then close down some programs and try again.

    If your error continues, be aware of the dreaded never ending Worksheet_Change event loop caused by some poorly written code in this event that makes a sheet change and triggers the event within the event. Use of the Application.EnableEvents code lines might resolve this. Additionally, large nested loops are processor hungry and can tie up computer resources. These are just a couple of the scenarios that gsmith was referring to.

    HTH,
    Maud

  10. #10
    WS Lounge VIP
    Join Date
    Mar 2002
    Location
    Newcazzle, UK
    Posts
    2,829
    Thanks
    136
    Thanked 482 Times in 459 Posts
    Hi Howard

    I think it is very brave of you to install the 64-bit version of Office.
    I posted this two years ago (2013-09-15) on this forum:
    By default, Microsoft Office installs the 32-bit version of Office even if your computer
    is running 64-bit editions of Windows. There is a good reason for this.
    Mainly, it's because there aren't many 64-bit versions of ActiveX controls available.
    And existing 32-bit ActiveX controls don't work with Office-64-bit.
    You should also need to be aware that running any VBA code that was written before the Office 2010 release (i.e Excel 2007 vba or earlier ) on a 64-bit platform can result in errors if the code isn’t changed to run in 64-bit versions of Office.

    Personally, I don't think your issue has anything to do with the 2GB Excel limit.
    I suspect your issues are with other processes running when you are running that Excel macro.
    I would suggest you try running the macro again on a less busy day.

    zeddy

  11. #11
    Gold Lounger Maudibe's Avatar
    Join Date
    Aug 2010
    Location
    Pa, USA
    Posts
    2,639
    Thanks
    115
    Thanked 650 Times in 592 Posts
    Howard,

    I would revert back to the 32 bit version of Office. If you are determined to keep the 64bit version, you will undoubtedly run into errors. Get to know the PtrSafe keyword and read this Microsoft article that reinforces the points zeddy makes.

    https://msdn.microsoft.com/en-us/library/ee691831.aspx

    Also note that with many of the changes you need to make to enable your code to run on 64bit Office, it will make it no longer be compatible with 32bit office.

  12. #12
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,421
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Thanks Maud & Zeddy for your input

    On Tuesday instead on selecting the form button linked to the macro, I clicked on the macro and the macro ran without any problems. When I clicked on the form control button linked to the macro, Excel closed down, but not sure why this would cause the problem

  13. #13
    WS Lounge VIP
    Join Date
    Mar 2002
    Location
    Newcazzle, UK
    Posts
    2,829
    Thanks
    136
    Thanked 482 Times in 459 Posts
    Hi Howard

    ..are you now using 64-bit Excel?? Is it a 32-bit activeX form control????


    zeddy

  14. #14
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,421
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Hi Zeddy

    Based in your and Maud's input, I have decided to stay with 32 bit-Office

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •