Results 1 to 12 of 12
  1. #1
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts

    Connect phone new drive letter

    When I plug my Nexus 5 Android phone into my Win 8.1 desktop via the USB cable, I no longer get a file explorer window open with the phone as a new drive letter.

    I've tried going to Device Manager and scanning for new hardware but that does nothing.

    Anyone have any ideas on how to fix/restore this functionality?

  2. #2
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    I would first try a different cable.
    David

    Just because you don't know where you are going doesn't mean any road will get you there.

  3. #3
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,161
    Thanks
    19
    Thanked 99 Times in 88 Posts
    If you used to get a connection, then the question is what changed before you stopped getting it?
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,180
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Have you changed the Android so it's not in "mass storage mode"?
    https://support.google.com/nexus/ans...40804?hl=en-GB

    cheers, Paul

  5. #5
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by gsmith-plm View Post
    If you used to get a connection, then the question is what changed before you stopped getting it?
    That's a good question! And unanswerable. Let's see - Probably a couple of Android OS updates and a whole lot of Win 8.x updates to start with. I've probably gotten 5 Android updates in the last 2 months. And who knows how many Windows updates.

  6. #6
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by wavy View Post
    I would first try a different cable.
    Made no difference.

  7. #7
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by Paul T View Post
    Have you changed the Android so it's not in "mass storage mode"?
    https://support.google.com/nexus/ans...40804?hl=en-GB

    cheers, Paul
    Don't know anything about "mass storage mode" but the link you point to refers to a USB setting of "Media device (MPT)", which I tried turning off/on but which made not difference.

    This seems like one of those stupid Windows problems where Windows pops up a dialog window when you attach a new device asking what you want to do (like display a file explorer window). If you miss that prompt for some reason, then Windows defaults to something, which may no longer display a dialog when you plug a cable or new device in.

    So the question is, how to force Windows to bring the option dialog back?

  8. #8
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    Did you remove media player per chance?

    Do you get a message in the Android notification area?
    David

    Just because you don't know where you are going doesn't mean any road will get you there.

  9. #9
    New Lounger
    Join Date
    May 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Possibly the 8.1 automount feature to assign drive letters to external USB drives has been disabled. At the RUN prompt type in "diskpart" and run it. Then type in "automount" and run it. If it comes back saying automount disabled type in "automount enable" and run it. You should then be good to go. I experience this frequently on 7 and 8/8.1 machines.

    Richard

  10. #10
    New Lounger
    Join Date
    Jun 2011
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    This may be obvious, but have you turned the phone off and then back on? I have had plenty of occasions where my connectivity was flaky (WiFi, BT) but when I restarted things worked much better.

    Have you tried being in Device Manager (DM) before you plug it in to see if anything changes? Likewise when you unplug it? I have had several occasions where multiple plugging/unplugging sequences were required. Sometimes it would show up in DM but not as a recognized drive and therefore no drive letter. It's like it partially recognized it.

    If you can see that it shows up in DM but no drive letter you may want to "Uninstall" the device from within DM. Then try a scan for new hardware, hoping that this time it will load completely.

    Best wishes. It's not a 100% foolproof arrangement. Sometimes it works, sometimes it doesn't.

  11. #11
    Lounger
    Join Date
    Jan 2010
    Posts
    29
    Thanks
    0
    Thanked 3 Times in 3 Posts
    I have an older android, but on mine I have:
    settings-connect to PC- and 3 options under that. Charge only, Disk Drive and USB tethering. If I select charge only, then the phone is not detected as a usb drive,

  12. #12
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    Oh well we might have misplaced the OP
    David

    Just because you don't know where you are going doesn't mean any road will get you there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •