Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    South Africa
    Posts
    49
    Thanks
    0
    Thanked 0 Times in 0 Posts

    dpc_watchdog_violation

    I upgraded from 7 to 10 on my msi cr620 laptop. It starts 10, but if I touch the pad, it crashes with dcp_watchdog_violation

    I believe the problem is with the touchpad driver. If I connect a mouse, I think I can get past the bootup. What do I do then to fix this problem?

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,188
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Try starting Windows in safe mode and scan for a new driver or delete the existing one.

    cheers, Paul

  3. #3
    Lounger
    Join Date
    Dec 2009
    Location
    South Africa
    Posts
    49
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have deleted (uninstalled AND deleted files) from Device Manager. However, when I reboot (which windows tells me I have to), then before I can do anything, it reinstalls the same problematic driver. I downloaded a program fro MS called wushowhide.diagcab which is supposed to prevent automatic updates (I am running Win 10 Pro). However, it does not show the updated (bad) driver in update history so I can't selected it for hiding.

    Very frustrated. If I touch the touchpad even in error, Windows 10 crashes!!

  4. #4
    5 Star Lounger
    Join Date
    Nov 2010
    Posts
    665
    Thanks
    1
    Thanked 26 Times in 24 Posts
    I got these errors a heck of a lot until M$ patched a few times (and so did VirtualBOX; combination of the two ended my frequent watchdog issues). Try manually running updates (right-click on notifications in your toolbar then click all settings. You'll then see the option for updates). Also check which application or driver is causing this issue and see if there are any updates for them.

  5. #5
    Lounger
    Join Date
    Dec 2009
    Location
    South Africa
    Posts
    49
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I found the fix in a posting at last. Here it is:

    start your computer in safe mode. Please follow these steps.
    a. Type advanced startup in search box on the taskbar and click "Change Advanced startup options".
    b. Click "Restart now" and then click "Troubleshoot".
    c. Click "Adavanced options" and then click "Startup settings".
    d. Click "Restart".
    This is how I'm getting around the problem:
    Don't touch the Synaptics Touch Pad after the computer re-starts
    1. I'm now using an external wireless usb mouse
    2. Open "Device Manager"
    3. Expand "Mice and other pointing devices"
    4. Double click on "Synaptic Touch Pad"
    5. Click on the "Driver" tab
    6. Click on "Update Driver"
    7. Click on "Browse my computer for driver software"
    8. Click on "Let me pick from a list of device drivers on my computer"
    9. "Un-Check" the "Show compatible hardware" option
    10. In the Left window under "Manufacturer", I chose "Microsoft"
    11. In the Right window under "Model", I chose "PS/2 compatible mouse"
    12. Click on "Next"
    13. Close the "Mouse Properties" window
    14. Click on "Yes" to re-start your computer
    15. Problem solved. The Synaptics Touch Pad has full functionality plus I can also continue to use my external usb wireless mouse.

    This problem will re-surface when the next Build is installed on your computer. Follow steps 2, 3, 4 and 5.
    This time click on "Roll back Driver". Re-boot your computer. Problem Solved. Hope this helps...

  6. #6
    5 Star Lounger
    Join Date
    Nov 2010
    Posts
    665
    Thanks
    1
    Thanked 26 Times in 24 Posts
    So it appears to be a Synaptic's Touch Pad driver. I use a Logitech keyboard that has a built it pad (it works but I only use it for the keyboard; have a laser mouse). Still; you would think Synaptics would have updated the driver by now or M$ should have.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •