Results 1 to 5 of 5
  1. #1
    Lounger
    Join Date
    Dec 2007
    Location
    Sydney, New South Wales, Australia
    Posts
    37
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Visio 2007 with Office 365

    I installed Visio 2007 as a stand-alone application way back in 2007.

    I have had no problems in using it through various Office upgrades until I installed Office 365.

    Now when I start Visio it goes through the install process each time. No big problem - once it starts it functions normally. I only use it for creating simple Gantt Charts so I have no need to spend the money and upgrade to the latest version. But I'm curious as to why it must do this and is there any way of enabling Visio 2007 to start without it re-installing itself.

    Thanks.

  2. #2
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    2,153
    Thanks
    31
    Thanked 306 Times in 266 Posts
    Try repairing Visio.

    Go to "Start\Control Panel\Programs and Features". Click on Visio in the list of installed programs then click on the "Change" or the "Repair" button just above the list.

    If there is no "Change" or "Repair" buttons then click on "Uninstall". You should then see a dialog which has a "Repair" option.
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    AMD FX8120 (8-core @ 3.1GHz) CPU, Gigabyte GA-990FXA-D3 motherboard, 8GB (2x4GB) DDR3 1866MHz RAM, ATI-AMD Radeon HD6770 PCI-E VGA, 480GB Kingston SSD, 2TB Seagate SATA3.0 HDD, ASUS DVD/RW.

  3. #3
    Lounger
    Join Date
    Dec 2007
    Location
    Sydney, New South Wales, Australia
    Posts
    37
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the suggestion, Coochin.

    I went through the Repair process. But it didn't fix the problem. Visio still fires up the Windows Installer.

  4. #4
    Star Lounger
    Join Date
    Dec 2009
    Location
    Southern California
    Posts
    78
    Thanks
    1
    Thanked 8 Times in 8 Posts
    That's interesting. I've got Visio 2003 starting and running just fine on Windows 10.

  5. #5
    New Lounger Glitch's Avatar
    Join Date
    Jan 2010
    Location
    Warwick, NY USA
    Posts
    22
    Thanks
    1
    Thanked 3 Times in 3 Posts
    First check the compatibly setting for the Visio exe file. (Right click Properties > Compatibility tab). More than once I've found this mysteriously reset on some Office files on my clients computers suffering similar problems.

    If that's ok, then per MS Support:

    "A repair/reinstall of Visio would typically fix this automatically, as would allowing Visio to finish configuring. However, if the repair/reinstall/configuration does not complete successfully, the user will continue to receive this message at each launch of Visio. To manually fix this issue, run 'regedit' and manually change the value of [HKEY_CLASSES_ROOT\.vsd] to Visio.Drawing.11 (if using the Visio client) or VisioViewer.Viewer (if using the Visio Viewer)."

    I've found there are several registry keys in this section that will need to be changed. Also it appears this "fix" is for at least for Visio 2003, 2007, 2010 and Office 2003 thru 2010 and 360, maybe more.

    .../Glitch

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •