Results 1 to 12 of 12
  1. #1
    5 Star Lounger
    Join Date
    Jan 2002
    Location
    Midlothian, Virginia, USA
    Posts
    874
    Thanks
    0
    Thanked 2 Times in 1 Post

    Text not wrapping in forwarded message

    I'm using Thunderbird that was updated in the last week or so. When I receive a message on occasion and then try to Forward it with the original message included, the text of the original message does not wrap at the window edge. Each paragraph consists of one long line. It did wrap correctly when it was received. It was wrapped correctly when I received it. When I look at the forwarded message in the destination computer it still consists of long single lines that have not been wrapped correctly. I don't know what email program or procedure the message sender is using.

    Is there any setting I can change in my Thunderbird that will correct this problem?

    Thanks,
    Bill

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,188
    Thanks
    47
    Thanked 983 Times in 913 Posts
    You could look at the raw data, after saving it in Draft, to see what technique they use to produce the text. Select the message, in the preview pane select More > View Source.

    cheers, Paul

  3. #3
    5 Star Lounger
    Join Date
    Jan 2002
    Location
    Midlothian, Virginia, USA
    Posts
    874
    Thanks
    0
    Thanked 2 Times in 1 Post
    Paul, sorry for the delay in following up. It appears that the bad messages are probably all coming from iPads or maybe also tablets! I have been waiting for another message with this problem and one just arrived. I wasn't able to follow your advice on how to look at the hex characters -- I use Thunderbird. But I did use UltraEdit-32 that I use for this kind of thing. I selected the text in the message and used Copy and Paste to put it into a new screen in UltraEdit and then switched to the hex display. A photo of the result is attached to this message. I don't recognize anything that is unexpected in the hex display.

    Thanks,
    Bill
    Attached Images Attached Images

  4. #4
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,401
    Thanks
    447
    Thanked 404 Times in 376 Posts
    As I recall, you can select plain text, rich text format, or HTML in Thunderbird. Anything other than plain text can contain formatting codes which aren't what you want. Switch between those three settings to see if the problem goes away.

  5. #5
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,188
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Long lines are usually wrapped based on screen width, but you only have the issue when you forward. Maybe the mail you've been sent is text only, not HTML. You need to View Source to see that - see below for an example.

    cheers, Paul

    Code:
    Content-Type: multipart/alternative;
    	boundary="===============1827786729398328610=="
    MIME-Version: 1.0
    Subject: Thank you for setting up Skype Manager.
    From: Skype <noreply@alerts.skype.com>
    Sender: forwardedby@************.com
    To: <*********@************.com>
    Message-ID: <20151105090814.26627.10222@lu4-scripter13>
    Date: Thu, 5 Nov 2015 01:08:14 -0800
    X-e4ward-REA: ***@********.com
    X-e4ward-From: Skype <noreply@alerts.skype.com>
    Reply-To:  Skype <noreply.alerts.skype.com>
    X-e4ward-RCPT: ***@**********.com
    X-e4ward-x: .
    
    --===============1827786729398328610==
    MIME-Version: 1.0
    Content-Type: text/plain; charset="utf-8"
    Content-Transfer-Encoding: base64
    
    PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09PT09

  6. #6
    5 Star Lounger
    Join Date
    Jan 2002
    Location
    Midlothian, Virginia, USA
    Posts
    874
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by mrjimphelps View Post
    As I recall, you can select plain text, rich text format, or HTML in Thunderbird. Anything other than plain text can contain formatting codes which aren't what you want. Switch between those three settings to see if the problem goes away.
    I believe that choice of formats is only available when composing and sending a new message. I tried it anyway on a received message where the problem is and didn't find any change in the very long line.

    Thanks,
    Bill

  7. #7
    5 Star Lounger
    Join Date
    Jan 2002
    Location
    Midlothian, Virginia, USA
    Posts
    874
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by Paul T View Post
    Long lines are usually wrapped based on screen width, but you only have the issue when you forward. Maybe the mail you've been sent is text only, not HTML. You need to View Source to see that - see below for an example.

    cheers, Paul
    I have learned a little more about this problem and I haven't described it correctly. I can't remember ever receiving one of these unwrapped messages except for messages forwarded to me from my wife! I thought I was seeing the same format she was seeing on her laptop because some time back she complained to me about an unwrapped message that was very difficult for her to read. I just went back and looked at the message I wrote this about and it is displayed correctly on her laptop! She is using Thunderbird set up just like my Thunderbird as far as I can tell. I looked at the source of this particular message on both laptops and they are very different. On her laptop the source of that message looks like the source of other messages and says Content-Type: text/plain; charset=us=ascii. After I received the forwarded message from her the source says Content-Type: text/html; charset=windows-1252. And the body text is preceded by <pre> and followed by </pre>. I don't know what the HTML <pre> designates.

    So, I must have some setting wrong in her Thunderbird. Any idea what it is?

    Thanks for helping.
    Bill

  8. #8
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,188
    Thanks
    47
    Thanked 983 Times in 913 Posts
    "Pre" is preformatted, so no wrapping etc. This implies that the message is being kept in it's original format for some reason.

    Check under Tools > Options > Composition > Send Options > Text Format. You should have "send the message in both plain text and HTML".

    cheers, Paul

  9. #9
    5 Star Lounger
    Join Date
    Jan 2002
    Location
    Midlothian, Virginia, USA
    Posts
    874
    Thanks
    0
    Thanked 2 Times in 1 Post
    That's interesting; the display is doing what it has been told to do! I can't imagine why it was formatted that way but I will change my wife's computer the way you suggest.

    Unfortunately, on my computer Thunderbird is suddenly displaying every message in what must be plain text format! Until this happened, the messages that I received from places like Groupon displayed only the text actually in the message and waited for me to tell it to download and display the graphics from their web site. Obviously, I have made some change in my Thunderbird that tells it to display in Text format but I haven't been able to find it so far. :-(

    Thanks,
    Bill

  10. #10
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,188
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Try View > Message Body As.

    cheers, Paul

  11. #11
    5 Star Lounger
    Join Date
    Jan 2002
    Location
    Midlothian, Virginia, USA
    Posts
    874
    Thanks
    0
    Thanked 2 Times in 1 Post
    That's the answer! Thanks Paul. I had never noticed that item in that menu but I obviously must have changed it a day or two ago. It was set to Simple HTML. I changed it to Original HTML and that fixed that problem.

    Thanks,
    Bill

  12. #12
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,188
    Thanks
    47
    Thanked 983 Times in 913 Posts
    I didn't have that set either - must be the default - and now my emails are much nicer to read.

    cheers, Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •