Page 1 of 2 12 LastLast
Results 1 to 15 of 25
  1. #1
    New Lounger
    Join Date
    Oct 2015
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wi-Fi connection limited

    A couple months ago I brought my laptop into staples to be upgraded to windows 8.1, when I brought it home it automatically updated. Since then my wifi will connect for a short period then switch to limited/no Internet. I thought if I brought it back to them and had it upgraded to windows 10 it would fix the problem, but no such luck. Any ideas what's going on or how to fix it?

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,179
    Thanks
    47
    Thanked 983 Times in 913 Posts
    You could have a flaky wifi card / connector. Is there a way to make it work before it fails? Is a re-boot helpful?

    cheers, Paul

    p.s. I hope you didn't pay them to upgrade to Windows 10, it's free from MS.

  3. #3
    New Lounger
    Join Date
    Oct 2015
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    They did the upgrade to 10 for free

    So far the only way to make the wifi work is to plug in the ethernet cord and reconnect to wifi. When I unplug the cord it will stay connected for up to 15 minutes and then go back to limited. I tried rebooting with no luck.

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,179
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Try disabling wifi and leave the cable in. What do you get?
    Do you have one card with both wifi and cable or two cards?

    cheers, Paul

  5. #5
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,161
    Thanks
    19
    Thanked 99 Times in 88 Posts
    There could be a problem with the WiFi router. Do you have anything else connected to it to compare?
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  6. #6
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    Did you reboot the router?
    Factory reset of router after you have recorded/backed up settings would be next.
    David

    Just because you don't know where you are going doesn't mean any road will get you there.

  7. #7
    New Lounger
    Join Date
    Oct 2015
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I plugged in the cable and shut off wifi. It wouldn't connect at all if wifi was off. The router seems to be working fine, we have a Xbox and 2 phones on wifi with no problems. Not sure how to check for more than one card.

  8. #8
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    You did not address my questions.
    David

    Just because you don't know where you are going doesn't mean any road will get you there.

  9. #9
    New Lounger
    Join Date
    Oct 2015
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sorry, I just reset the router. Still no luck. I'm thinking something is wrong with my wifi card... but I'm not a tech savvy person either so it could just be me

  10. #10
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,143
    Thanks
    101
    Thanked 579 Times in 464 Posts
    It would help to know the make and model of laptop.

    It sounds like your wireless NIC may be being turned off due to inactivity. To check, right-click on the Start button, select Device Manager then right-click on the Wireless NIC under Network adapters.

    Next, select Properties from the context menu and then the Power Management tab (if available). Take any tick out of the Allow the computer to turn off this device to save power checkbox.
    wireless nic.png
    Click to enlarge

    Let us know the results.

    Hope this helps...

  11. #11
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,179
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Your computer should connect via a cable. Can you post the output from this command:
    Start > Run
    %comspec% /c ipconfig /all > %temp%\ip.txt & notepad %temp%\ip.txt

    cheers, Paul

  12. #12
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,613
    Thanks
    147
    Thanked 871 Times in 833 Posts
    As it has been doing this since the upgrade to Win 8.1 then it could be a driver problem, but obscure.

    Go into Device Manager/Network adapters - right click on the wireless adapter and select Uninstall - but do not check the box to include software.

    Close up Device Manager then reboot where Windows will reinstate the driver.

    In Win 8.1, Windows was turning off the WiFi when Ethernet was connected but not sure if the same in Win 10.

    Who is your Internet provider ?

  13. #13
    New Lounger
    Join Date
    Oct 2015
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    here are the results Paul


    Windows IP Configuration


    Host Name . . . . . . . . . . . . : Langenfelds
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No


    Ethernet adapter Ethernet:


    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : B8-88-E3-FD-08-81
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes


    Wireless LAN adapter Local Area Connection* 12:


    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
    Physical Address. . . . . . . . . : 12-B7-C3-5D-90-EB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes


    Wireless LAN adapter Local Area Connection* 3:


    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Hosted Network Virtual Adapter
    Physical Address. . . . . . . . . : 52-B7-C3-5D-90-EB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes


    Wireless LAN adapter Wi-Fi:


    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Qualcomm Atheros AR9485WB-EG Wireless Network Adapter
    Physical Address. . . . . . . . . : 50-B7-C3-5D-90-EB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::5dce:e2ed:205:7116%3(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.9(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Tuesday, October 13, 2015 11:29:14 AM
    Lease Expires . . . . . . . . . . : Wednesday, October 14, 2015 11:29:14 AM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 333972378
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-42-CB-9A-B8-88-E3-FD-08-81
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled


    Ethernet adapter Bluetooth Network Connection:


    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
    Physical Address. . . . . . . . . : 50-B7-C3-5D-90-EC
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes


    Tunnel adapter Teredo Tunneling Pseudo-Interface:


    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6abd:2090:10ef:3f57:fef6(Preferred)
    Link-local IPv6 Address . . . . . : fe80::2090:10ef:3f57:fef6%11(Preferred)
    Default Gateway . . . . . . . . . : ::
    DHCPv6 IAID . . . . . . . . . . . : 369098752
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-42-CB-9A-B8-88-E3-FD-08-81
    NetBIOS over Tcpip. . . . . . . . : Disabled


    Tunnel adapter isatap.{0F547962-155A-4D0D-9618-CE4D747A9BF5}:


    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

  14. #14
    New Lounger
    Join Date
    Oct 2015
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I also followed the instructions Rick gave me.

    I did not uninstall the driver yet, I wanted to wait to see what you guys think of those results before I go uninstalling anything.

  15. #15
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,613
    Thanks
    147
    Thanked 871 Times in 833 Posts
    Is that with the Ethernet unplugged ?

    Can you go into services.msc and check that WLAN AutoConfig is showing as Started and Automatic

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •