Results 1 to 13 of 13
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    Columbus, OH
    Posts
    66
    Thanks
    12
    Thanked 5 Times in 4 Posts

    Post migration auto-complete returns "mailbox not found" errors

    We are in the process of doing a staged migration of our Exchange 2007 to a service from Microsoft (Please don't hate me, it wasn't my decision) that would host our Exchange service. After the migration the user converts from mailbox user to mail user. The email address converts from username@company.com to username@company.onmicrosoft.com. This is supposed to be seamless and the old address would auto forward/sync to the new one. After a user gets migrated, if someone sends them and email internally the sender gets an email with the message "The recipient's e-mail address was not found in the recipient's e-mail system. Microsoft Exchange will not try to redeliver this message for you. Please check the e-mail address and try resending this message, or provide the following diagnostic text to your system administrator". We are unable to determine why this is happening for internal messages only. Anyone sending to us from outside the domain can send fine. Any help would be appreciated.

    Rick Allen

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,585
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    If you are using Office 365 you can have Exchange online take over the @company.com domain for email. No need to change any email addresses. You just have to follow the migration rules and tools for Office 365.

    Joe

  3. #3
    Star Lounger
    Join Date
    Dec 2009
    Location
    Columbus, OH
    Posts
    66
    Thanks
    12
    Thanked 5 Times in 4 Posts
    Thank you Joe, but we are doing a staged migration. Not all mailboxes at once. Would this still be the answer?

    Rick

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,585
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    There are many articles to read in the results at office 365 staged migration exchange 2007. Without knowing what you've done already it is difficult to know what you need to do.

    Joe

  5. #5
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts

  6. #6
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    I suspect you need to update AD for migrated users to add the MS address as the preferred email and keep the old. Mail should then be forwarded automatically. I assume you have a connector to send email to the MS domain?

    I agree that using an MS domain name is not a good idea, but I can't see how you can do otherwise with a staged migration. You should be able to change the email domain back post migration.

    cheers, Paul

  7. #7
    Star Lounger
    Join Date
    Dec 2009
    Location
    Columbus, OH
    Posts
    66
    Thanks
    12
    Thanked 5 Times in 4 Posts
    [QUOTE=BruceR;1029214]Try deleting autocomplete nicknames:

    Bruce, this was our thought. We set Group Policy to delete the nk2/auto-complete files from the local computer and then disable the feature until after the migration. Doing it one mailbox at a time would be too cumbersome with 300+ people to migrate.

    We were hoping to find another way.

  8. #8
    Star Lounger
    Join Date
    Dec 2009
    Location
    Columbus, OH
    Posts
    66
    Thanks
    12
    Thanked 5 Times in 4 Posts
    [QUOTE=Paul T;1029230]I suspect you need to update AD for migrated users to add the MS address as the preferred email and keep the old. Mail should then be forwarded automatically. I assume you have a connector to send email to the MS domain?

    Paul, yes we have a connector. Adding the other domain to our email addresses was shot down by our Director. His thought was that it would confuse the Exchange server and put it in an endless loop not knowing where to send the email. Thank you for the idea though. I guess what we are looking for is a way to force companyname.com to automatically find companyname.onmicrosoft.com. Your suggestion sounded like a good idea to me, but he didn't like it.

    Rick

  9. #9
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    He might not like it but that's how you do it. Why not try it for one test user?

    cheers, Paul

  10. #10
    Star Lounger
    Join Date
    Dec 2009
    Location
    Columbus, OH
    Posts
    66
    Thanks
    12
    Thanked 5 Times in 4 Posts
    [QUOTE=Paul T;1029308]He might not like it but that's how you do it. Why not try it for one test user?

    Actually, I just looked at his account since his is the only one migrated completely so far. He does have the other account address as an alias and it doesn't help for people using auto-complete. Some on domain can send to him, others are unable and there is no rhyme or reason for it. All users are set the same. My mailbox has been partially migrated. There is a step left that will finish the process. In the meantime I have to login to my web interface on Office365 to receive email and use my Outlook on my desktop to send email. Replying is very cumbersome!

    Any other thoughts on this would be appreciated.

    Rick

  11. #11
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    Moving the director first was very brave, hope it was his idea!

    The "new" address should be the primary and the "old" the alias.
    Check that the nicknames are not inserting X400 addresses - the old MS standard. If they are there is no work around and you have to delete the nicknames.

    cheers, Paul

  12. #12
    Star Lounger
    Join Date
    Dec 2009
    Location
    Columbus, OH
    Posts
    66
    Thanks
    12
    Thanked 5 Times in 4 Posts
    Moving the director first was very brave, hope it was his idea!

    Yes, it was his idea and he actually did it. He's the only one so far the has been doing the migrations. Him and me.

    The "new" address should be the primary and the "old" the alias.
    Check that the nicknames are not inserting X400 addresses - the old MS standard. If they are there is no work around and you have to delete the nicknames.

    We do have X400 addresses in our email address list, but they are left over from when we migrated from Exchange 2003 to Exchange 2007. They have not been an issue as yet. Can't we just delete the X400 address? Do we have to delete the whole user profile?

    On another note, he now can send an email and have the return address show username@companyname.com. That issue is fixed. However some, not all, people who send new email to him or me using the auto-complete feature in the "to" line get bounce backs. This was the original issue of this thread and it has not been resolved short of disabling the feature for all users via Group Policy. Why can't the address in the auto-complete authenticate to the server when it's the same address as the return address listed when we sent emails out?

    Rick
    Last edited by rmallen07; 2015-11-04 at 11:56.

  13. #13
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    You need someone with a bounce to send you the raw email so you can see what address they have used.

    X400 addresses are used up to Exchange 2010 - I think.

    cheers, Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •