Results 1 to 10 of 10
  1. #1
    2 Star Lounger NTLS's Avatar
    Join Date
    Mar 2010
    Location
    Great LAND of TEXAS
    Posts
    122
    Thanks
    3
    Thanked 4 Times in 3 Posts

    Windows PowerShell stopped working error message

    Greetings from the GREAT land of TEXAS,

    Have an issue with my desktop running "Win7 Pro SP1" for about the last month or so . . slow opening of programs plus not very responsive, mouse will not move nor open anything, most of the time. This past week have been getting a window opening with the info from the TITLE for this thread.

    Looking into WHAT this 'Windows PowerShell' is and cannot find any such animal, have found "PowerShell.exe and PowerShell_ise.exe" in folder C:\Windows\Syswow64\v1.0 which has NOT been any HELP! When opening the PowerShell program got a message that 'scripts disabled' and none can be run.

    Where and how may I reset that feature to "Scripts Enabled" because Mozilla FireFox will not open nor any other program on my computer. Am NOT a programmer just a simple user with many skills and features that give me some extraordinary abilities to have been able to keep my systems working for many years, like about 30 years. This one has stumped me because there seems to be NO helpful information for a NON-Programmer.

    P.S. Also like to thank you for giving me a chance to change my password so I could get back into your Lounge.
    Last edited by NTLS; 2015-11-07 at 12:00. Reason: Forgot to add the P.S.
    TIA, CU L8R,
    NTxLS Win7 Pro 64bit SP1; FireFox v49.x, all with the latest updates

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,634
    Thanks
    147
    Thanked 883 Times in 844 Posts

  3. #3
    2 Star Lounger NTLS's Avatar
    Join Date
    Mar 2010
    Location
    Great LAND of TEXAS
    Posts
    122
    Thanks
    3
    Thanked 4 Times in 3 Posts
    Sudo15,

    That article just may be of some assistance to a Programmer, which I am NOT. What I am looking for is, HOW DO I RE-ENABLE SCRIPT EXECUTION? From what I have found is 'Execution of Scripts is Disabled' without any reason nor where to go to re-enable said feature.
    TIA, CU L8R,
    NTxLS Win7 Pro 64bit SP1; FireFox v49.x, all with the latest updates

  4. #4
    jwoods
    Guest
    There appears to be more than one issue. I would recommend the following...

    1. Run a System Health report by opening a Run box or Command Prompt and entering perfmon /report

    2. Check for errors in the Event logs. In Control Panel, navigate to Administrative Tools and click on Event Viewer. Expand the Custom Views folder and click on Administrative Events. The Administrative Events contain Warnings, Errors, and Critical events from all event logs.

    3. To enable scripts from trusted publishers in Powershell enter Set-ExecutionPolicy RemoteSigned in the Powershell command prompt
    Last edited by jwoods; 2015-11-07 at 14:04.

  5. #5
    2 Star Lounger NTLS's Avatar
    Join Date
    Mar 2010
    Location
    Great LAND of TEXAS
    Posts
    122
    Thanks
    3
    Thanked 4 Times in 3 Posts
    jwoods,

    I feel you are on the right track, have just gone through some testing, of my own development on the system with the issues, opened the "PwerShell.exe" file and did some inquiries about the 'Execution Policies" and partially some good results. Will do what you advised to see where the issue really is located. Still having issues with the "Windows PowerShell Stopped working" box showing up when attempting to open my browser of choice.

    Will let you know if any further work brings better results.

    Thank you for reding and giving a response
    TIA, CU L8R,
    NTxLS Win7 Pro 64bit SP1; FireFox v49.x, all with the latest updates

  6. #6
    jwoods
    Guest
    Quote Originally Posted by NTLS View Post
    ...opened the "PwerShell.exe" file
    I am assuming this is a misspelling...the executable should be powershell.exe or powershell_ise.exe if you are using the integrated scripting environment.

    To turn on scripting using Group Policy, do the following...

    1. In the Search box, type "gr" (no quotes) and click on the Edit Group Policy entry.

    2. Expand the User Configuration section and navigate to Administrative Templates and expand it.

    3. Navigate to and expand the Windows Components folder.

    4. Navigate to the Windows Powershell folder and expand it.

    5. Click on the Turn On Script Execution entry and configure it.
    Last edited by jwoods; 2015-11-07 at 16:48.

  7. #7
    2 Star Lounger NTLS's Avatar
    Join Date
    Mar 2010
    Location
    Great LAND of TEXAS
    Posts
    122
    Thanks
    3
    Thanked 4 Times in 3 Posts
    jwood,

    Yes it is just a misspelling, my fingers are not very well trained to follow my instructions. My testing as referenced in my last message was to go into "PowerShell.exe" do some HELP requests and follow some of their instructions 'til learning a bit about their format and finally found about the execution policy/w explanations. Now this was within PowerShell, not for Windows Group Policy, at this time do not remember which has priority over the other. Have regained some operations.
    TIA, CU L8R,
    NTxLS Win7 Pro 64bit SP1; FireFox v49.x, all with the latest updates

  8. #8
    jwoods
    Guest
    Group Policy overrides...test it yourself when you get a chance.

  9. #9
    2 Star Lounger NTLS's Avatar
    Join Date
    Mar 2010
    Location
    Great LAND of TEXAS
    Posts
    122
    Thanks
    3
    Thanked 4 Times in 3 Posts
    Excuse me, please? There is a discrepancy in your instructions and what I am finding on my DeskTop, "Win7 PRO SP1" does NOT have any listing for "Windows PowerShell" under "Windows Components" nor any "Scripts". In place of "Windows Components" should have been expand "Systems" going to "Scripts" then right pane click on "Run Windows PowerShell scripts first at user logon, logoff" the "State" is 'Not Configured' then select in the laft edge of right pane "Edit policy setting selecting "ENABLED" and is that the only one to be done this way? There are four (4) other that are set to "Not configured' in this same area.

    Am communicating with my laptop that has Win7 Home Premium SP1 both 64 bit yet my laptop does NOT have this same information in the area you mentioned nor even the "Edit Group Policy" the 'gr' brings up NOTHING for editing anything that I have been able to find.

    Your last reply you say "Group Policy overrides" meaning 'Windows Group Policy" not PowerShell's, right?

    "
    Quote Originally Posted by jwoods View Post
    I am assuming this is a misspelling...the executable should be powershell.exe or powershell_ise.exe if you are using the integrated scripting environment.

    To turn on scripting using Group Policy, do the following...

    1. In the Search box, type "gr" (no quotes) and click on the Edit Group Policy entry.

    2. Expand the User Configuration section and navigate to Administrative Templates and expand it.

    3. Navigate to and expand the Windows Components folder.

    4. Navigate to the Windows Powershell folder and expand it.

    5. Click on the Turn On Script Execution entry and configure it.
    TIA, CU L8R,
    NTxLS Win7 Pro 64bit SP1; FireFox v49.x, all with the latest updates

  10. #10
    jwoods
    Guest
    Windows 7 Home Premium does not include the Local Group Policy Editor.

    This website gives the registry changes for each setting, which is how you would need to do it...

    http://gpsearch.azurewebsites.net/

    If you use this, create a System Restore point first.
    Last edited by jwoods; 2015-11-07 at 18:24.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •