Results 1 to 6 of 6
  1. #1
    5 Star Lounger petesmst's Avatar
    Join Date
    Dec 2009
    Location
    Cape Town, South Africa
    Posts
    790
    Thanks
    38
    Thanked 43 Times in 33 Posts

    Unable to prevent Edge defaulting to selected viewer for .pdf files: (Build 10586)

    Ever since upgrading to the November build, I have been unable to "permanently" de-select Edge from being the default .pdf file viewer. (No matter what means I use; whether via Settings Default Apps or by choosing "set this program as default .pdf file viewer" in my preferred software.) I can only open a .pdf file in my preferred software ("Soda PDF") if I open it from within Soda PDF. Any ideas?




    Oops: Perhaps this should have been posted as a new thread under Internet Explorer and Edge. Admin please feel free to move if necessary.
    Last edited by petesmst; 2015-11-29 at 05:22. Reason: Added "Oops"
    (My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Motherboard (Military Class III); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 512GB SAMSUNG SD850 PRO SSD; 120GB SAMSUNG 840 SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2013 Prof (32-bit); MS Project 2013 (32-bit); Acronis TI 2017 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Samsung 24" Curved HD Monitor.

  2. #2
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    290
    Thanks
    46
    Thanked 5 Times in 5 Posts
    Right click on a pdf, chose "open with", Then click "Chose another app". If you don't see your app on the next window, click "more Apps".
    George

  3. #3
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,762
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Your pdf viewer may not have all of its defaults set. You should be able to change that by going through Control Panel > Default Programs > Set Default Programs.

    That's how I got Edge to stop opening web page links that I access through email or shortcuts, and use my preferred IE 11.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  4. #4
    5 Star Lounger petesmst's Avatar
    Join Date
    Dec 2009
    Location
    Cape Town, South Africa
    Posts
    790
    Thanks
    38
    Thanked 43 Times in 33 Posts
    @High Sierra and @ bbearren: I have done both; but each time I re-boot, and even when I "wake up" from Sleep, I find that Edge has once again been set as the default program. There was no issue such as this prior to the Windows 10 "November Update". Weird!
    (My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Motherboard (Military Class III); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 512GB SAMSUNG SD850 PRO SSD; 120GB SAMSUNG 840 SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2013 Prof (32-bit); MS Project 2013 (32-bit); Acronis TI 2017 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Samsung 24" Curved HD Monitor.

  5. #5
    New Lounger
    Join Date
    Feb 2011
    Posts
    9
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Petesmst: Try opening control panel - default program - set default programs and find the program you want to use to open .pdfs (most likely Acrobat or Nitro), then click Set this program as default as mentioned before. This will set the .pdf's to open in the program. The problem is with Edge itself I believe. If you have another browser like Chrome installed, in that same control panel app, find the Chrome (or other) browser and click Set this program as default. That way, Edge is not considered the default browser any longer and can't change the settings. Anyway this worked for me on my upgrade!
    Last edited by Selee; 2015-12-03 at 15:43.

  6. #6
    5 Star Lounger petesmst's Avatar
    Join Date
    Dec 2009
    Location
    Cape Town, South Africa
    Posts
    790
    Thanks
    38
    Thanked 43 Times in 33 Posts
    @Selee. Tried all that (with Internet Explorer as my default browser) but no joy. And, suddenly today (after latest accumulative update, I am able to get the default change to "stick". So, I suppose I can now label this post as "solved"?(!)
    (My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Motherboard (Military Class III); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 512GB SAMSUNG SD850 PRO SSD; 120GB SAMSUNG 840 SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2013 Prof (32-bit); MS Project 2013 (32-bit); Acronis TI 2017 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Samsung 24" Curved HD Monitor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •