Results 1 to 15 of 15
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Win 10 and MicroSD Card dismouting

    Just purchased a Microsoft Surface 3 wifi version running Win 10 which took the 1511 update about three days after I purchased it.


    I have run into a problem with the micro sd card dismounting on its own. The card is a new Samsung Evo+ 128gb. The problem is that when the computer is restarted either from shut down or hibernation or sleep the card is no longer mounted. However, when you remove it you hear the audible tone and then re-inserting finds it again. I use it primarily to store 70+ gigs of music files. So far, when playing music it has not dropped the card.


    There are many threads on this in different forums and the debate rages from specific cards, defective sd card reader to driver being out of date. I have tried formating the card in NTFS and exFat, tape on the back of the card to make it thicker, assigning a specific drive letter to the card without success. I have been in contact with MS tech support three times and found no solution. Took the Surface to an MS store yesterday where I was told that the best SD manufacturer is Kingston but that the Samsung was OK. They supposedly installed a driver for the card from Samsung and it actually worked twice and then an hour later didn't. When I checked the driver I found it to be the same generic MS driver dated 2006 that was had been on it originally, so I have no idea what, if anything, they did. I also couldn't find a Samsung driver for an SD card. This seems to be the quality of tech support today.


    Any suggestions would be appreciated.

  2. #2
    jwoods
    Guest
    In Device Manager, check that the card reader is not being turned off to save power.

    USB ports will sometimes react in a similar fashion

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Check your power management options in Device Manager and in Power Options advanced settings.

    Joe

  4. #4
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by JoeP517 View Post
    Check your power management options in Device Manager and in Power Options advanced settings.

    Joe
    When the card is not showing in file explorer it is not in the device manager list. Where would I find this setting in Device Manager.

  5. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    In "View" try "Show hidden devices". It that does not work you'd need to have it showing.

    Joe

  6. #6
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    jcgc,

    1. Power Options
    2. Change Plan Settings
    3. Change Advanced Power Settings
      USBPower.JPG
    4. Since most card readers are setup on a USB hub you probably want to disable the ability for the machine to turn the USB devices off.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  7. #7
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts
    In advanced settings there is no line item for USB settings. I see the plan in your view is High Performance. Mine is set to Balanced, don't know if that makes a difference to what you see in the list.

    Jim

  8. #8
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts
    I could not find any power management options in Device Manager. With the card visible in DM and looking through properties I could find nothing there.

    Jim

  9. #9
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by JoeP517 View Post
    Check your power management options in Device Manager and in Power Options advanced settings.

    Joe
    To further clarify. The device shows up under Disk Drives not USB hub. USB hub does have a power management option and that is checked to allow the computer to turn that off. Also, today I plugged a 16gb card into the slot while the computer was in hibernation. When I woke it up the card showed up with a message even before I got to the log in screen.

    What I have seen frequently in other forums is the suggestion that the problem seems to persist with 128gb cards although some people claim that some cards work. However, there is no consistency. In other words. someone will have good luck with a Lexar or another with Sandisk, etc. But other can't find a brand that works.

    Jim

  10. #10
    jwoods
    Guest
    Is your Surface firmware up to date?

  11. #11
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by jwoods View Post
    Is your Surface firmware up to date?
    Yes.

  12. #12
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,165
    Thanks
    19
    Thanked 99 Times in 88 Posts
    Quote Originally Posted by jwoods View Post
    Is your Surface firmware up to date?
    There was a problem in the SP3 regarding the SD card slot that was fixed in a firmware update, but if you are up to date then that probably isn't the issue.

    I have a Samsung EVO 64GB card in mine and did run into a similar problem a couple weeks ago. I had removed the card for a test and when I set it back in, it apparently didn't seat quite right. Removing and reseating it seems to have fixed my problem. FWIW, the SD slot on the SP3 seems a bit "loose" to me and the location makes it possible to accidentally disturb. I've been tempted to put a piece of tape over it.

    There do seem to be more reports of issues with 128GB cards in general. But I'm not sure if that's true or not.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  13. #13
    Star Lounger
    Join Date
    Dec 2009
    Posts
    77
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by gsmith-plm View Post
    There was a problem in the SP3 regarding the SD card slot that was fixed in a firmware update, but if you are up to date then that probably isn't the issue.

    I have a Samsung EVO 64GB card in mine and did run into a similar problem a couple weeks ago. I had removed the card for a test and when I set it back in, it apparently didn't seat quite right. Removing and reseating it seems to have fixed my problem. FWIW, the SD slot on the SP3 seems a bit "loose" to me and the location makes it possible to accidentally disturb. I've been tempted to put a piece of tape over it.

    There do seem to be more reports of issues with 128GB cards in general. But I'm not sure if that's true or not.
    It is up to date. The SD card has been taken in and out repeatedly and I have tried tape. None of which has solved the problem.

  14. #14
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,165
    Thanks
    19
    Thanked 99 Times in 88 Posts
    Quote Originally Posted by jcgc50 View Post
    It is up to date. The SD card has been taken in and out repeatedly and I have tried tape. None of which has solved the problem.
    Then it sounds like either a bad slot or bad card.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  15. #15
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,072
    Thanks
    0
    Thanked 259 Times in 248 Posts
    It could also be the SD Adapter that usually comes with the MicroSD card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •