Results 1 to 15 of 15
  1. #1
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts

    Outlook and winmail.dat problems

    A friend of mine is secretary of a club. She is not very computer savvy, and I am trying to help her. She is using Windows 10 and Outlook - the headers of her messages say that it is "Outlook 15", which I think is either from Office 16 or Office 365. Anyway, she sends regular emails to the club members, and often these include attachments of .docx or .doc format. Some of the members complain that they are unable to receive the attachments - they just see a winmail.dat attachment, which they are unable to open. It turns out that the affected members are either using a non-Outlook email client, such as Thunderbird, or are using a Macintosh computer. Users of Outlook (any version) ae not affected.

    I am aware that this problem may be caused by messages going out in Rich Text Format (RTF), as described in https://support.office.com/en-ie/art...7-0e0150ef87a8 , and on checking her outgoing messages, they were indeed in RTF. I have assisted her to change the format of her outgoing messages from RTF to HTML (doesn't want to use Plain Text), and as far as I know, the changes have been made, but the messages are still going out in RTF, and the affected recipients are still not able to open the attachments.

    Can anyone please advise the correct settings for that particular version of Outlook (which I do not have), to ensure that outgoing messages will be in HTML format? I believe there is a general setting (compose in this format ....), and also an override for particular addressees ??

  2. #2
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,143
    Thanks
    101
    Thanked 579 Times in 464 Posts
    If the Outlook version number is 15 then the version name is Outlook 2013. The default message format in Outlook 2013 is HTML so if messages have been composed as RTF then the default has been changed.

    Having said that, when you send a Rich Text Format message to someone outside your organization, Outlook should automatically convert it to HTML so the message keeps its formatting and its attachments. [Source: https://support.office.com/en-us/art...3-CF41F792FEFA]

    This article also shows how to change the default message format, i.e. select File > Options > Mail, scroll to the bottom of the dialog then select Convert to HTML format.
    outlook2010-global.png
    Click to enlarge

    I also spotted this tip:

    You can clear your [autocomplete] cache settings for a person if they are still receiving Winmail.dat files from you. Create a new message, begin to enter the email address, then use the arrow keys to scroll up or down, highlight the address of the person and press the delete key to remove the entry. Enter their address in the To field and it will create a new entry.
    If you have a lot of recipients then instead of deleting the autocomplete cache settings individually, you can delete them all in one fell swoop by clearing the whole auto-complete cache. Go to the File > Options > Mail > Send Messages section then click on Empty Auto-Complete Lists which will clear the entire cache

    If you still get problems then it may be an idea to repair the installation of Outlook.

    1. Open up Control Panel then Programs and Features.
    2. Find Microsoft Outlook 2013 (or Microsoft Office 2013) in the list and select it.
    3. Click Change.
    4. Select Repair then follow the prompts.

    If a repair doesn't work then it may be necessary to uninstall then re-install Outlook.

    Hope this helps...
    Last edited by Rick Corbett; 2016-01-10 at 02:08.

  3. #3
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    Thanks Rick, I will pass this information on and try to get it set up correctly. I will post in here what the result is - could take a few days. Thanks again.

  4. #4
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    All settings were checked, and were found to be correct for sending messages in HTML format and not RTF, but further investigation showed that this lady did not have a proper distribution list, and was not sending new messages. She had picked up a previous email which had been addressed to all the members, and she was using "Reply to all" to send her messages. Unfortunately, the message she had picked up was in Rich Text, and it looks like when you reply to such a message, or forward it, the original formatting is retained over your own settings. I don't know if this is by design, but it makes sense when you think about it.

    Anyway, I have advised her to set up a distribution list, and henceforth to use it for new messages. Also told her to always check in "Format text" before sending a message, to make sure it says HTML.

    Thanks again for providing the above information, and I believe (hope??) that the issue is resolved now.

  5. #5
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Hartford, WI, USA
    Posts
    370
    Thanks
    153
    Thanked 62 Times in 37 Posts
    Can the sender of the emails check what file type the attachment actually has AFTER attaching it but BEFORE sending the email?
    It's kind of hard to believe that M$ would change or wrap an attachment.

    Nice ways M$ employs to "force" more people to use their overpriced Office software.

    Thank you for this warning, another GOOD reason to avoid M$ Office.
    Eike J Heinze
    What I am about
    SE Wisconsin

  6. #6
    New Lounger
    Join Date
    Apr 2010
    Location
    Canada
    Posts
    9
    Thanks
    2
    Thanked 2 Times in 2 Posts
    The fault is in Outlook and the fix is simple. Non-MS e-mail clients can't read Outlook messages. It's not that they are in HTML or RTF format, it's the pesky winmail.dat files which are in TNEF format, proprietry to Microsoft. There are add-on openers for other e-mail clients, but the easist way for the non-computer literate person to resolve this is to format and save the contents of the newsletter in .pdf format (use word processing software and save as .pdf). Then send the .pdf file as an attachment to a plain text e-mail, NOT in HTML. I send all my e-mails in plain text (either selectable as a default or when composing the e-mail in Outlook) and use attachments. Everyone can read them.

  7. #7
    3 Star Lounger
    Join Date
    Jul 2002
    Location
    Rockledge, FL
    Posts
    327
    Thanks
    23
    Thanked 11 Times in 11 Posts
    Nah, don't think so. I use Outlook 2013 to send email messages to several different distribution lists. Those users are PC users, mac users, people who use the installed Outlook client (some before the 2013 version) and others that pick up their mail using a browser based logon.

    None complain that my emails cannot be read. If what you say were really, the web would be inundated with messages complaining about this.

    K

    Quote Originally Posted by DKS01 View Post
    The fault is in Outlook and the fix is simple. Non-MS e-mail clients can't read Outlook messages. It's not that they are in HTML or RTF format, it's the pesky winmail.dat files which are in TNEF format, proprietry to Microsoft.

  8. #8
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    As far as I know, the issue is resolved. It applied only to two types of recipients: those on a PC but using non-MS email such as Thunderbird, and those on a Mac. Since the switch to HTML, the messages and attachments (which are mostly of type docx) are getting through to these recipients.

    Quote from a Thunderbird support site:

    "When people send messages from incorrectly configured Microsoft Outlook email clients, a file attachment called winmail.dat may be added as an attachment to the message. This file contains formatting information for messages that use Microsoft's proprietary TNEF standard and any attachments sent with the original message. The file is not recognized by other email clients. Because of this, any attachments sent with the original message are not displayed in Thunderbird's message pane.

    If you try to open winmail.dat, you will probably be prompted to specify the application that should be used to open the file. Because this file is in a Microsoft proprietary Outlook/Exchange format, you may not have an application installed that can decode this file and display it. Even if your system is capable of displaying the file, it does not contain any useful information.

    To prevent this file from being attached to messages, the sender of the message (or their system administrator) can configure various options as described in this Microsoft Support Bulletin."

    The MS Support Bulletin referred to says:

    "Recipients receive a winmail.dat attachment
    Symptoms

    Recipients notify you that the e-mail message you sent appears to them as a message with an attachment called winmail.dat.
    Cause

    You are using the Rich Text message format, which the recipient's e-mail program cannot interpret correctly.
    Resolution

    Send your messages in either HTML or plain text format."

    TNEF (Transport Neutral Encapsulation Format) apparently applies only to RTF. According to this Microsoft support site (it's a long one, but worth a read):

    "For Microsoft Outlook 2010 and later versions:

    To turn off TNEF, follow these steps:

    Click the File tab, click Options, and then click Mail.
    In the Compose in this message format list, click Plain Text or HTML, and then click OK."
    Last edited by Bundaburra; 2016-01-21 at 03:16.

  9. The Following 2 Users Say Thank You to Bundaburra For This Useful Post:

    DKS01 (2016-01-21),Paul T (2016-01-21)

  10. #9
    New Lounger
    Join Date
    Apr 2010
    Location
    Canada
    Posts
    9
    Thanks
    2
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by kevmeist View Post
    Nah, don't think so. I use Outlook 2013 to send email messages to several different distribution lists. Those users are PC users, mac users, people who use the installed Outlook client (some before the 2013 version) and others that pick up their mail using a browser based logon.

    None complain that my emails cannot be read. If what you say were really, the web would be inundated with messages complaining about this.

    K
    I can assure you it is the problem. In fact, I am certain it is. I have had it happen and dealt with it repeatedly over the years, going back to Outlook 2003. The web is indeed having this issue. The ubiquity of Mictosoft's Outlook does mitigate things a bit, but it's still an issue. I can't, for example, read any Outlook formatted messages on my iPad in Apple's mail client unless they are in plain text. Same with my iPhone. If you want more info, just search for "winmail.dat". Here is Microsoft's own response to the issue, which they do acknowledge:

    https://support.microsoft.com/en-us/kb/278061

    Apple's response:

    https://support.apple.com/en-us/HT201773

    Here is another set of technical solutions, one involving a registry hack (which I wouldn't recommend to a novice user).

    http://www.slipstick.com/problems/ou...t-attachments/

  11. #10
    New Lounger
    Join Date
    Apr 2010
    Location
    Canada
    Posts
    9
    Thanks
    2
    Thanked 2 Times in 2 Posts
    Thunderbird also has an extension to allow their client to decode winmail.dat files. There are other freeware programs out there, too. I can't testify to how well they work, though. The real solution is to use plain text, as the DOS gods intended.

  12. #11
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,582
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    The problem is ONLY if the originating mail client is Outlook AND the message is sent as RTF. It does NOT apply to HTML or plain text emails. It is simple to fix. For new emails make sure that Outlook is set to compose new email in HTML or Plain text - File | Options | Mail | Compose Messages. For responses make sure that RTF emails get converted to HTML or plain text when sent to Internet recipients - File | Options | Mail | Message format.

    Joe

  13. #12
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    I agree with JoeP517, who has summed it up nicely, and I can say for a fact that the lady's messages now going out in HTML format are no longer causing a problem to the recipients I mentioned.

    Microsoft support is confused on the issue. This one says that using HTML (or Plain Text) will resolve the issue, and that is so in practice.
    Last edited by Bundaburra; 2016-01-21 at 17:40.

  14. The Following 2 Users Say Thank You to Bundaburra For This Useful Post:

    DKS01 (2016-01-21),Fyrewerx (2016-01-22)

  15. #13
    New Lounger
    Join Date
    Apr 2010
    Location
    Canada
    Posts
    9
    Thanks
    2
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by Bundaburra View Post
    I agree with JoeP517, who has summed it up nicely, and I can say for a fact that the lady's messages now going out in HTML format are no longer causing a problem to the recipients I mentioned.

    Microsoft support is confused on the issue. This one says that using HTML (or Plain Text) will resolve the issue, and that is so in practice.
    Which is, at the core, what we have all said. It applies to Outlook as both a standalone client and when used in an Exchange Server. Switch to HTML or, as I believe the modem gods foreordained, switch to plain (DOS) text. There are, at the end of the day, multiple solutions and the right one is the one which works best for the end user.
    Last edited by DKS01; 2016-01-21 at 20:52.

  16. #14
    2 Star Lounger
    Join Date
    Sep 2001
    Location
    Middelburg, Zeeland, Netherlands
    Posts
    165
    Thanks
    20
    Thanked 2 Times in 2 Posts
    Customer also had this problem after installing an app using outlook for sending messages. The simple solution was a registry 'hack':
    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\O utlook\Preferences]
    "DisableTNEF"=dword:00000001

    BTW change 12.0 if you have an other version of Office.

  17. #15
    3 Star Lounger
    Join Date
    Jul 2002
    Location
    Rockledge, FL
    Posts
    327
    Thanks
    23
    Thanked 11 Times in 11 Posts
    Ah, OK. I have had my Outlook 2013 set to HTML as a default for a long time, hence never seeing this problem.

    K

    Quote Originally Posted by JoeP517 View Post
    The problem is ONLY if the originating mail client is Outlook AND the message is sent as RTF. It does NOT apply to HTML or plain text emails. It is simple to fix. For new emails make sure that Outlook is set to compose new email in HTML or Plain text - File | Options | Mail | Compose Messages. For responses make sure that RTF emails get converted to HTML or plain text when sent to Internet recipients - File | Options | Mail | Message format.

    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •