Results 1 to 11 of 11
  1. #1
    New Lounger
    Join Date
    Feb 2013
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Windows 10 Default App Associations Keep Re-appearing

    After countless times setting up my default file associations , Windows 10 keeps resetting to the Microsoft default programs. The system constantly discards my settings and reverts back to MS defaults. I have this issue with many of my graphic files especially .tif. I have looked on other forums and many others are experiencing the same or similar issue. Any help would be appreciated. This is a REAL PITA.

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    L.P.,

    You could uninstall the Win 10 Apps {read linked thread to end!} that use those files.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    New Lounger
    Join Date
    Feb 2013
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    De-Crapifier Rules

    Will look at it and maybe give it a try. Not worried about the outcome just the time it takes.

    Thanks for the reply!

  4. #4
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,792
    Thanks
    117
    Thanked 798 Times in 719 Posts
    Did you use Settings > System > Default Apps to set your defaults?

    Jerry

  5. #5
    New Lounger
    Join Date
    Feb 2013
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Have tried multiple processes. Not only the built-in tools [Settings > System > Default Apps > File Type] but a couple 3rd party tools also. Same result. My biggest 'gripe' is for .tif and .tiff files. The system keeps resetting to the Windows 10 Photo Viewer.

  6. #6
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,792
    Thanks
    117
    Thanked 798 Times in 719 Posts
    Did you also change Settings > System > Default Apps > Photo Viewer ?

    Jerry

  7. #7
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Skelmersdale, Lancashire, UK
    Posts
    252
    Thanks
    44
    Thanked 10 Times in 10 Posts
    I've had the same problem and tried the many routes to setting default apps, eventually getting satisfaction.
    But what a stupid way to run an operating system. What's the point of having a straightforward settings page that doesn't work.

    No doubt MS will have some obscure reason why the task is made so difficult, but I can't think of one. What was wrong with the old 'open with' in the context menu with a tick box for making the choice the default. worked well in previous Windows incarnations.

    Rant over.

    Alex

  8. #8
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,723
    Thanks
    146
    Thanked 156 Times in 149 Posts
    I have some tif files hanging around on my W10 PC, which didn't have any associations. So I associated them with Photoshop, and even after a couple of restarts, they still are. So I've just changed the association to Irfanview and they still have that association after shutting down then starting (not a restart in case that has a bearing).

    Indeed, I used file manager, rightclick then 'open with'. Photoshop was top of the list. I then clicked 'Choose another app' at the bottom of the list and chose Irfanview, clicking the option 'Always use this app...'. As far as I can see the task is pretty much identical to 8.1 (and probably 7), with just a slightly different naming convention. Only one thing, it takes a few seconds for the list to appear when I choose 'open with'.

    Why yours should revert to other programs I don't know. If you let me know which programs they default to, I could try setting mine to those and see if I can change them again.

  9. #9
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,141
    Thanks
    101
    Thanked 579 Times in 464 Posts
    Quote Originally Posted by access-mdb
    Only one thing, it takes a few seconds for the list to appear when I choose 'open with'.
    Try this:
    1. Run regedit.
    2. Navigate to HKEY_CURRENT_USER\Control Panel\Desktop.
    3. Right-click on the Desktop key and export it (e.g. to the desktop), just in case.
    4. Change the value for MenuShowDelay from the default 400 to 20 and accept the change.
    5. Close regedit.

    Or copy/paste the following into Notepad (including the blank line at the bottom) and save as something like faster-menu.reg then merge it by double-clicking on it:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "MenuShowDelay"="20"
    Any faster for you?

  10. #10
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,723
    Thanks
    146
    Thanked 156 Times in 149 Posts
    Thanks Rick, I'll try to investigate tomorrow when I next switch that PC on - this one is the 8.1 - and that's instant!

  11. #11
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,723
    Thanks
    146
    Thanked 156 Times in 149 Posts
    Tomorrow has become the day after tomorrow! The fix didn't make any difference to the first time I get the menu up - but it's instant thereafter.

    I also set the default app to Photo Viewer, and after rebooting, back to Irfanview and this has remained the default. There must be another setting somewhere that's changing the default to Photo Viewer.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •