Results 1 to 9 of 9
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    South Africa
    Posts
    49
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Win 10 disconnecting from wifi after an hour or so

    Although the WIFI signal stays strong, after a while my computer disconnects, and I have to click manually to reconnect.

    There must be a setting somewhere to change this behaviour?

    Any help would be very welcome.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    If this is just at home check your router settings.

    Joe

  3. #3
    Lounger
    Join Date
    Dec 2009
    Location
    South Africa
    Posts
    49
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My iPhone stays connected and never looses the connection on its own, so the router is OK

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,180
    Thanks
    47
    Thanked 983 Times in 913 Posts
    Try a new driver for the wifi card. Go to the card manufacturer's site, don't use the Windows search for update option.

    cheers, Paul

  5. #5
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    2,154
    Thanks
    31
    Thanked 306 Times in 266 Posts
    @ errolgreer

    In 'Device Manager' right-click on the wireless connection device then left-click on 'Properties'. Under the 'Power Management" tab un-tick the "Allow the computer to turn off this device to save power" then click 'OK'.

    Restart Windows and see how it goes...
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    AMD FX8120 (8-core @ 3.1GHz) CPU, Gigabyte GA-990FXA-D3 motherboard, 8GB (2x4GB) DDR3 1866MHz RAM, ATI-AMD Radeon HD6770 PCI-E VGA, 480GB Kingston SSD, 2TB Seagate SATA3.0 HDD, ASUS DVD/RW.

  6. The Following User Says Thank You to Coochin For This Useful Post:

    AdamKertesz (2016-02-05)

  7. #6
    5 Star Lounger Vincenzo's Avatar
    Join Date
    Mar 2004
    Posts
    654
    Thanks
    95
    Thanked 14 Times in 13 Posts
    I've read that Win 8 and Win 10 can have a problem with older routers. Windows wants to go into a mode that maintains the connections but is designed to use lower power, and the older routers cannot handle it. The fix supposedly is to go into your Power Options in Control Panel and select the High Performance profile. I can't confirm or deny that this works, but I've read that it has helped with some older routers.

  8. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Stony Brook, NY
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Vincenzo View Post
    I've read that Win 8 and Win 10 can have a problem with older routers. Windows wants to go into a mode that maintains the connections but is designed to use lower power, and the older routers cannot handle it. The fix supposedly is to go into your Power Options in Control Panel and select the High Performance profile. I can't confirm or deny that this works, but I've read that it has helped with some older routers.
    I'll give it a try but I've found a lot of additional problems since. It seems that a number of services that are set to automatic are not starting and some of my programs now require me to run them as an administrator. I'm going to try a complete reinstall on a new hard drive and see what happens.

  9. #8
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,617
    Thanks
    147
    Thanked 875 Times in 837 Posts
    You could also run the Windows Repair program from www.tweaking.com which among other things, will reset the Permissions.

  10. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Stony Brook, NY
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Coochin View Post
    @ errolgreer

    In 'Device Manager' right-click on the wireless connection device then left-click on 'Properties'. Under the 'Power Management" tab un-tick the "Allow the computer to turn off this device to save power" then click 'OK'.

    Restart Windows and see how it goes...
    Didn't work for me. Nor did changing the power settings to High Performance. I've also noticed that several services that should load automatically aren't starting and the Windows Security service won't start. Also, a number of programs, mostly Adobe's, have to be run as administrator. I don't know if these are related but there may be a clue in there somewhere.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •