Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Feb 2016
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Windows 10, Realtek PCIe GBE Family Controller, Intermittent ethernet disconnect

    There was a thread last year about this controller. The problem I'm having is different. The controller has the latest driver but randomly disconnects. Most of the time, unplugging and replugging the ethernet cable fixes the problem, but not always. Sometimes a reboot is required.

    The machine is a Dell Inspiron 7737 laptop with the Realtek PCIe GBE Family controller on the MB. The machine shipped in December with Windows 8.1. I immediately upgraded to Windows 10. The device manager was set to allow the computer to automatically turn off the controller to save power. I disabled that option but it has not resolved the issue. I can use the laptop in WiFi mode, but I prefer not to when financial transactions are involved. It has been a real bitch isolating this issue because I was also having service provider issues through Comcast. We've finally isolated it down to this device. Our other laptop, a Toshiba, has had no issues. Exchanging the ethernet cable between machines did not resolve and using a different modem port didn't either. The signal from Comcast is now solid and has been verified to have virtually no jitter (about 1-2 ms).

    I'm at my wits end... I'm about ready to get a cheap outboard USB ethernet adapter... Suggestions?

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,170
    Thanks
    47
    Thanked 978 Times in 908 Posts
    Open Device Manager and un-install the ethernet controller. Re-boot and let Windows re-install it.

    cheers, Paul

  3. #3
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,140
    Thanks
    101
    Thanked 579 Times in 464 Posts
    Similar to my Inspiron N5050.

    Open Device Manager, double-click on the Realtek PCIe GBE Family Controller, select the Power Management tab and take the tick out of the Allow the computer to turn off this device to save power checkbox. Click on the OK button to dismiss the dialog then close Device Manager.

    dell.png
    Click to enlarge

    Let us know if this improves matters.

    Hope this helps...

  4. #4
    5 Star Lounger
    Join Date
    Oct 2013
    Location
    Phoenix, AZ
    Posts
    926
    Thanks
    554
    Thanked 137 Times in 128 Posts
    If you are talking about this driver, Realtek RTL8411B-US Ethernet Controller Driver, on Dell's support site for your laptop it is from 2013 and doesn't state Win10 support.

    https://www.dell.com/support/home/us...driverId=889RP

    Download the latest driver for Win10:

    http://www.realtek.com.tw/

    Sorry I would have had a more specific link but of course this site has decided at this point to timeout. I am sure it will work just fine in 20 minutes after I no longer need access. Grrrrrrr!!!!!

    http://www.dell.com/support/my-suppo...spiron-17-7737

    In the end, it may be a defective Ethernet port/controller. You did a good job narrowing it down to this device. And new laptop means covered under Dell warranty.
    Last edited by Fascist Nation; 2016-02-09 at 07:57.

  5. #5
    New Lounger
    Join Date
    Feb 2016
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks, everybody.

    I pulled a fresh download from Realtek, uninstalled, re-installed via Realtek's setup.exe, and then went to properties and turned off both the Green Ethernet and Energy Efficient Ethernet options. So far, so good

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •