In Fred Langa's recent article Improve Internet Explorer 11ís security settings there is a recommendation to change some advanced security options. One of these, when checked, can cause Outlook 2010 to block most images. This is the "Do not save encrypted pages to disk" option. I had checked that box after reading the article. Shortly afterward, I was surprised when most of the images in my emails were blocked. Eventually, I connected the two events and found that I could get images working again by unchecking that option.
David Salahi
Windows 10