Results 1 to 13 of 13
  1. #1
    3 Star Lounger
    Join Date
    Feb 2004
    Location
    Moundridge, Kansas, USA
    Posts
    342
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Windows 10 resets default printer after RDP session

    I have a very irritating situation with my computer. If I remote in to it, my default printer gets reset. It resets to the first printer (alphabetically in the port name) in the list, which is a Zebra label printer and it really messes things up. I think it's a bug in Windows 10 with RDP. I already have the "Let Windows manage my default printer" option turned off. Does anyone have an idea for me?

    Windows10_DefaultPrinterSettings.PNG

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    What is the printer setting on the local resources tab for the RDP connection?

    Joe

  3. #3
    3 Star Lounger
    Join Date
    Feb 2004
    Location
    Moundridge, Kansas, USA
    Posts
    342
    Thanks
    1
    Thanked 0 Times in 0 Posts

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    What happens if you clear the printer check mark?

    Joe

  5. #5
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,726
    Thanks
    147
    Thanked 156 Times in 149 Posts
    My setup is that my printer is on the remote PC, and I don't appear to have that problem. However, it happens that the printer name is first on that list. Perhaps renaming the printer so it's first will fix the problem for you. I realise that's it's a fudge, but it may help until MS fix the problem.

    I take it you've told them?
    Talk is cheap because supply exceeds demand

  6. #6
    3 Star Lounger
    Join Date
    Feb 2004
    Location
    Moundridge, Kansas, USA
    Posts
    342
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I'm experimenting with that, JoeP517. Thank you for that suggestion. So far that seems to have made a difference. For anyone reading this, I understood that when you remote in to another computer, if you do not need the printers, before making the connection, go to Remote Desktop Connections -->Local Resources and clear the check box by Printers.

  7. #7
    3 Star Lounger
    Join Date
    Feb 2004
    Location
    Moundridge, Kansas, USA
    Posts
    342
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I have not sent a report to MS. Windows apparently does not allow you to change a port name once you have your printer set up.

  8. #8
    New Lounger
    Join Date
    Apr 2016
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have exactly the same problem and you're correct in that renaming the printer to be the first printer alphabetically does make a difference. Have you found a permanent solution other than the workaround in renaming the printer?

  9. #9
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,761
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by 79schultz View Post
    I have a very irritating situation with my computer. If I remote in to it, my default printer gets reset. It resets to the first printer (alphabetically in the port name) in the list, which is a Zebra label printer and it really messes things up. I think it's a bug in Windows 10 with RDP. I already have the "Let Windows manage my default printer" option turned off. Does anyone have an idea for me?
    I use RDP to connect to my Windows 10 NAS, my default printer is a network printer, it's not the first one on the list, and it doesn't change.

    Try this: RDP into your computer, turn on "Let Windows manage my default printer" (I use that setting), then start a print job. In the print dialog box that opens, select the printer you want as the default to actually run the print job.

    Windows should then set that printer (which is now the last one used) as the default printer, and keep it as default unless you RDP into the computer and use a different printer for a print job. That different printer would then become the default printer.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  10. #10
    3 Star Lounger
    Join Date
    Feb 2004
    Location
    Moundridge, Kansas, USA
    Posts
    342
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I don't want to contradict you bbearen, but it is a problem for us. It's true, if I can remember to always remember to deselect 'Printers' when I RDP, it won't be a problem. I understand what you suggested, but it causes a real problem with Microsoft Access. We use Microsoft Access for our database, and unless you go in to each report and manually set a printer to be used all the time, Access goes with the default printer. When a report is set to print on a Letter sized piece of paper and suddenly you are trying to print to a label, it causes problems.

    I have yet to see any benefit in this new option MS placed in W10.

  11. #11
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,753
    Thanks
    171
    Thanked 652 Times in 575 Posts
    Quote Originally Posted by 79schultz View Post
    I already have the "Let Windows manage my default printer" option turned off. Does anyone have an idea for me?
    Turn it on.

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    See if the last post at User's default printers reset every session on Terminal Services helps. The description of the policy in gpedit.msc seems like it might be what you want.
    Joe

  13. #13
    New Lounger
    Join Date
    Jun 2016
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by 79schultz View Post
    I have a very irritating situation with my computer. If I remote in to it, my default printer gets reset. It resets to the first printer (alphabetically in the port name) in the list, which is a Zebra label printer and it really messes things up. I think it's a bug in Windows 10 with RDP. I already have the "Let Windows manage my default printer" option turned off. Does anyone have an idea for me?

    Windows10_DefaultPrinterSettings.PNG

    OMG that is exactly the situation I am having. It has been bugging me for some time now. What I hate is that when I come in to work and want to print something like an email, my default printer has been changed to the Zebra label printer!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •