Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Mar 2016
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Excel 2003 on Windows 10 (Shortcuts in the 'Open' dialog)

    Hi, I've noticed a thread about Excel 2003 compatability with Windows 10 on here but this is a bit more specific.

    On my desktop I have shortcuts (either to a folder on the network drive or to a specific xls file).

    I'm in Excel and click File>Open and navigate to my desktop. I can see my shortcuts but Excel refuses to open them.

    If I double click, nothing happens. If I single-click and then click the Open button (bottom right) absolutely nothing happens.

    Has anyone else seem this issue. Its very frustrating to have to resort back to navigating through all your folders to select a file whose shortcut is sat nicely on the desktop laughing at me!

    If an xls file is actually located on the desktop then it opens fine but a shortcut? No sir!

    Hope someone can help with this.

    Thanks
    John

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    Have you double checked the shortcut properties?

    Joe

  3. #3
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,401
    Thanks
    447
    Thanked 404 Times in 376 Posts
    Try putting the following in as the target of your shortcut: "C:\Program Files (x86)\Microsoft Office\Office14\excel.exe" "filename.xls"

    You will also need to put the following for "Start In" in your shortcut: "C:\Program Files (x86)\Microsoft Office\Office14"

    (Substitute the actual path to Excel and the actual name of the spreadsheet for what I have put.)

    Doing your shortcuts this way will mean that Windows will have no trouble deciding what program to run with the spreadsheet in question when you double click on the shortcut.

    A better way would be if you could associate files of type "XLS" with Excel 2003; but this will get you by for now.
    Last edited by mrjimphelps; 2016-03-01 at 16:52.

  4. The Following User Says Thank You to mrjimphelps For This Useful Post:

    AdamKertesz (2016-03-01)

  5. #4
    New Lounger
    Join Date
    Mar 2016
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi, thanks for the replies. There is nothing wrong with the shortcut and Excel knows that it is responsible for opening .xls files. (If I double click the shortcut on the desktop it opens in Excel immediately).

    I've read a comment here (https://ca.answers.yahoo.com/questio...0154741AANnoCn) (Search for darwinlisa post) that seems to confirm my theories - Microsoft have purposely crippled Office 2003 on Windows 10. It says that .lnk (shortcut files) now no longer work in the Open/Save dialog boxes.

    So it seems like its not a bug but I'd be interested to see if anyone else is seeing this and hope there is some sort of tweak for it.
    Thanks
    John

  6. #5
    New Lounger
    Join Date
    Mar 2016
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thought it would be worth re-iterating this point as it doesn't seem to have been picked up.

    Its not just excel shortcuts that it won't action, its any shortcut (even to a folder).

    Lets say I have a file in C:\user\john\my documents\house\garden\hoses\fittings\spreadsheets

    If I have a desktop shortcut to the 'spreadsheets' folder Excel can see the shortcut to this folder but refuses to go into it. I am then left to go to My Computer>C>Users and navigate through like that.

  7. #6
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,401
    Thanks
    447
    Thanked 404 Times in 376 Posts
    If, in fact, Microsoft has purposely crippled Office 2003 on Windows 10 (not sure that they have, but if...), then it seems that your only option is to try my suggestion in #3 above. Did you try it, and did it work for you? It should work, since you can get into Excel 2003 by double-clicking on Excel's icon.

    By the way, it's not Excel which knows that it is responsible for opening .xls files; it is Windows which associates file extensions with the appropriate programs.

  8. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    Works fine with Excel 2016. I think Microsoft changed the underlying API and the 13 year old Office 2003 does not know how to interface with the new rules.

    Joe

  9. #8
    New Lounger
    Join Date
    Mar 2016
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks again for the replies. I would definitely expect Excel 2016 to work :-)

    mrjimphelps - I haven't tried your idea because the issue is more related to folder shortcuts rather than xls shortcuts. It seems like your suggestion would probably work if I was linking to a spreadsheet but for example my boss has a shortcut on his desktop which points to his folder on the network drive. If he needs something from there then he just navigates to his desktop and opens the shortcut to his folder and then selects any spreadsheet he needs.

    The workaround for Excel is simply to go his actual desktop (not through Excels Open dialog) and double click the shortcut for his folder on the network drive then open the s/s from there.

    Unfortunately the same can't be done for other office 2003 programs. If you're in Outlook and writing an email then want to attach a file to it, you simply cannot use the handy folder shortcut you have on your desktop to find the file you want. You must work your way through the folders.

    I perhaps could just add these buried folders to the 'My Network Places' in the open dialog but again, if there is a way around it, it would be really handy.

    Thanks again
    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •