Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Solomons, MD, USA
    Posts
    18
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Win 10: Setting default apps?

    Win 10 > Settings > System > Default Apps - How do I activate a new default? For example, if I click on Web Access choices come up including Chrome, Firefox, etc. If I click on Firefox nothing happens, same if I double click or hit enter. Same problem for Photos and others. How do I change the default?

    Whitey

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,435
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Whitey,

    When you set the default app you are telling Windows which app to open when your double click on a certain file type in Windows Explorer.

    In the case of a Web Browser that would be .htm or .html file. Now if you want a URL to automatically open In FF (or other browser) you need to set that as the default browser in the browser itself via the Tools->Options menu.

    The following graphic is from Pale Moon (a FF fork).
    PMOptions.PNG

    You'll notice that it says to check each time PM is started to make sure it is the Default. If I should change this in say Chrome. The next time I started PM it would prompt me to change it back to PM if I so desired. So what you need to do is go into the settings of the Browser you want to be your default and make the change there.

    This is what Chrome tells me since I have PM set as my Default.
    ChromeDefault.PNG

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Solomons, MD, USA
    Posts
    18
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thanks for your reply. I do have Firefox set as my default browser and have no problems with it. Each time I click the browser key (Microsoft 4000 keyboard) it automatically brings up Firefox. My question was why doesn't it appear in Settings > System > Default Apps. Could it possibly be because I rarely use Windows Explorer? I use Opus instead.

    Whitey

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,435
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Whitey,

    Sorry I misunderstood your question.

    My machine does not seem to have the same problem:
    SetDefaultApps0.PNG

    You may be able to fix it by using the Set defaults by app selection.
    SetDefaultApps.PNG
    Then browsing to C:\Program Files (x86)\Mozilla Firefox
    and then selecting the Firefox.exe file. I'm pretty sure that's how I got Pale Moon to show up in my list.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. The Following User Says Thank You to RetiredGeek For This Useful Post:

    Whitey (2016-03-24)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •