Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Jacksonville,FL, USA
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Receiving Message "Class not registered" whenever I try to view any .jpg file

    Whenever I attempt to view any .jpg file, I receive a pop-up stating "Class not Registered". However the thumbnails are displayed fine if I open File Manager and point to any folder containing .jpg files.
    I know the files are not damaged as I can open them with no issues using Photoshop and Lightroom. It's only whatever viewer that Windows-10 is using, that appears to be having the problem.

    Anyone have any idea what the issue is?
    Thanks!

    Bill

  2. #2
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,571
    Thanks
    471
    Thanked 417 Times in 389 Posts
    Try setting the default Windows program for .jpg files either to Photoshop or to Lightroom.

  3. #3
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,885
    Thanks
    119
    Thanked 813 Times in 728 Posts
    Try running SFC /scannow in an administrative command window.

    If that doesn't help, there are some other things to try here:
    http://windowsreport.com/class-not-r...ed-windows-10/

    Jerry

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •