Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Canberra City, Australian Capital Territory, Australia
    Posts
    133
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Network TCP/IP numbers do not stick

    I have two computers both operating Win2000 (desktop and laptop) networked with Internet Sharing enabled on the desktop. We find that every time the laptop is closed down (or the user logs off) it looses the TCP/IP settings for the desktop (192.168.0.1) and reverts to an older setting.

    We have deleted and re-installed TCP/IP repeatedly but still each time the laptop is started it shows the old settings. Changing the settings to the current TCP address allows Internet Sharing to operate for that session only.

    Can someone please tell me how to get the laptop to retain the new address of the desktop so Internet Sharing works without all the resetting of addresses?

    Thank you

    Noel

  2. #2
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Roanoke area, Virginia, USA
    Posts
    3,729
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Network TCP/IP numbers do not stick

    let me make sure i understand it correctly:
    desktop is the ICS host and when the laptop is shutdown and restarted it loses the TCP/IP?

    The ICS host is 192.168.0.1, the laptop gets it's assignment from the host (desktop). It's supposed to give the IP to the laptop when it joins the network, something like 192.168.0.8. Wild guess, if you run ipconfig from the command line, i'll bet the laptop's IP is 169.xxx.xxx.xxx. Correct?

    That means the laptop is set to be browse master and assigns itself an IP before the DHCP server in the ICS host can. I know where to disable it in win9x but not sure in win2k or even if win2k has that option. look in the network settings.

  3. #3
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Canberra City, Australian Capital Territory, Australia
    Posts
    133
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Network TCP/IP numbers do not stick

    Dear MJ,

    Thank you for your help and suggestions. I suspect you are near the answer - but!

    First, yes the desktop is (or should be) the ICS host. Yes when we reset the TCP/IP addresses in the laptop then shut it down and then restart (or even log off and log on as another user) the old TCP/IP addresses are back.

    Perhaps I should explain that the TCP/IP addresses that will not go away are the ones I put in the laptop when I first loaded Win2000 on it and represented the network set up I had at that time (in case it is relevant the address of the laptop was and remains 192.168.20.3 and the old address of the desktop was 192.168.20.2). You are correct the desktop now has the address 192.168.0.1.

    Running ipconfig from the command line in the laptop gave this result -
    IP Addresss 192.168.20.3
    Subnet mask 255.255.255.0
    Default Gateway 192.168.20.2

    I went to Networking, Local Area Network and reset the TCP/IP Properties from the above address to Obtain and IP Address Automatically and Obtain DNS Address Automatically, then ran ipconfig again getting -
    IPAddress 192.168.0.10
    Subnet mask 255.255.255.0
    Default Gateway 192.168.0.1

    Well and good and Internet Sharing worked.

    But log off as Administrator and log on as myself back to the first set of responses.

    Resetting the Local Area Networking to Automatic again gave the correct result, but log off and it is gone.

    I can not see any setting that I can disable, so I have tried stopping the DHCP Service to see what that does, but looging off and then on again resulted in the old response to ipconfig.

    So I am at a loss. It really looks like the old TCP/IP addresses are hard wired in. But I am reluctant to start playing with the Registry unless I know where to look.

    Can you suggest anything else?

    NoelM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •