Page 1 of 2 12 LastLast
Results 1 to 15 of 25
  1. #1
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts

    How to get a Libre Office document to open as the active window in the foreground

    I've used Libre Office for some time now and like it, but there is one small issue I'd like to resolve. When I open an existing LO document or spreadsheet, say by clicking on it in Windows Explorer, the LO splash screen appears, after which the document/spreadsheet opens. The problem is that the newly-opened LO document/spreadsheet window isn't in the foreground as the active window, but is instead hidden behind the Windows Explorer window, so I have to search out the document/spreadsheet I just opened and click on it to make it the active window and to see it in the foreground.

    This is hardly a major issue, but it is annoying, and though I've searched through the LO Options screen, I can't seem to find a way to make this change, or else I've missed it completely. If anyone can help with this, I'd be much obliged.

    Cheers,
    HH33
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

  2. #2
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,072
    Thanks
    0
    Thanked 259 Times in 248 Posts
    Are both the Windows Explorer [File Explorer on Win8/8.1/10] and LibreOffice opening Maximized? If so first resize the file management window so it covers a smaller portion of the screen then double-click the file to open it. If the Explorer window is still on top you might be able to simply click once in the visible part of the document to change the focus, bring that window to the forefront.

  3. #3
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts
    Hi, Berton,

    Usually neither Windows Explorer (in W7 Pro) nor the LO document are full-screen, so I can see the newly-opened LO document appear behind Windows Explorer, at which point I do exactly as you suggest and click on the LO document in the background to make it the active window in the foreground. If Windows Explorer is full-screen, then I have to click on the LO document tab at the bottom of the screen.

    The point is that I shouldn't have to do this when I open a document. In virtually every other software application I can think of, a new document, spreadsheet, or window of whatever kind opens in the foreground, having focus as the active window. I assume that this logical standard practice is likewise possible in LO, but for some reason I am unable to find the setting to tweak, hence my question.

    Cheers,
    HH33
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

  4. #4
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,072
    Thanks
    0
    Thanked 259 Times in 248 Posts
    There's some pages at https://duckduckgo.com/?q=new+progra...+top&ia=videos that speak to the problem, may be of some help.

  5. #5
    2 Star Lounger
    Join Date
    Mar 2010
    Location
    Charlotte, NC
    Posts
    132
    Thanks
    1
    Thanked 19 Times in 18 Posts
    I don't see that issue with LO 5.1 on Windows 10. Right clicking and selecting Open works as does double clicking the file. In both cases the LO spreadsheet opens with the focus.

  6. #6
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts
    Thanks for that link. It started me searching again using new search terms and I came across this page which appears to answer my problem. However, as it involves changing the Registry - which I only do rarely, cautiously, and after backing it up - I thought I'd check before I do it to see if anyone on this forum knows of a reason why this change would be an unwise thing to do. It seems innocuous enough, but I don't want to inadvertently cause myself a problem, as I have no time to muck about with a self-inflicted major computer issue at the moment.

    Thanks in advance for any and all thoughts on this.

    Cheers,
    HH33
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

  7. #7
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,143
    Thanks
    101
    Thanked 579 Times in 464 Posts
    HH33 - I've just checked on both x64- and x32-bit versions of Windows 7 and the default registry value for ForegroundLockTimeout appears to be 200000 (decimal). Changing the value to zero is a minor change that is easily reversible so I can't think of any reason why you shouldn't try it.

    If it helps, I've attached a zip file that includes 2 .REG files. After checking them using Notepad, double-click on ForegroundLockTimeout (amended).reg to change the value to zero, as advised in the article you referenced. Alternatively, double-click on ForegroundLockTimeout (original).reg to change the value back to the default again.

    Hope this helps...
    Attached Files Attached Files

  8. #8
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    Quote Originally Posted by HealingHands33 View Post
    Thanks for that link. It started me searching again using new search terms and I came across this page which appears to answer my problem. However, as it involves changing the Registry - which I only do rarely, cautiously, and after backing it up - I thought I'd check before I do it to see if anyone on this forum knows of a reason why this change would be an unwise thing to do. It seems innocuous enough, but I don't want to inadvertently cause myself a problem, as I have no time to muck about with a self-inflicted major computer issue at the moment.

    Thanks in advance for any and all thoughts on this.

    Cheers,
    HH33
    I get this behavior too. Interestingly when I just run LO it presents itself right up front.
    I have not researched this but my first thought on the matter is if all other programs behave why make a generic change to the Reggy? If you get no satisfaction here after a suitable time maybe there is a LO forum.

    BTW I found an interesting bit of info in that link:
    TIP: You can also set the registry keys to auto focus for a windows where you drag your mouse. Follow the procedure below

    1. Open Registry Edit as explained above, Navigate to the following path in the registry:

    <tt>[HKEY_CURRENT_USER/Control Panel/Mouse/ActiveWindowTracking</tt> ]

    2. Set the value to 1
    I have been wondering how to do this! IIRC this is a GUI option in Linux bit not Windows. Seems just backwards!
    David

    Just because you don't know where you are going doesn't mean any road will get you there.

  9. #9
    Silver Lounger wavy's Avatar
    Join Date
    Dec 2009
    Location
    ny
    Posts
    2,373
    Thanks
    235
    Thanked 147 Times in 136 Posts
    Now more strangeness! After testing OL behavior (NO changes made) I just clicked on a file that a few minutes past opened in the background and found it opened in the foreground!

    David

    Just because you don't know where you are going doesn't mean any road will get you there.

  10. #10
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts
    Quote Originally Posted by Rick Corbett View Post
    HH33 - I've just checked on both x64- and x32-bit versions of Windows 7 and the default registry value for ForegroundLockTimeout appears to be 200000 (decimal). Changing the value to zero is a minor change that is easily reversible so I can't think of any reason why you shouldn't try it.

    If it helps, I've attached a zip file that includes 2 .REG files. After checking them using Notepad, double-click on ForegroundLockTimeout (amended).reg to change the value to zero, as advised in the article you referenced. Alternatively, double-click on ForegroundLockTimeout (original).reg to change the value back to the default again.

    Hope this helps...
    Hi, Rick,

    Many thanks for your kindness in including the Zip file. I was comfortable in making the change directly without the file, but it was very thoughtful of you to provide it.

    I changed the ForegroundLockTimeout value to zero, rebooted, and bingo, Libre Office opened a document full screen, in the foreground, and with the focus, rather than opening in the background and leaving the focus on the Windows Explorer window within which I'd clicked the LO file.

    Cheers,
    HH33
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

  11. #11
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts
    Quote Originally Posted by wavy View Post
    I get this behavior too. Interestingly when I just run LO it presents itself right up front.
    I have not researched this but my first thought on the matter is if all other programs behave why make a generic change to the Reggy? If you get no satisfaction here after a suitable time maybe there is a LO forum.
    Hi, David,

    Thanks for your posts. Like you, if I just start up Libre Office directly, I find that the LO window opens in the foreground and with the focus, but if I click on a LO file in Windows Explorer, the LO file opens behind the Windows Explorer window. I have no idea why the opening procedure differs in the two scenarios.

    I very much agree with you that if all other programs are behaving themselves, it seems somehow inappropriate to make a generic change to the Registry just to cure a problem with a single piece of misbehaving software. In the short run, making that generic change resolved a minor annoyance for me, but when I have time, I'll join the Libre Office Forum and see what I can learn there about a cure that is LO-specific.

    The problem is that I've been spoiled. Over the years, I've come to respect the wide diversity of experience and knowledge here in the Lounge, so I normally make this my first port of call when I'm wrestling with any computer issue and I can honestly say that I'm very rarely disappointed.

    Cheers,
    HH33
    Last edited by HealingHands33; 2016-03-25 at 05:03.
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

  12. #12
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,143
    Thanks
    101
    Thanked 579 Times in 464 Posts
    Quote Originally Posted by HealingHands33
    Many thanks for your kindness in including the Zip file. I was comfortable in making the change directly without the file, but it was very thoughtful of you to provide it.

    I changed the ForegroundLockTimeout value to zero, rebooted, and bingo, Libre Office opened a document full screen, in the foreground, and with the focus, rather than opening in the background and leaving the focus on the Windows Explorer window within which I'd clicked the LO file.
    I'm pleased the issue's resolved for you. Many thanks for letting us know. Not everyone's comfortable using the registry directly so I thought I would add the attachment just in case. Who knows, others may land here after searching on the same issue (plus, as a LibreOffice user myself, I thought it interesting enough to create the .reg files and keep copies on my USB 'fix' stick so I wouldn't have to search on the issue again if I ever experience it. )

  13. #13
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts
    Well, it appears that I may have celebrated too soon. While LO appears to open in the foreground and with focus when I start LO from scratch, I've now had occasions when - with LO open, but minimized - clicking on a document or spreadsheet in Windows Explorer still results in that doc/xls file opening in the background. I've played with it for a while, but have so far been unable to document a clear pattern of behavior. It looks as though I may need to go to the LO Forum after all when I have some time to research it.
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

  14. #14
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,143
    Thanks
    101
    Thanked 579 Times in 464 Posts
    In post #3 you mentioned just Win 7 Pro (both 64-bit versions) but it's not clear whether the issue happens on both your desktop and laptop or just one?

    Does it happen on your HP Mini? (i.e. is the issue reproducible on a 32-bit version of Windows?)

    What version(s) of LibreOffice are you using? (i.e. Both version no. and 'bitness')

  15. #15
    2 Star Lounger
    Join Date
    Sep 2011
    Posts
    193
    Thanks
    22
    Thanked 20 Times in 11 Posts
    At the moment, the only experience I have of this issue is on my W7 Pro 64-Bit desktop, running LO Version 5.0.5.2 (64-Bit), on which I do most of my day-to-day computer work. I normally only use the laptop and (very rarely now) the HP Mini when I am traveling or teaching, so I can't report on those at the moment. I can check the issue on one or both of them, but it may be a while before I can get the time to do that. In the meantime, perhaps other Loungers will weigh in on this question.

    Thanks for your post and your interest in this issue.
    Windows 7 Pro, 64-Bit, SP1 on desktop
    Windows 7 Pro, 64-Bit, SP1 on HP ProBook
    Windows 7 Home Premium, 32-bit, SP1 on HP Mini 5103
    Windows XP/Media Edition, SP3 on OLD Dell laptop
    Samsung Galaxy S5 running Lollipop 5.0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •