Results 1 to 10 of 10
  1. #1
    2 Star Lounger
    Join Date
    Jan 2007
    Posts
    123
    Thanks
    13
    Thanked 1 Time in 1 Post

    Exclamation Word 2010: how to make simple header on each page, "Blah blah page [x] of [y]" ?

    [Workaround found: see post #7]

    Hi all,

    I am trying to do something which I found very simple in Word 2003 and 2007, but which is stumping me in Word 2010 even after half an hour.


    I have a four page document, nothing fancy in it, just text, a few bullet points etc. I now want to add the following to each page:


    -- in the upper left hand corner, in 9 point Calibri font, underlined, this header: "John Smith Bio, page [x] of [y]" where x is the current page number and y is in this case always 4.


    (If making it automatically know there are 4 pages is a stretch, I can live for now, as I'm in a hurry, with "John Smith Bio page [x] of 4")


    It would take quite a while to describe everything that I've tried. All the templates, wizards etc seem to let me do everything except what I want. What look like they are blue fields in Design mode don't seem to let me type anything in them.


    Could someone please take pity and just tell me, step by step, what to do? I'd be very grateful. I imagine it's easy to do once you know the well-buried secret. This is rather time-sensitive.
    Last edited by lingyai; 2016-04-09 at 13:39.

  2. #2
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,054
    Thanks
    2
    Thanked 417 Times in 346 Posts
    The process is exactly the same in Word 2010 as it was in Word 2007:
    1. Click anywhere in the page header
    2. Click on Page Number>Top of Page, then scroll down to and select, say, 'Bold Numbers 3'
    3. Type 'John Smith Bio, ' before 'Page'.
    4. Press Ctrl-A and apply the 9 point Calibri font.
    Done.
    Last edited by macropod; 2016-04-09 at 08:41.
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  3. The Following User Says Thank You to macropod For This Useful Post:

    lingyai (2016-04-09)

  4. #3
    Star Lounger Graham Mayor's Avatar
    Join Date
    Mar 2016
    Location
    Cyprus
    Posts
    68
    Thanks
    0
    Thanked 24 Times in 24 Posts
    From the Insert Tab click Header > Edit Header.
    The header view will open.
    Type "John Smith Bio, page "
    Press CTRL+F9
    between the brackets type PAGE thus { PAGE }
    after they second bracket type " of " then press CTRL+F9 again
    Between the second set of brackets type NUMPAGES, thus { NUMPAGES }
    Press CTRL+A then ALT+F9 to toggle the display
    Close the header.
    Graham Mayor - Word MVP
    http://www.gmayor.com

  5. The Following User Says Thank You to Graham Mayor For This Useful Post:

    lingyai (2016-04-09)

  6. #4
    2 Star Lounger
    Join Date
    Jan 2007
    Posts
    123
    Thanks
    13
    Thanked 1 Time in 1 Post
    Thanks gentlemen!

    Macropod, sorry, I actually never did this before in Word 2007, rather only in 2003.

    Graham Mayor, thanks very much, nothing about that was intuitive from the outset, yet as you've shown, it's easy once you're guided. Thanks a lot.

    However, a problem persists...it's not appearing on each page.

    In fact one thing that was blowing my mind was that when trying to enter a header via "Edit Header" I could see my cursor move but nothing I typed appeared. I've finally figured out that this is because I was on page 1, and for some reason Word has decided that the header should only appear only on certain pages, excuding the page I was working on, page 1.

    In fact, right now, the header reads the way I want it , but appears only on pages 2, 3 and 5 of my 5 page document. I don't get what it's thinking; anyway, I never knowingly asked for that. In the header design tab, "Different First Page" and "Different Odd & Even Pages" are NOT checked.

    Anyway, how can I make these appear on every single page?

    Regards

    Ken

  7. #5
    Star Lounger Graham Mayor's Avatar
    Join Date
    Mar 2016
    Location
    Cyprus
    Posts
    68
    Thanks
    0
    Thanked 24 Times in 24 Posts
    It certainly sounds like you have the odd and even page option set. However the header view has a label on the page itself which will tell you which header you are working in. Copy the header text you have created and click Next/Previous and ensure that the header appears in all the header ranges. If not paste it there and/or check the link to previous check box.
    Graham Mayor - Word MVP
    http://www.gmayor.com

  8. #6
    2 Star Lounger
    Join Date
    Jan 2007
    Posts
    123
    Thanks
    13
    Thanked 1 Time in 1 Post
    I'm sorry Graham, I don't know why but when I click on Previous / Next nothing happens. And if I copy the text from the header on page 2 and manually go to the header space on page 1, and paste, it just creates a blank extra row. It's like there is text on page 1, it's just invisible. Gosh, how hard can this be? Any ideas what could be wrong?

  9. #7
    2 Star Lounger
    Join Date
    Jan 2007
    Posts
    123
    Thanks
    13
    Thanked 1 Time in 1 Post

    Workaround found

    After messing around with this for another hour in Word 2010, I downloaded OpenOfffice, opened the document in its word processor, figured out how to do it in around 5 seconds, did it, opened it in MS Word, and now it's as it should be.

    By the way, I'm not techno-illiterate; I wrote an entire book in Word 2003, about Excel. But I guess I'm not sophisticated enough for the "user experience enhancements" in later "improved" versions of Word.

  10. #8
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,054
    Thanks
    2
    Thanked 417 Times in 346 Posts
    Quote Originally Posted by lingyai View Post
    After messing around with this for another hour in Word 2010, I downloaded OpenOfffice, opened the document in its word processor, figured out how to do it in around 5 seconds, did it, opened it in MS Word, and now it's as it should be.
    That's a gross overkill for a trivial problem resulting from a failure to understand to use Word. All you needed to do any one of:
    1. Remove the Section break between the first & second pages;
    2. Scroll down to the second page's header, select it, then and click on the 'Link to Previous' button; or
    3. Copy the first page's header, then scroll down to the second page's header, select it and paste.
    Any of those would have resolved the problem.
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  11. The Following User Says Thank You to macropod For This Useful Post:

    Charles Kenyon (2016-04-09)

  12. #9
    2 Star Lounger
    Join Date
    Jan 2007
    Posts
    123
    Thanks
    13
    Thanked 1 Time in 1 Post
    I'm good, thanks.

  13. #10
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    Charles Kyle Kenyon
    Madison, Wisconsin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •