Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Apr 2016
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Issues trying to join a domain in a VM

    Hello everyone,
    Recently I decided to start learning Windows Server so installed it to play around at home, I ran into somewhat of a problem and think that I may need help.

    I have Windows Server 2012 r2 running in a VM and Windows 8.1 also running in a VM. After installing the server OS I added roles: DNS, AD, DHCP. The server was promoted to a DC. Both VMs can ping each other and connect to internet successfully, they are on the same network. But I can't seem to get the Win 8 VM to join the domain. Firewalls on both VMs are fully disabled.

    Any pointers would be greatly appreciated.

    This is the error I receive when I try to join the domain:
    tgkCZgd.png

    Local server
    hMeHL34.png

    DHCP
    Ieqztbr.png

    IP config & ping between the VMs
    ZvAux3E.png

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,176
    Thanks
    47
    Thanked 982 Times in 912 Posts
    My guess is both have IP addresses and DNS pointing to an external server, not the Server 2012 box. Windows needs to use the domain DNS for joining to work. (AD should always use the DC as DHCP and DNS, then add pointers and routes for external access.)

    1. Set up both boxes with network adapters on an internal / custom network - no connection to anything else.
    2. Set up the server with a fixed IP address in your range, e.g. 192.168.22.10.
    3. Set up DHCP scope to have the DNS server the same as your server IP.

    Now the W8.1 box will obtain an IP and have DNS pointing to the server.
    Ping srv1.com and you should get the IP address of the server.
    Join the domain.

    cheers, Paul

  3. #3
    New Lounger
    Join Date
    Apr 2016
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Paul T View Post
    My guess is both have IP addresses and DNS pointing to an external server, not the Server 2012 box. Windows needs to use the domain DNS for joining to work. (AD should always use the DC as DHCP and DNS, then add pointers and routes for external access.)

    1. Set up both boxes with network adapters on an internal / custom network - no connection to anything else.
    2. Set up the server with a fixed IP address in your range, e.g. 192.168.22.10.
    3. Set up DHCP scope to have the DNS server the same as your server IP.

    Now the W8.1 box will obtain an IP and have DNS pointing to the server.
    Ping srv1.com and you should get the IP address of the server.
    Join the domain.

    cheers, Paul
    Hi Paul,

    Thank you for the advice. I was able to successfully join the domain after following your tips.

    I changed the NIC settings on each VM to be a part of a separate network not connected to the host machine and then manually changes the settings on the Win 8 VM to have its DNS and default gateway pointing towards the server, then I specified the IP address on the server.
    Win 8: 192.168.1.11
    Default gateway: 192.168.1.1
    DNS Server: 192.168.1.1

    Server: 192.168.1.1
    Default gateway: 0.0.0.0
    DNS: 192.168.1.1

    Win 8 machine is now a member of the domain, I will have to worry about internet connectivity at a different point.

    Many thanks for the help!

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,176
    Thanks
    47
    Thanked 982 Times in 912 Posts
    You can't do internet access properly with VM Player because you can't use a NAT connection and turn off the DHCP server.
    To gain internet access add a second network card to the server and connect it to the internet network (NAT). Then set up the server as a router.

    cheers, Paul

  5. The Following User Says Thank You to Paul T For This Useful Post:

    RickRoss (2016-04-09)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •