Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Sydney, NSW, Australia
    Posts
    19
    Thanks
    8
    Thanked 0 Times in 0 Posts

    MS Outlook 2010 won't display linked images (Windows 7 Pro x64)

    This seems similar to a recent thread from Bundaburra for Outlook 2016. In my case it is Outlook 2010 and the 2016 solution does not work for me.

    For the last several weeks, my MS Outlook 2010 client often does not display linked images (maybe half of my HTML formatted emails with images). Where the image should display, a placemarker box displays a red "X" in a box in the top LH corner, with the text:

    "The linked image cannot be displayed. The file may have been moved, renamed, or deleted. Verify that the link points to the correct file and location."

    Yet, if I delve into the HTML source and find the link, I can copy and paste it into a browser and the browser will download and display the missing image with no problems. I have tried this several times with the same result. A likely clue seems to be that all the failed links that I have checked out have "https://", and successful links have "http://".

    Do I have something set up incorrectly? I can't find anything relevant in File | Options.

    I have searched online for solutions. There was a spate of this type of problem circa 2010, but these mostly involved older versions of Internet Explorer which I don't use (but understand that Outlook probably uses part of IE to process HTML emails). My system has IE11 which is up to date.

    Another suggestion was interference from my AV security system. I use MS Essentials. I have tried turning it off briefly to see if it made a difference, but no effect.

    Since everything was working OK until a few weeks ago, I was wondering if the cause could be a MS patch - to Outlook or to Office generally, or even to Windows. If so, any ideas as to which patch it might be?

    Has anyone else experienced this problem? Any advice appreciated.

    Thanks,
    Pete.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    See if Red X's in Email Messages. Be sure to work your way through the whole article.
    Joe

  3. The Following User Says Thank You to JoeP517 For This Useful Post:

    pegleg pete (2016-05-05)

  4. #3
    New Lounger
    Join Date
    Feb 2012
    Posts
    10
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Joe, I went through the material in that link. But was unable to get the images to display. Sometimes we get a small box as in the attachment or a large box with the image title, which changes quickly to a small square with red 'X' and text "the link image cannot be displayed".

    Dick
    Windows 7 Home Premium
    MS Office 2010
    Attached Images Attached Images

  5. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Sydney, NSW, Australia
    Posts
    19
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Thanks for the Slipstick link. Scanning down the page, the heading "Encrypted page setting" caught my eye because only images with "https:" fail to display. I examined the Advanced IE Internet option "Do not save encrypted pages to disk" and saw that it was checked. I unchecked it and immediately the encrypted Outlook images started displaying again.

    I never use IE as a browser and had never seen this option before. I can only assume that it was set by a recent Cumulative Security Update to IE. Either that or the space allocated by default to saving encrypted pages (wherever that is) finally filled up after 18 months of using this PC.

  6. #5
    New Lounger
    Join Date
    Feb 2012
    Posts
    10
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I looked at that too, but in my case it was not checked.

  7. #6
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 38 Times in 24 Posts
    In my case, it was because the "Temporary Internet Files" folder was set up incorrectly. It is defined in Internet Explorer, and even if you never use IE for browsing (as I don't), it still needs to be set up correctly, because there is an interaction between IE and Outlook. As I understand it, when you open an Outlook message with linked images, the images are stored in "Temporary Internet Files" and then retrieved from there for display. If for some reason that can't happen, then you see the red X and its message instead. So I would suggest going into IE, Internet Options, and on the General tab, click Settings. Then, on the "Temporary Internet Files" tab, see what it says for "Current location". If that looks OK, click "View files" and see if anything is there. In my case I had to use the "Move folder" button a few times to to delete and recreate the folder. I finished up just putting it in the root of my C drive, so the "Current location" shows as "C:\Temporary Internet Files\", and that now works for me. Also be sure that "Disk space to use" is adequate. I have mine at 250 MB

    Also be aware that some IE security settings can affect how it works. A while ago, Fred Langa gave us a list of settings to change, to make IE more secure. I implemented all his suggested changes, and the red X problem came back, so one (at least) of his suggestions was blocking the images. So I undid the changes, and it was OK again. The other thing you might try is just an IE reset, on the "Advanced" tab. If you do that, it may change a setting which requires a restart, so then restart your computer.
    Last edited by Bundaburra; 2016-05-05 at 20:28.

  8. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Sydney, NSW, Australia
    Posts
    19
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Thanks Bundaburra for your comments. I had cleared the TIF folder early on as it was one of the suggested actions I found in my original research. I just checked it again - there were now 72 files (all cookies) for a total of 21.5 MB. My "Disk space to use" is also set to the default 250 MB. So it was less than 10% full. Anyway, I have cleared it again.

    Doesn't TIF cache ALL downloaded URLs? In my case it was only encrypted images (with "https:" prefix) that failed to display. If the TIF folder was full (250 MB) I would have expected that ALL images would have failed to display. In any case, unchecking the Advanced option "Do not save encrypted pages to disk" did the trick. Although this seems a bit counterintuitive - unchecking would cause encrypted images to be saved in TIF, eventually tending to fill it up. Obviously I don't understand how this option is used.

  9. #8
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Edinburgh, UK
    Posts
    237
    Thanks
    24
    Thanked 49 Times in 21 Posts
    Pete - I think that my experience, described here - Images showing as red x - matches the problem that you are describing.

    Good luck.

  10. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Sydney, NSW, Australia
    Posts
    19
    Thanks
    8
    Thanked 0 Times in 0 Posts
    John, it certainly sounds like the same problem I had. Resetting the whole of IE probably unchecked the "Do not save encrypted pages to disk" option (among many other things). A kind of shotgun approach! Unchecking this flag is what fixed it for me.

    Thanks for your comment.

  11. #10
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Edinburgh, UK
    Posts
    237
    Thanks
    24
    Thanked 49 Times in 21 Posts
    Pete - glad to know that you're fixed now.

    What MS doesn't tell you is that Outlook uses IE to manage images in and attached to eMails, even if you never use it as a browser, as you say that you do not, and I never do, unless forced to for some reason. Hence, the IE cache fills up, even though you don't use it as a browser.

  12. #11
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 38 Times in 24 Posts
    "Do not save encrypted pages to disk" is one of Fred Langa's suggested security improvements in IE, and in fairness to Fred, he did say that changing such settings could have unexpected consequences. Here is his comment on this one:

    "Many webpages — such as, again, those on banking sites — are SSL/TLS-encrypted for your safety. SSL/TLS encryption makes the pages initially indecipherable to snoops. However, Internet Explorer can store fully decrypted, plain-text versions of these pages in the Temporary Internet File area on your PC, making these pages potentially vulnerable to snooping.

    Enabling this option will prevent IE from saving copies of decrypted SSL/TLS pages."

    Fred did not say that this setting effectively destroys Outlook's ability to display images from a https site (of which there are plenty nowadays), so perhaps he should not have recommended that particular setting?

    You can set IE to "Delete browsing history on exit", but if you rarely use IE, that's not going to help much with regard to the TIF filling up. My solution is to have the following commands in a batch file, which runs periodically as a scheduled task:

    ::
    :: Delete any IE temporary files...
    ::
    cd "C:\Temporary Internet Files\Content.IE5"
    if errorlevel 1 goto next6
    del /q /s /f *.*
    :next6

    It it means that something has to be downloaded afresh, rather than retrieved from the TIF, that does not bother me.
    Last edited by Bundaburra; 2016-05-08 at 20:18.

  13. #12
    New Lounger
    Join Date
    Dec 2009
    Location
    Sydney, NSW, Australia
    Posts
    19
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Bundaburra - It's problematic. A case of one size does not fit all. As you pointed out, in the same article Fred Langa mentions that checking this option will cause problems downloading protected files.

    Going back even further, Susan Bradley (January 26, 2012 - Top Story) recommends unchecking the option to allow protected PDFs to download. This was for an older version of IE, but apparently still applies to IE11. She also links to a MS Support article 2549423 which says much the same thing. Apparently the default setting is UNchecked (why mine was checked I don't know - possibly it was set by a patch, or maybe I set it after reading the Langa article and forgot about it).

    In any case, it seems that a lot of functionality is unavailable with the option checked, but there is a potential security hole if it is UNchecked. Fortunately, the latter seems to be a problem only if/when you use IE as a browser (which I don't unless MS forces me to). So I think I am pretty safe leaving it unchecked. However, I like your workaround, and have saved your script for possible future use. Thanks.

  14. #13
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 38 Times in 24 Posts
    Pete - as a follow up to that: If you want to have a script like that run completely in the background, with no screen interaction, set the scheduled task to be run by a different user who does not log on. I have created a user named Subtask, because that is exactly what it does and nothing else. Set the task to be run by this user, and clear the box that says "Run only when user is logged on". Because the user is not logged on, you don't see anything when the task runs. It runs completely in the background, i.e. as a subtask.

    I agree with you about leaving the option unchecked and not using IE for browsing (I use Firefox). But shouldn't Firefox and other browsers have the same protection available? The Outlook problem highlights the interactions and dependencies between various MS products, some of which we probably don't even know about, but who knows if settings in IE can also affect other products such as Firefox? And it raises another question: if you want to see the linked images in an Outlook message, is that a security risk? (I do like the word "problematic".)

  15. #14
    New Lounger
    Join Date
    Dec 2009
    Location
    Sydney, NSW, Australia
    Posts
    19
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Bundaburra View Post
    Pete - as a follow up to that: If you want to have a script like that run completely in the background, with no screen interaction, set the scheduled task to be run by a different user who does not log on.
    Great idea! I will keep your suggestion in mind for when I need a background task.

    Quote Originally Posted by Bundaburra View Post
    I agree with you about leaving the option unchecked and not using IE for browsing (I use Firefox). But shouldn't Firefox and other browsers have the same protection available? The Outlook problem highlights the interactions and dependencies between various MS products, some of which we probably don't even know about, but who knows if settings in IE can also affect other products such as Firefox?
    I have always understood that Firefox is completely independent of Internet Explorer. Similarly Chrome. Outlook and IE are both MS products so it seems natural that they should both use common code to process HTML.

    Quote Originally Posted by Bundaburra View Post
    And it raises another question: if you want to see the linked images in an Outlook message, is that a security risk? (I do like the word "problematic".)
    It possibly is. That is why, by default, images are not automatically displayed in an Outlook message unless you have specifically asked for pictures to be downloaded and displayed, or have whitelisted the sender or the site in one of several ways. This applies to both "http:" and "https:" images. At least that is my understanding.

  16. #15
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 38 Times in 24 Posts
    I have something else to add to this saga, because I found that I was still getting the dreaded red X in some email messages, even though "Do not save encrypted pages" was not checked. But after I did a reset of IE, that stopped happening, so I guessed it was due to another of Fred's security settings. I found that if I started Outlook and displayed a message with http images, that worked, but if I then opened another message with https images, there was the red X. Conversely, if I started Outlook and opened that same message with the https messages, that would work, but if I then opened another message with just http images, there was the red X again. I eventually narrowed it down to the IE setting "Warn if changing between secure and not secure mode". By switching between Outlook messages with http and https links, I was effectively "changing between secure and not secure mode", but because I was not actually running IE it was not able to issue the warning, I did not see a prompt, and so nothing happened. That's my take on it anyway. All I know is that with "Do not save encryped files" and "Warn if changing" BOTH disabled, there are no more red Xs. (I hope ..... fingers crossed..??)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •