Results 1 to 9 of 9

Thread: Win 7 4TB HDD

  1. #1
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Win 7 4TB HDD

    Hi

    I cannot get my Win 7 system to recognise my new Western Digital 4TB HDD. It only recognises it as 1.64TB of unallocated space.

    I have formatted it as GPT with AOMEI Partition Assistant since I know MBR is not appropriate for a 4 TB HDD. In fact I have reformatted it back to MBR and then back to GPT in case there were any formatting issues. The Intel drivers are up to date, though I am not using RAID, as are Win 7 patches.

    Specs:
    Intel i5 760
    Gigabyte P55M-UD2 Motherboard
    8GB Memory
    Windows 7 64 bit
    All HDD SATA connectors are SATA 3Gb/s

    The MB is not a UEFI MB, but as I only plan to use the 4TB HDD for backup purposes, NOT to run the operating system, that should not be a problem from what I have researched.

    I have also read this Microsoft article on the subject: https://support.microsoft.com/en-us/kb/2581408

    Any ideas what I am missing please?

    Rob

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,203
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Sounds like a BIOS not seeing more than 2TB. Check the mobo site for specs.
    If you leave it unformatted what does Windows see?
    Is it connected to an internal SATA port?

    cheers, Paul

  3. #3
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have the latest BIOS for the MB.

    Win 7 sees the drive as 1.64 TB (see original post).

    Yes, on an internal HDD connected to a SATA 3 port.

    Rob

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,203
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Sounds like a mobo issue to me. Can you test the drive in another computer to be sure it's not a faulty disk?
    What model is the drive? (to be sure it's a 4TB disk.)

    cheers, Paul

  5. #5
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I tend to agree with you and think it is probably a mobo issue.

    The Western Digital Model Model No is WDC WD40EZRX-22SPEB0 and recognised by the HWiNFO64 program as 4000 GB.

    I can probably test it in another PC at the weekend and will report back.

    Rob

  6. #6
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I placed the HDD in another Win 7 PC over the weekend and it was correctly recognised as 4GB.

    Also double checked I had the latest BIOS on the original PC. So it does look like the MB/BIOS will not support a 4GB HDD under Win 7 which I find rather surprising.

    Rob

  7. #7
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,203
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Do you have odd settings for the hard disks?
    Is AHCI enabled?
    Try resetting to factory defaults - after making and testing a backup.

    cheers, Paul

  8. #8
    5 Star Lounger
    Join Date
    Oct 2013
    Location
    Phoenix, AZ
    Posts
    926
    Thanks
    554
    Thanked 137 Times in 128 Posts
    The only other things I can think of and I would not be optimistic would be to update the chipset and SATA drivers.

  9. #9
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for your inputs.

    Yes, AHCI is enabled and I don't think I have any odd settings on the hard drives.

    I have already checked chipset and SATA drivers and they are up to date.

    I may try resetting to factory defaults but not until I have full backups. Otherwise I will just buy another 2GB HDD for the PC and use the 4GB drive in a new PC I am building.

    Rob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •