Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Blacksburg, VA
    Posts
    19
    Thanks
    1
    Thanked 0 Times in 0 Posts

    read only can't be removed

    I am the only one who uses my Windows 10-64 bit computer with Office Professional 2013. A few weeks ago all my files were read only with I opened them. I need to save any changes under a different file name. I have tried right clicking on the file and going to properties and unchecking the read only, but it just comes back. I tried going through File Explorer and making the entire folder with read only unchecked. That makes it go through the files in that folder to apply the fix, but the the folder is still read only and most of the files in the folder are read only. What is going on? How can I fix this? It is very annoying to have to keep saving under a different name. Then I delete the old file and rename the newly saved file with the old name. I don't like this work around. I hope someone can help me.

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,167
    Thanks
    47
    Thanked 978 Times in 908 Posts
    It's probably a permission problem.
    1. Open File Explorer.
    2. In the address bar enter "%userprofile%", without the quotes.
    3. Right click on the "Documents" folder and select Properties > Security.
    4. Click Edit.
    5. Click on your user.
    6. Make sure all permissions are ticked. Tick any that aren't.
    7. Click OK and follow the prompts to complete the change including all sub-folders.

    cheers, Paul

  3. #3
    Bronze Lounger DrWho's Avatar
    Join Date
    Dec 2009
    Location
    Central Florida
    Posts
    1,501
    Thanks
    30
    Thanked 205 Times in 163 Posts
    First let me say, "I don't, and will NEVER use MS Office" and having said that, I'm wondering if you have ever installed the program, "Grant Admin Full Control" or even "Take Ownership" ??
    I install GAFC as one of the very first things I do when setting up any OS for the first time.
    That allows me to right click on any file or folder and become the OWNER of that file or folder.

    I'm thinking that if you take ownership of your Documents folder and all the files in it, you should be able to do what you want with those files.

    Just a thought......

    The Doctor
    Last edited by satrow; 2016-05-20 at 12:53. Reason: Removed irrelevant sentence.
    Experience is truly the best teacher.

    Backup! Backup! Backup! GHOST Rocks!

  4. #4
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    DrWho:

    Where can I download "Grant Admin Full Control" or "Take Ownership"?

    This is a problem I come across sometimes, particularly if one user creates a folder, and then another user wants to access that folder.

    Thanks.

    Jim

  5. #5
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    Jim,

    Here's the Registry Code for GrantAdminFullControl.reg
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\*\shell\runas]
    @="Grant Admin Full Control"
    "NoWorkingDirectory"=""
    
    [HKEY_CLASSES_ROOT\*\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
    [HKEY_CLASSES_ROOT\exefile\shell\runas2]
    @="Grant Admin Full Control"
    "NoWorkingDirectory"=""
    
    [HKEY_CLASSES_ROOT\exefile\shell\runas2\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas]
    @="Grant Admin Full Control"
    "NoWorkingDirectory"=""
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    Just save it to a text file with the Extension of .reg then double click the file to add it to the registry.

    Here's the code for TakeOwnerShipShortcut.reg
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\*\shell\runas]
    @="Take Ownership"
    "NoWorkingDirectory"=""
    
    [HKEY_CLASSES_ROOT\*\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas]
    @="Take Ownership"
    "NoWorkingDirectory"=""
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    Or if you're lazy here's a .zip file with the two files ready to go. RegFilesZipped.zip

    HTH
    Last edited by RetiredGeek; 2016-05-20 at 14:16.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Blacksburg, VA
    Posts
    19
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Paul T View Post
    It's probably a permission problem.
    1. Open File Explorer.
    2. In the address bar enter "%userprofile%", without the quotes.
    3. Right click on the "Documents" folder and select Properties > Security.
    4. Click Edit.
    5. Click on your user.
    6. Make sure all permissions are ticked. Tick any that aren't.
    7. Click OK and follow the prompts to complete the change including all sub-folders.

    cheers, Paul
    I did that, but all are checked. My documents are on a different partition so I went there and did what you suggested. When I clicked OK it went through the files, seeming to change them, but they are stilled marked read only. So, that fix didn't work. Do you have any other ideas?

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Blacksburg, VA
    Posts
    19
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I am a bit frightened to mess with the registry, but I'll do a backup and give it a try.

  8. #8
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    Quote Originally Posted by RetiredGeek View Post
    Jim,

    Here's the Registry Code for GrantAdminFullControl.reg
    ...

    Just save it to a text file with the Extension of .reg then double click the file to add it to the registry.

    Here's the code for TakeOwnerShipShortcut.reg

    ...

    Or if you're lazy here's a .zip file with the two files ready to go. RegFilesZipped.zip

    HTH
    Do these add commands to the right-click menu in Windows when I right-click on a file or folder?

  9. #9
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    Quote Originally Posted by mrjimphelps View Post
    Do these add commands to the right-click menu in Windows when I right-click on a file or folder?
    Yep!
    phelps.PNG

    FYI: You can only use one! They will overwrite each other...I prefer GrandAdminFullControl.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  10. The Following User Says Thank You to RetiredGeek For This Useful Post:

    mrjimphelps (2016-05-23)

  11. #10
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,167
    Thanks
    47
    Thanked 978 Times in 908 Posts
    Quote Originally Posted by iberney View Post
    When I clicked OK it went through the files, seeming to change them, but they are stilled marked read only.
    That is normal Windows indication and it's wrong. Try writing to one.

    cheers, Paul

  12. #11
    New Lounger
    Join Date
    Dec 2009
    Location
    Blacksburg, VA
    Posts
    19
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I installed AdminFullControl and it seemed to fix one file. I then right clicked on my folder at the top of the tree and ran it. It took several minutes to go through my hundreds of files in sub folders and then it went through again to say report processed. However some files are fixed, but some are not. The top folder still says read only. Does it take a while for this to work?

    I can write to the files, but I can't save them under the original name. I must give the file a new name. It is read only, but I can edit and write, but not save. It appears that if I close the file and reopen it (somethime 2 or 3 times), it opens without being read only. It is a mystery. I appreciate the help you have given. I am glad to know that the indication is sometimes wrong, but I can't know until I open a file and it tells me it is read only - even if I have created it myself.

    Thanks. I guess I will just live with this.

  13. #12
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    iberney,

    The AdminFullControl only gives you control to change the R/O attribute. You still have to change it.

    You can use this command in a Command Window to change the R/O attribute for all files at or below the specified file in the tree.

    Code:
    attrib -r c:\folder\*.* /s
    Just replace Folder with the name of your top level folder. Also replace the C: if the folder is not on the C: drive.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  14. #13
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,606
    Thanks
    147
    Thanked 869 Times in 831 Posts
    It could be worthwhile running just the Permissions resets in Windows Repair from www.tweaking.com as something may have changed the Permissions.

    Also, create a new admin account and see what they display as then.

  15. #14
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,167
    Thanks
    47
    Thanked 978 Times in 908 Posts
    Taking Ownership would be the next step. Try just one file first.

    cheers, Paul

  16. #15
    New Lounger
    Join Date
    Dec 2009
    Location
    Blacksburg, VA
    Posts
    19
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I tried the attrib command and files scrolled down the screen telling me they were changed, but some files still are read only. I appreciate the help suggested, but I am ready to give up. I will try the windows repair from www.tweaking.com, but my life has other demands. I'll let you know what happens. I really do appreciate the suggestions given. I've learned new things.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •