Results 1 to 5 of 5
  1. #1
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts

    Task Scheduler & Multiple Accounts

    Hey Y'all,

    I continue to have problems with the Task Scheduler and Multiple Accounts on Win 10.

    I have an extensive Toolbar that I use to launch things "As Administrator" (Highest Privileges in task scheduler parlance).

    ToolBar.PNG

    However, when I switch between the Microsoft Account and the Local Account (both Administrators) the Tasks will work correctly only work on the Account with which they are created.

    I've tried changing the Settings to Administrators Group vs the logged on user. With this change I can launch the programs from either account using the Task Scheduler Run (right-click menu) option. However, they WILL NOT launch from a Shortcut, i.e. my Toolbar! Unless of course I check the Run As Administrator box in the Shortcut properties then they run fine, but of course this defeats the whole purpose (avoiding the UAC prompt) of setting up the Scheduled Task in the first place.

    So I'm left to create two Scheduled Tasks (one for each account) and two Shortcuts (one for each Account) and two Toolbars (one for each Account).

    Anyone have a solution to avoid all of this duplication?

    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  2. #2
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    Could be that the scheduled task will only run if its user is logged on? I don't (yet) know about Win10, but in Win7 there are options on a scheduled task that say "Run only when user is logged on" and "Run whether user is logged on or not". If you have those in Win10, try unchecking the first and checking the second.

  3. #3
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Bundaburra,

    Thanks for the reply.

    When you select a Group, Administrators in this case, the "Run only if user is loggedon" option is greyed out.

    tasksch as administrators.PNG

    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,583
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    Does changing the user to a built-in object such as SYSTEM help?
    Joe

  5. #5
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Joe,

    According to the TechNet documentation if run as System it will not run Interactively which is what I want. Thanks for the suggestion though.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •