Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    Philadelphia
    Posts
    94
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Poor IE11 Performance

    In its efforts to push Edge as its browser, would MS not optimize W10 for IE11? I have W10 on three PCs and all exhibit poor performance with IE11, lockups, crashes and delay when going from one to another link.

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    In my brief stay in Win 10 I found IE 11 worked fine.

    Do you have the same add-ons in each machine ?

    You could try resetting one of them to defaults or running IE without add-ons to see if there's any improvement or it may be a DNS issue, or a build up of the temporary Internet cache.

    Press the Windows key+r then type ncpa.cpl into the Run box and press enter - right click on whichever adapter you are using and select Properties.

    Click on (TCP/IPv4) - Properties then check the bottom radio button for Use the following DNS server addresses then in the top row of boxes enter 8.8.8.8 - tab down to the next row and enter 8.8.4.4 - check the box to Validate settings upon exit - OK - Close and then see if you get the same lag when browsing.

    This command run from Command Prompt (Admin) can also help with browsing -

    netsh winsock reset

    exit

    then reboot.

    For the temp Internet cache, the free version of CCleaner is normally used, but not sure if it will work in Win 10 as it has been reported that it gets kicked out during a Win 10 upgrade, but you can see if it works, else use Disk Cleanup.

    https://www.piriform.com/ccleaner/download

    http://windows.microsoft.com/en-gb/w...-in-windows-10

    Before you run CCleaner, uncheck the box for Memory Dumps then under the Applications tab, uncheck the box for MS Search.

  3. #3
    3 Star Lounger djohnson's Avatar
    Join Date
    Dec 2009
    Location
    Delaware City, Delaware
    Posts
    323
    Thanks
    13
    Thanked 32 Times in 30 Posts
    Open control panel, and follow steps in image.

  4. #4
    Star Lounger
    Join Date
    Dec 2009
    Location
    Philadelphia
    Posts
    94
    Thanks
    2
    Thanked 2 Times in 2 Posts
    Made all recommended changes, DNS setting, clean up and resets. I'll see how IE11 now runs and let you know.

  5. #5
    Star Lounger
    Join Date
    Dec 2009
    Location
    Philadelphia
    Posts
    94
    Thanks
    2
    Thanked 2 Times in 2 Posts
    For now, IE11 appears to be working better. Hope it eeps up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •