Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Aug 2011
    Location
    Los Alamos, NM
    Posts
    121
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Visual Studio 2015 "Diagnostics" compiler options have disappeared

    I happen to be using PGI Fortran with Visual Studio 2015 on Win7 64bit. I would guess the particular compiler being used isn't that important. When I open the Solution Property page(s) and the Diagnostics category, it is blank. It used to be there so I must have done something to eliminate it. Is true in both the debug or release code versions.

    Thanks for any suggestions.
    Gigabyte Z97X-UD5H , Intel i7 4770K @4.7Ghz using 1.3V
    -- G.Skill DDR3 2400 (2*2Gb) 9-11-11-31
    -- Iwaki MD-20RLZT -> EK Sup. Univ. -> Chiller -> Resev
    -- EVGA GTX680,Klipsch Promedia 4.1
    -- Intel 510 120G, Crucial M4 120G, Samsung 840 Pro 500G
    -- Corsair 1050 in Corsair 730T
    -- Win 10 Pro

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    There was a known issue in the pre-release versions of VS. Are you using the RTM version? Which SKU?
    Have you reported the error using the VS feedback tool?
    There is a hot fix released 9/2015 available also - see Update to improve Diagnostic Tools in Visual Studio 2015.
    Joe

  3. #3
    2 Star Lounger
    Join Date
    Aug 2011
    Location
    Los Alamos, NM
    Posts
    121
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Thanks for the quick reply JoeP.

    It was included in PGI compiler download. The help info says it is Version 14.0.25123.00 Update 2 so sounds like it is later than the problems you note.

    In the short term I've just added "-Minfo=all" to the compile command line.
    Gigabyte Z97X-UD5H , Intel i7 4770K @4.7Ghz using 1.3V
    -- G.Skill DDR3 2400 (2*2Gb) 9-11-11-31
    -- Iwaki MD-20RLZT -> EK Sup. Univ. -> Chiller -> Resev
    -- EVGA GTX680,Klipsch Promedia 4.1
    -- Intel 510 120G, Crucial M4 120G, Samsung 840 Pro 500G
    -- Corsair 1050 in Corsair 730T
    -- Win 10 Pro

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    The PGI web site says the VS Shell included with its products only has the PGI compilers. Perhaps it does not include the full VS suite of tools. Have you checked the PGI support site?
    Joe

  5. #5
    2 Star Lounger
    Join Date
    Aug 2011
    Location
    Los Alamos, NM
    Posts
    121
    Thanks
    8
    Thanked 0 Times in 0 Posts
    No, I'll check with tech support next week. I'm sure nobody is there this weekend.

    Thanks again.
    Last edited by deeppow; 2016-05-28 at 16:26.
    Gigabyte Z97X-UD5H , Intel i7 4770K @4.7Ghz using 1.3V
    -- G.Skill DDR3 2400 (2*2Gb) 9-11-11-31
    -- Iwaki MD-20RLZT -> EK Sup. Univ. -> Chiller -> Resev
    -- EVGA GTX680,Klipsch Promedia 4.1
    -- Intel 510 120G, Crucial M4 120G, Samsung 840 Pro 500G
    -- Corsair 1050 in Corsair 730T
    -- Win 10 Pro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •