Results 1 to 13 of 13
  1. #1
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts

    Wake on LAN works for Dell Optiplexes when they are shut down but not when sleeping

    These Dell Optiplexes (755, 760) used to Wake on LAN successfully in Windows 7 Pro from both the shutdown state and sleep/hibernate state.

    Now upgraded to Windows 10 Pro, I find that Wake-on-LAN works successfully when the Optiplexes are shut down, but not when they are set to sleep.

    This seems to be the exact opposite of what is reported on Google!

    Has anyone investigated Wake on LAN in Windows 10?
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,886
    Thanks
    5
    Thanked 1,103 Times in 969 Posts
    Is this the November 1511 version of Win10?
    Up to date with cumulative fixes?
    Double checked all the power settings?
    Using a OEM NIC driver, a DELL driver, or Windows? Sometimes the base Windows drivers are not full featured.
    Joe

  3. #3
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    I updated these PCs to Windows 10 yesterday, and kept Checking for Updates, so I think that side should be OK.

    All the (motherboard) NIC power settings seem fine to me.

    I can't say which drivers the NICs are using, and I'm surprised that this might matter! I will have a look on the Dell website for anything new.

    I'm just puzzled that waking from shutdown works perfectly, but not from sleep. I'll also check in the BIOS - but remember that it all worked fine on Windows 7.

    I suppose I will have to read up on how Windows 10 Sleep compares with Windows 7 Sleep/Hibernate.

    BTW in this instance I'm using Nir Sofer's WakeMeOnLAN, with the caveat mentioned in v1.76.

    BTW2 of two Optiplex PCs and one Lenovo Thinkpad, I've had trouble with two of the three Windows 10 device upgrades!
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,886
    Thanks
    5
    Thanked 1,103 Times in 969 Posts
    Have you tried disabling fast startup? That seems to be the remedy for many start/non-start problems.
    Joe

  5. #5
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    I've updated both BIOSes, and found that Dell doesn't have any new drivers for Windows 10 for the Optiplex 755 and 760. I also observe that the NICs are the standard Intel Gigabit ones, for which I'm told that there are no newer drivers.

    I'll look into Fast Startup - thanks!
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  6. #6
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    Having Fast Startup on or off doesn't seem to make any difference to my Wake on LAN problem - WoL works when the Optiplexes are shut-down, but not when in sleep mode.
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  7. #7
    WS Lounge VIP Browni's Avatar
    Join Date
    Dec 2009
    Location
    Rochdale, UK
    Posts
    1,750
    Thanks
    39
    Thanked 178 Times in 155 Posts
    Anything in device manager for the network card?

    wolmagicpacket.PNG

  8. #8
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    Precisely what you show! Remember that for me, Wake on LAN works when the Windows 10 Optiplexes are in the shutdown state.
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  9. #9
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,885
    Thanks
    119
    Thanked 813 Times in 728 Posts
    You could try playing with your sleep state settings in BIOS:
    http://www.pcworld.com/article/22583...leep_Mode.html

    Jerry

  10. #10
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    'nother thing to check - I always have it set to S3. Thanks, Jerry!
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  11. #11
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    I changed the Sleep state to S1, and disabled "Wake on pattern match" (no obvious connection), and neither of those enabled a Wake-on-LAN to happen when the Optiplexes were put to Sleep...
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

  12. #12
    Bronze Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,222
    Thanks
    20
    Thanked 101 Times in 90 Posts
    It has been a very long time since I looked at this, but WoL works slightly differently when the computer is shut down vs when it's asleep.

    When the computer is shut down, WoL is a function of the network card and BIOS which will power up the computer. When the computer is asleep, it is the function of the OS to bring it out of the sleep state.

    I know that this doesn't answer the question of why WoL isn't working when asleep, but it does explain why it works when it's off. So at least we are now confused at a higher level.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  13. #13
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,472
    Thanks
    34
    Thanked 197 Times in 177 Posts
    I think this is where I disable sleep state, and, when I get some time, look at Hibernate instead. Shutdown is adequate for my purtposes.
    BATcher

    "The trouble with quotes on the internet is that you can never know if they are genuine."
    Abraham Lincoln
    

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •