Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Network file sharing

    I have a home network with computers A, B, C and D. A is Win 10 Pro and B is Win 7 Pro. Computer A has just been replaced with a completely new machine hardware and Win 10 Pro. Previously, computer A had complete R/W access to both hard-drives on computer B. With the new computer A, the permissions to B's drives are gone. Both of Computer B's drives are Share Everyone.

    Apparently, I have to do something on the new computer A in order to R/W files on computer B's drives. What do I need to do?

    Thanks,
    Bill

  2. #2
    Silver Lounger lumpy95's Avatar
    Join Date
    Feb 2013
    Location
    Mojave Desert CA
    Posts
    1,845
    Thanks
    258
    Thanked 176 Times in 149 Posts
    In file explorer, right click on the drive you want to share and click on "Share With" and then set permissions.
    Hope this helps.

  3. #3
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,203
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Depends on how you were sharing. Do you know if you have set up a homegroup or if you are doing per user shares?

    cheers, Paul

  4. #4
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Here are screenshots of drive C: share properties on the "B" computer:
    (As you can see, "Everyone" is supposed to have full permissions.)

    000.jpg

  5. #5
    Silver Lounger lumpy95's Avatar
    Join Date
    Feb 2013
    Location
    Mojave Desert CA
    Posts
    1,845
    Thanks
    258
    Thanked 176 Times in 149 Posts
    Computer A has just been replaced with a completely new machine hardware and Win 10 Pro
    Check in Network and Sharing settings to make sure all is well there and also check that the windows firewall has file and printer sharing ticked.

  6. #6
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I just verified both computer's WORKGROUP settings are the same "GCC".

    Here's what I get if I attempt to open "C" drive on "B" from "A".
    001.jpg

    And, from the sharing properties on compute "A":

    003.jpg

  7. #7
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    On Computer "A", (Win 10 Pro), I don't see any Firewall settings that pertain to sharing.................. am I missing something?

  8. #8
    Silver Lounger lumpy95's Avatar
    Join Date
    Feb 2013
    Location
    Mojave Desert CA
    Posts
    1,845
    Thanks
    258
    Thanked 176 Times in 149 Posts
    Your firewall settings should look like this:
    WF 1.JPG

    As to your "compute A" sharing properties photo, I would change the HomeGroup settings since you say that you are on a WorkGroup. Here's mine:
    Network n Share.JPG

  9. #9
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    According to your screen shots you're using a HomeGroup.

    How did you setup the HomeGroup on the new computer? Did you establish a new one or link to the existing one?

    Here's a link on joining an existing HomeGroup.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  10. #10
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Here's my InBound Rules............... not the same as yours, but I can't tell where we're different if it makes any difference.

    004.jpg

    I did change the Homegroup setting as you suggested. I don't have a Homegroup, only a Workgroup. I've never worked with Homegroups.

  11. #11
    Silver Lounger lumpy95's Avatar
    Join Date
    Feb 2013
    Location
    Mojave Desert CA
    Posts
    1,845
    Thanks
    258
    Thanked 176 Times in 149 Posts
    Since you changed the HomeGroup setting, try rebooting. Then when you try to access the other computers it should ask for a username and password if you have those set on your computers.

  12. #12
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Computer B already had a Homegroup, so I had Computer join that group. Didn't resolve the issue. I still can't open the "C-drive" on Computer B from Computer A via Windows Explorer Network. It does me no good to select anything referencing shared data via homegroup.

    Internal to the Access App on Computer A, there are references like: \\AV-Computer\AV-Cdrive\Sermons\ AND \\AV-Computer\AV-Cdrive\SermonPortal\ as file copying and file deleting are carried out on Computer B from Computer A. I'm guessing Homegroup permissions don't handle such references. The OLD Computer A with Win 7 Pro never used a Homegoup. The Access app has been running for years on Computer A and performing its function on Computer B.

    I remain totally stumped.

  13. #13
    3 Star Lounger
    Join Date
    Mar 2010
    Location
    USA
    Posts
    301
    Thanks
    65
    Thanked 39 Times in 30 Posts
    Not sure it helps; check these items:
    In network of control panel:
    Try enable 40- 56-bit encryption for all PCs. XP and below use only 40- 56-bit encryption.
    Or try enable 128-bit-only encryption for all PCs. Win7 and up default is 128-bits.
    Enable 'allow all users in local network to share'
    Select 'password protection for sharing', not 'Let Windows handles it'.

    If not already, enable sharing.
    If not already, troubleshoot using hard-wire networking first. Maybe 2 PCs at a time.
    Use ipconfig on each PC, to find the IP address of each PC, and its gateway is the same.
    Use ping to locate the PCs in the local network.
    Maybe obvious, double-check at least one folder in each PC is shared enabled as public folder.
    (Otherwise you can ping but no access.)

  14. #14
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I'll be back to this on Thursday, 7/28. Computer B currently upgrading to Win 10 Pro.

  15. #15
    Star Lounger
    Join Date
    Jan 2010
    Location
    Graeagle, California, USA
    Posts
    82
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I'm relatively sure it's NOT supposed to work this way, but when I added the SAME user to computer "B" that uses computer "A", and I mean the same, once I provided the "Credentials" and a "Remember Me" upon first reference to "B's" hard-drive from the App running on computer "A" there's been no problem since.

    I'm beginning to suspect that the use of HOMEGROUP only applies to Document, Picture, Video and Music folder sharing. If that's true, then it's of limited use in my case. I can tell you that same WORKGROUP was all that was required with XP.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •