Results 1 to 11 of 11
  1. #1
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Colorado Springs, CO
    Posts
    110
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Num Lock is not locked

    On two machines having used three different keyboards, the num lock will not stay on. I called Dell (gritting my teeth) and wasted an hour of my time. The tech finally told me that he and his manager say that the xps systems are designed this way. I told him they are all wrong and if Dell built the machine this way they made a grave error. After all, what does NUM LOCK stand for???
    Does anyone have a solution? I have a feeling this is a Win10 issue.

  2. #2
    WS Lounge VIP Calimanco's Avatar
    Join Date
    Dec 2009
    Location
    UK
    Posts
    722
    Thanks
    1
    Thanked 144 Times in 130 Posts

  3. #3
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    I'll attest to that fix working on my Dells.

    Unfortunately I've had to reapply it each time MS pushed out a new Insider Edition!.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  4. #4
    5 Star Lounger Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    627
    Thanks
    168
    Thanked 77 Times in 68 Posts
    Did you change motherboards or refresh BIOS/UEFI recently? If so, check in BIOS/UEFI for a setting to boot with Num Lock on or off. Even if you didn't change/refresh, worth a look anyway.
    Lugh.
    ~
    Windows 10 Pro x64 1607; Office 2016 (365 Home) x32; Win Defender, MBAM Pro

    ASRock H97 Anniversary; Xeon E3-1231V3 (like i7)
    Gigabyte GeForce GTX 970; 12GB Crucial DDR3 1600
    Logitech MX Master mouse; Roccat Isku kb

  5. #5
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by Lugh View Post
    Did you change motherboards or refresh BIOS/UEFI recently? If so, check in BIOS/UEFI for a setting to boot with Num Lock on or off. Even if you didn't change/refresh, worth a look anyway.
    Doesn't work. Windows 10 takes over after it boots, and sets NUM LOCK to suit its own purposes. Registry editing seems to be the only cure.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  6. The Following User Says Thank You to bbearren For This Useful Post:

    Lugh (2016-08-01)

  7. #6
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by RetiredGeek View Post
    I'll attest to that fix working on my Dells.

    Unfortunately I've had to reapply it each time MS pushed out a new Insider Edition!.

    HTH
    If you use Edit > Find in Regedit and put InitialKeyboardIndicators in the textbox, you can then use F3 to progress through the registry and make the changes fairly quickly and painlessly.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  8. #7
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Sorry I should have posted this last evening but here's the .reg file I use to apply the patch.

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
    "InitialKeyboardIndicators"="2"
    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  9. #8
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,078
    Thanks
    0
    Thanked 259 Times in 248 Posts
    I've found the Registry edits [have tried all 3 suggestions] in Win10 are useful but only retains how the NumLock was set when the computer is shutdown, if left in the On state it is on when the computer starts.

  10. #9
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    290
    Thanks
    46
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by Berton View Post
    I've found the Registry edits [have tried all 3 suggestions] in Win10 are useful but only retains how the NumLock was set when the computer is shutdown, if left in the On state it is on when the computer starts.
    I'm not sure what the standard behavior is supposed to be in Win 10 with "fast boot" enabled but my system retains whatever setting it had when shutdown.

    Perhaps this is a Dell specific behavior.
    George

  11. #10
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by High Sierra View Post
    I'm not sure what the standard behavior is supposed to be in Win 10 with "fast boot" enabled but my system retains whatever setting it had when shutdown.

    Perhaps this is a Dell specific behavior.
    It's not Dell specific — I have two DIY boxes that behave in the same manner without the registry edits. Whether sign out, restart or shut down and startup, NUM LOCK gets turned off, even thought UEFI is set for NUM LOCK on.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  12. #11
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    290
    Thanks
    46
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by bbearren View Post
    It's not Dell specific — I have two DIY boxes that behave in the same manner without the registry edits. Whether sign out, restart or shut down and startup, NUM LOCK gets turned off, even thought UEFI is set for NUM LOCK on.
    Interesting. My system is DIY as well and UEFI with boot up numlock on. I was noticing that numlock light was on untill I logged on, then it went out. When I saw this thread I turned it back on after logging on and then rebooted. It stayed on. I then turned it off and rebooted and it stayed off.
    George

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •