Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts

    W10 Regularly Turns Keypad Num Lock OFF

    This is a very minor issue, but an irritant nonetheless. I post it only on the chance that someone else might have a simple fix for this.

    All my W10 computers were upgraded from W7, and this problem never happened in W7.

    We leave the Num Lock permanently enabled for all the desktop computers. With only two computers out of four (a Dell with wireless M$ keyboard and an HP with USB keyboard), we have found W10 regularly turning Num Lock off; it turns back on easily, but it is a real irritant to start typing and find nothing happening! And with W10 we have started using PIN signon, so we notice quickly when the Num Lock has been disabled.

    Have not yet found a correlation with some action that might be triggering this - I am pretty sure it is not sleep mode. Just seems to happen randomly.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Are you running the anniversary update? If not, which Win10 version are you running?
    Joe

  3. #3
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    No AU yet - all my machines are on 1511.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Joe

  5. #5
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Really appreciate the suggestions! I had tried to do a search, but got nothing worthwhile ("num" was too short, and I didn't think to quote the whole term). That first archived post seemed to be the answer, but unfortunately my registry key HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyboardIndicators was already set to "2" (the supposed solution).

    And I'm pretty darn sure my num lock changes spontaneously at times even without a boot, so maybe that is why that key doesn't help?

    However, I DID find that my HKEY_USERS\Default\Control Panel\Keyboard\InitialKeyboardIndicators was set to 2147483648, which is the equivalent of 0, so I changedthe last two digits to 50. Time will tell if this solves the issue. Thanx!

    Oh, and just in case somebody else is trying to follow along - the regedit needed to be done by an administrator. On one machine, the basic user is not admin, and we found the default setting at 2147483648 but could not change it. We did not log out of that user, just switched to Administrator (which turned OFF the Num Lock) and changed the value to 2147483650. Then when we switched back to the normal user session that was still running, we saw it also had the updated value.
    Last edited by V7Goose; 2016-08-09 at 12:14.

  6. #6
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    UPDATE:
    I am sorry to report that this did NOT fix this annoying problem. Just found the Num Lock off again (and checed the registry - the change made above still there).

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Had you re-booted?
    Has the system been hibernated or sleeping?
    Have you run any programs you normally do not run or run infrequently?
    Joe

  8. #8
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by V7Goose View Post
    Really appreciate the suggestions! I had tried to do a search, but got nothing worthwhile ("num" was too short, and I didn't think to quote the whole term). That first archived post seemed to be the answer, but unfortunately my registry key HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyboardIndicators was already set to "2" (the supposed solution).

    And I'm pretty darn sure my num lock changes spontaneously at times even without a boot, so maybe that is why that key doesn't help?

    However, I DID find that my HKEY_USERS\Default\Control Panel\Keyboard\InitialKeyboardIndicators was set to 2147483648, which is the equivalent of 0, so I changedthe last two digits to 50. Time will tell if this solves the issue. Thanx!

    Oh, and just in case somebody else is trying to follow along - the regedit needed to be done by an administrator. On one machine, the basic user is not admin, and we found the default setting at 2147483648 but could not change it. We did not log out of that user, just switched to Administrator (which turned OFF the Num Lock) and changed the value to 2147483650. Then when we switched back to the normal user session that was still running, we saw it also had the updated value.
    Change the value for HKEY_USERS\.DEFAULT\Control Panel\Keyboard InitialKeyboardIndicators to 2. Works for me through sign out/sign in and restart. If I turn it off with the key and reboot, it's turned back on.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  9. #9
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by JoeP517 View Post
    Had you re-booted?
    Has the system been hibernated or sleeping?
    Have you run any programs you normally do not run or run infrequently?
    The computer had been rebooted twice this morning - one time it came up with Num Lock on, the second time with it off. No programs were run at all except FireFox. No sleep yet today; never use hibernation. This computer only uses one ID, which has admin access.

    The second computer where I made the same change uses multiple IDs, most of them no admin access. Often just switching active user accounts would find the NumLock off on that one, but so far that has not happened again. Based on the seeming random nature of this happening, I suspect it is still too soon to declare victory on that one.

  10. #10
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by bbearren View Post
    Change the value for HKEY_USERS\.DEFAULT\Control Panel\Keyboard InitialKeyboardIndicators to 2. Works for me through sign out/sign in and restart. If I turn it off with the key and reboot, it's turned back on.
    2147483650 is the same value as "2" in these registry keys (as documented by Micro$oft).

    And even though that solution seems to work for SOME computers, we know that something else screwy is going on with W10 since

    a): most, if not all, of the computers afflicted with this annoyance NEVER did it under W7 (based on the many internet posts I have found complaining of the issue), and
    b): this "fix" does not fix it for everyone who tries it, and
    c): I have two other computers running W10 (one for only a week, but the other one was upgraded about a year ago) that still have the default value of 2147483648, and they have NEVER lost the Num Lock setting.

  11. #11
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Do you have fast start enabled?

    Also, in addition to the HKEY_USERS\.DEFAULT, I changed the value to 2 for all instances of InitialKeyboardIndicators in the registry.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  12. #12
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,072
    Thanks
    0
    Thanked 259 Times in 248 Posts
    I've found on my Notebooks the changes to the Registry retains the last state of NumLock when shutting down or rebooting, i.e. if Off when shut down will be Off at next startup, if On when shut down will be On at next startup.

  13. #13
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    2,153
    Thanks
    31
    Thanked 306 Times in 266 Posts
    On all three of my Win10 systems the value of
    HKEY_USERS\Default\Control Panel\Keyboard\InitialKeyboardIndicators
    is 2147483648

    I have not changed the value of that key on any of these three systems, however I have a vague memory of having to hit the "Num Lock" key to turn it on after the initial install/upgrade of Win10, after which "Num Lock" was on after each restart or cold boot.

    All three of these systems have "Fast Startup" (hibernation) turned off.
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    AMD FX8120 (8-core @ 3.1GHz) CPU, Gigabyte GA-990FXA-D3 motherboard, 8GB (2x4GB) DDR3 1866MHz RAM, ATI-AMD Radeon HD6770 PCI-E VGA, 480GB Kingston SSD, 2TB Seagate SATA3.0 HDD, ASUS DVD/RW.

  14. #14
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by bbearren View Post
    Do you have fast start enabled?
    Yes, Fast Start was on as default (same on all four of my machines, including the two that never have this problem). I suspect that certainly may have something to do with this, as this particular machine has been having a few weird problems with boot. For the last two days I have found it on in the morning with a blank screen, and completely unresponsive - even the power button would not wake it up, which it always will if the issue is with USB keyboard or mouse. Only thing I could do is force power off. The clue here is that when I tried to access the BIOS on start, I got a warning message that Windoze was trying to restore from hibernate. I tried several normal boots and let it sit LONG time with the disc activity light really going to town, but it never came back to life until I did a second force power off during boot. Then it finally booted normally.

    I never use hibernate, but I am pretty sure the machine was in sleep mode each day when I left it, so Fast Startup may have been using the hibernate file anyway. Perhaps it is corrupted?

    I turned hibernate off at the command prompt now, which totally deletes the hiberfile, so we'll see if the annoyances go away.

  15. #15
    Lounger
    Join Date
    Jul 2010
    Location
    Texas
    Posts
    33
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Interesting note here - after disabling Fast Start and totally shutting off Hibernate, the cold boot time for this computer now seems FASTER than before! Now if that danged Num Lock will just stay on (so far so good), I'll be a happy camper.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •