Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Sleep mode kills open applications

    Hi folks,

    I gather from Internet searches that this problem isn't unique to me, but I'm hoping someone here can help.

    Win 10, Surface Pro 3 with external Dell P2715Q 4k monitor connected through Surface Pro 3 docking station's DisplayLink port. I have it set to only use the Dell, as the SP3 screen is a tad small for everyday use.

    Ever since installing this external monitor, whenever the display goes into Sleep mode (which it does at the correct interval, after 1 hour) frequently (but not always) all open apps have been killed when I re-awaken it. Chrome says "shut down incorrectly, do you want to restore all tabs?" (which it does just fine), but Word, Lightroom, Excel, Quicken, whatever else I was working on at the time has been closed without saving my work. Further, sometimes (but not always) when it re-awakens my personal settings (e.g. Bluetooth keyboard, mouse-keys set up in reverse) are ignored, and the task bar along the bottom of the Dell display is missing. I have to use the on-screen keyboard to sign in so I can do a full shut-down and re-start to get things back to normal; "restart" doesn't usually bring them back and Ctrl-Alt-Del doesn't bring up the usual menu allowing me to go to the Task Manager or to power off. The power/sleep profile has the display go off after one hour when plugged in, and the computer "never".

    Microsoft's automatic update installations and reboots overnight have a similar effect, but this happens during the day, too.

    I've checked all drivers, and all are "the latest version".

    And yes, I know it's really hard to diagnose things that don't consistently show the same symptoms, but does anyone have any suggestions? It doesn't stop me using my computer, but it's intensely annoying to have to remember to save all open work every time I step away from the keyboard.

    Thanks!

    Jon

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Sounds to me more like the machine going into hybrid sleep. Have you double checked all your power settings?
    Joe

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the prompt response, Joe, but please could you elaborate? My understanding was that all forms of sleep mode, including hybrid, just store work in progress somewhere (memory or disk, depending on the mode) so that it can be restored with varying degrees of speed when the computer re-awakens' it's not supposed to shut down applications and abandon work in progress, which is what's happening. Do you have any suggestions as to which power settings I should check and what they should be? I ran Windows Troubleshooter for Power Settings and all it did was decide that my existing settings were "too long", resetting the display time from one hour to ten minutes and the computer time from "never" to ten minutes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •