Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts

    Question Task Scheduler no longer waking from S3 sleep

    I have a somewhat ancient laptop (c. 2000 vintage) which has run Win7 successfully for several years. I recently updated it to Windows 10 Pro 32-bit which, despite the PC's age, runs pretty well.

    But I have one serious problem - with scheduled tasks which are supposed to wake it up from S3 sleep. These tasks worked fine in Windows 7, and they still run in Windows 10 if the laptop is awake - but they no longer wake it from sleep.

    Power options have Wake Timers enabled.
    powercfg /waketimers shows the correct wakeup time and task

    Yet it when the laptop is in S3 sleep, it does not wake up.

    Research suggests that this might be due to Windows 10 (and possibly Windows 8/8.1) needing a High Performance Elapsed Timer to wake the computer - and this laptop predates the HPET technology.

    For testing I am also using PassMark Software's Sleeper utility - and the laptop doesn't wake as it should when I use that either.

    I have tried using 'bcdedit /set userplatformclock', but this has not worked either - presumably because whilst this is supposed to enable the HPET it can only do so it the HPET actually exists in hardware.

    Has anyone got any suggestions?

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Which version of Win10 are you running?

    Have you tried any of the powercfg diagnostics?
    Joe

  3. #3
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    Win 10 Pro 32-bit Anniversary Update

    I have tried all sorts of things including "bcdedit /set useplatformclock on / off", "powercfg /waketimers", "powercfg /a", checking power profile to ensure Sleep/Waketimers is enabled etc.

    But I am stumped. The closest I have is a comment from someone saying that Win 10 (and possibly 8) uses HPET for scheduling.

    But I haven't found any solutions in my web research. So asking here is my last ditch attempt - and if anyone can find a solution it will be the folks here.

  4. #4
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    P.S. Personally I think it is the RTC that wakes the PC up, though scheduler may then use HPET to run the task at exactly the right instant. I have sat there at the time it should wake up and it simply stays asleep.

    So, my guess is that it is something to do with RTC and Windows 10 but no idea what - and AFAIK there are no settings to tweak either.

  5. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    You could try /LASTWAKE or /SLEEPSTUDY or /SYSTEMSLEEPDISAGNOSTICS. They may all produce some useful information.
    Joe

  6. #6
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    /LASTWAKE - ACPI Power Button
    /SYSTEMSLEEPDISAGNOSTICS - more about why it went to sleep than why it woke - nothing useful.

  7. #7
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    /SLEEPSTUDY says PC doesn't support S0 sleep state - so I guess this is about microsleep.

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    If you have fast startup enabled try disabling it.
    Joe

  9. #9
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    I will try that - though I am unclear why it would make a difference.

  10. #10
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,761
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by Protopia View Post
    I will try that - though I am unclear why it would make a difference.
    Fast startup is hybrid sleep; a different animal.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  11. #11
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    Yes - but as per the original post, the PC is not waking from standard sleep.

    But you never know so I will try it and see.

  12. #12
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,421
    Thanks
    33
    Thanked 195 Times in 175 Posts
    My tests today on Dell Optiplexes show that Wake-on-LAN* will work only when the Optiplex was shut down
    shutdown.exe /s /t 0
    or hibernated
    shutdown.exe /h
    but would not restart from fast shutdown
    shutdown.exe /s /hybrid /t 0
    nor from sleep (with hibernate off)
    powercfg /h off
    rundll32.exe PowrProf,SetSuspendState <any parameter you like>


    Where I say "any parameter you like" I have tried: nothing, "dummy", Sleep and 0,1,0

    * using Nir Sofer's WakeMeOnLAN program.
    Last edited by BATcher; 2016-08-21 at 15:32. Reason: PowrProf, not PowerProf!
    BATcher

    Time prevents everything happening all at once...

  13. #13
    Star Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    60
    Thanks
    0
    Thanked 20 Times in 2 Posts
    It is possible that Wake-on-LAN and WakeTimers (RTC) are linked an have the same symptoms, but not necessarily. Nevertheless the list above makes interesting reading.

    Have you tried WoL with Hybrid sleep? Did you try sleep with orwithout Hybrid sleep enabled? Did you try selecting shutdown, hibernate and sleep from the start menu or from Right-Click on the start button?

    There seems to be no fundamental reason (i.e. not technically possible) for these oddities - it sounds to me that the LAN card is not prepped for WoL in some circumstances and is prepped for WoL in others.

    There is scope for some detailed analysis of what is happening and a formal research report. This would help highlight the issue and perhaps get a fix from Microsoft.

  14. #14
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,761
    Thanks
    26
    Thanked 424 Times in 338 Posts
    There is a registry key for fast start that might be involved in some nefarious fashion.

    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Session Manager\Power" and the subkey "HiberbootEnabled" in the right pane. A value of 1 means "Enabled", and a value of 0 means "Disabled".
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  15. #15
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,421
    Thanks
    33
    Thanked 195 Times in 175 Posts
    Bob: yes, the inimitable Brink talks about turning Fast Start on or off here.

    Protopia: my WoL needs are simple: to find an 'off state" from which these Optiplexes can be started up using WoL.

    The Optiplexes will be put into that state using SHUTDOWN (since PsShutdown hasn't been updated since XP? Windows 7?) from a server. SHUTDOWN -m \\pcname should give the same results as any of the other options Brink talks about in his tutorial on Shutdown.

    Hybrid sleep seems even less likely to be useful to me than is sleep - and I would have to look it up! Perhaps I have been testing it inadvertently anyway...
    BATcher

    Time prevents everything happening all at once...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •