Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Jun 2001
    Location
    USA
    Posts
    710
    Thanks
    48
    Thanked 1 Time in 1 Post

    mailto: links don't work in Chrome on Windows 10

    Hi all -

    I'm experiencing a weird problem in Chrome on Windows 10. Clicking on mailto: links does nothing. Doesn't matter what webpage; it's like the link doesn't even exist.

    I've reinstalled Chrome, and confirmed that my default app for email is Chrome. See screenshot. Still nothing.

    Untitled.png

    A little Googling led me http://www.tenforums.com/browsers-em...tml#post424855, where I saw this screenshot, the bottom of which allows you to specify the mailto: default:

    42558d1444751127t-mailto-browsers-not-working-mailto.jpg

    Yet I can't figure out how to navigate to this section within Windows 10. Any help?

    Thanks a million!

  2. #2
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    2,283
    Thanks
    32
    Thanked 332 Times in 287 Posts
    Quote Originally Posted by Jon5 View Post
    ...Yet I can't figure out how to navigate to this section within Windows 10...
    Win10 logo\Settings\System\Default apps\Choose default apps by protocol (scroll down to see it).
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    Confuscius said: "no use running harder if you're on the wrong road" and "any problem once correctly understood is already half-solved".

  3. The Following User Says Thank You to Coochin For This Useful Post:

    Jon5 (2016-09-01)

  4. #3
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,925
    Thanks
    176
    Thanked 689 Times in 606 Posts

  5. The Following User Says Thank You to BruceR For This Useful Post:

    Jon5 (2016-09-01)

  6. #4
    5 Star Lounger
    Join Date
    Jun 2001
    Location
    USA
    Posts
    710
    Thanks
    48
    Thanked 1 Time in 1 Post
    Thanks, Coochin! That is indeed where that setting is.

  7. #5
    5 Star Lounger
    Join Date
    Jun 2001
    Location
    USA
    Posts
    710
    Thanks
    48
    Thanked 1 Time in 1 Post
    Thanks, Bruce! How right you are -- and how helpful that article was!

    Turns out I needed to install the following plug-in:

    https://chrome.google.com/webstore/d...opajdf/related

    What a hassle.

    Thank you again!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •