Results 1 to 13 of 13
  1. #1
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts

    How to prevent unwanted flash cookie

    Win 7-64, SP1

    Whenever I open Pale Moon (32-bit, latest version), it places the flash cookie "settings.sol" in the macromedia folder. I know this because my "flashcookiecleaner" app finds it when I check after closing Pale Moon. I note that Firefox (also 32-bit latest version) does not place any flash cookies on my machine.
    I haven't checked if Internet Explorer does.

    Is there some setting in Pale Moon that I can activate to prevent this behavior? I notice that there are some settings in the Firefox about:config file relating to Adobe that are not in the Pale Moon about:config file. I wonder if adding these settings to the Pale Moon about:config file would work? I would have tried this, but I don't know how to edit the about:config file.

    Any help would be appreciated.

  2. #2
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts
    OK, here's what I did:

    I found out how to edit the Pale Moon about:config file, and added the string "media.gmp-eme-adobe.enabled" to the file (copied from the Firefox about:config file). Then I set the string value to "false" (as it was in Firefox). This appears to work.

    I wonder why this wasn't included in Pale Moon, and what setting in Firefox actually let me change its value (it shows that the false value was set by user in Firefox, so there must be some setting that allowed me to do that)?

  3. #3
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts
    Oops! I spoke too soon. The dreaded flash cookie returned immediately after I posted the previous reply, so the original question still remains.

    Oh well, at least I learned how to edit about:config.

  4. #4
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    "settings.sol" is the Macromedia/Adobe settings file for your Flash options, not something that should cause you any dread.

    EME (in browser DRM) is not included in Pale Moon anyway.

  5. #5
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts
    Satrow, thanks for the reply.

    While I don't actually dread this particular cookie (although, in general, I dislike any unwanted cookies), I am curious about why it happens in Pale Moon and not in Firefox (or in Internet Explorer). I would like to see the same behavior concerning this particular cookie (actually, I never get any other flash cookies) in all my browsers.

  6. #6
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    It might be that you've done something different in Pale Moon, like disabling hardware acceleration maybe, or in Firefox, maybe HTML5 is default there, or you've not made any settings changes in Flash.

  7. #7
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts
    Thanks, satrow, you put me on the right path. I compared all the option settings between Pale Moon and Firefox. Under Tools/Options/Advanced/Update, I changed my Pale Moon setting from "Check for updates, but let me choose whether to install them" to "Never check for updates" (which now matches the FF setting). This appears to have solved my issue. I also got rid of the about:config strings that I'd added in Pale Moon.
    Now everything seems OK.

  8. #8
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    Good work, Les.

  9. #9
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts
    Sorry, the fix didn't hold, the problem remains.
    Guess I'll give up, but it always irks me when things like this happen. I'd really like to understand why.
    Thanks again for your help.

  10. #10
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    Try asking on the Pale Moon forum?

  11. #11
    4 Star Lounger
    Join Date
    Jun 2010
    Location
    Littleton, Colorado
    Posts
    492
    Thanks
    33
    Thanked 6 Times in 6 Posts
    Thanks for the suggestion. I just posted there, should've thought of it earlier.

  12. #12
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    No worries, I see it there now.

  13. #13
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    There is an add-on called BetterPrivacy, which works in Firefox (don't know about Pale Moon), described as a "Super-Cookie Safeguard", which will delete unwanted Flash cookies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •