Results 1 to 7 of 7
  1. #1
    3 Star Lounger
    Join Date
    Jun 2014
    Posts
    287
    Thanks
    11
    Thanked 6 Times in 5 Posts

    Updating Hard Drive Firmware on an HP DL380 G5?

    On bootup I get a bios message that the firmware on my second drive array needs updating.
    I searched the HP site and found the update file, and downloaded it onto the server.
    After extracting the files I click on the executable and shortly after the opening screen it indicates that it didn't install because there is no compatible hardware found. This is all after Windows has started up.
    So does this mean that the upgrade has to be done before Windows has loaded? and if so, how?

    Thanks,
    rstew

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    Those updates are designed to be installed from Windows.
    You may have the wrong update. Did you search for updates by server serial number?

    cheers, Paul

  3. #3
    3 Star Lounger
    Join Date
    Jun 2014
    Posts
    287
    Thanks
    11
    Thanked 6 Times in 5 Posts
    Quote Originally Posted by Paul T View Post
    Those updates are designed to be installed from Windows.
    You may have the wrong update. Did you search for updates by server serial number?

    cheers, Paul
    No; I'll try that. I searched by drive model number. These drives were originally in a different server.

    Cheers, rstew

  4. #4
    3 Star Lounger
    Join Date
    Jun 2014
    Posts
    287
    Thanks
    11
    Thanked 6 Times in 5 Posts
    So I rechecked a few things.
    The drives are DG146ABAB4 with firmware rev HPD7.
    The bios recommends a firmware update to at least rev HPDA.
    The cp015093.exe firmware update that I tried to install lists this drive model, and is rev HPDF of Jan 2012.
    The release notes indicate the P400 driver firmware must be at least rev 5.2, and mine is rev 7.24
    The only other thing is the update is listed for use with Windows Server 2003 and 2008, 32 and 64 bit versions; whereas I am running Win7 Pro x 64 bit. Might this be an issue?

    rstew

  5. #5
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    It's possible W7 is the issue. Can you download a bootable version of the update?

    cheers, Paul

  6. The Following User Says Thank You to Paul T For This Useful Post:

    rstew (2016-11-22)

  7. #6
    3 Star Lounger
    Join Date
    Jun 2014
    Posts
    287
    Thanks
    11
    Thanked 6 Times in 5 Posts
    Quote Originally Posted by Paul T View Post
    It's possible W7 is the issue. Can you download a bootable version of the update?

    cheers, Paul
    Kind of what I was thinking. (Don't know if there is a bootable version.)
    So I loaded Server 2008 x 64 on a spare drive on a spare DL380, just to see if that would work.
    Then I put the 4 x 146 GB drives that needed updating in it. Had to update the P400 firmware first, as it was too old.
    Then the update of the drives firmware went without a hitch.
    Interestingly it booted back to the bios after the firmware executable loaded, and the actual update was done at the bios level.
    Only took a few minutes with all sorts of dire warnings about not interrupting the power or shutting it off!
    But the drives are working just fine and a check using HP's array configuration utility shows the new firmware as rev HPDF. All good.

    Thanks again Paul for staying with me on this!
    Rod

  8. #7
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •