Results 1 to 6 of 6
  1. #1
    New Lounger
    Join Date
    Aug 2015
    Posts
    14
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Angry OneDrive - Can't Disable or Hide It - What Now?

    I tried to disable or hide OneDrive per MS instructions, but they didn't work maybe because OneDrive settings have changed? I'm using Windows 10 Home anniversary update. MS says it can't find gpedit.msc.

    Even though I have unchecked "Start OneDrive automatically when I sign in to Windows," it keeps asking me several times a day to set it up. It's driving me crazy and, of course, MS is no help. What do I do now?

    TIA for any help.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    See if How to Disable OneDrive and Remove It From File Explorer on Windows 10 helps.

    Note: gpedit.msc is only available in a Pro, Enterprise, or Education sku.
    Joe

  3. The Following User Says Thank You to JoeP517 For This Useful Post:

    LaurieN (2016-11-30)

  4. #3
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,761
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Gpedit.msc is not available in the Home edition as far as I know.

    Are you using a MS account or a local account to log in?
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  5. #4
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Delaware, US
    Posts
    1,172
    Thanks
    19
    Thanked 99 Times in 88 Posts
    Are you saying that if you don't give it a login, it bugs you to login?

    You can always just login then ignore it. Don't use it.
    Graham Smith
    DataSmith, Delaware
    "For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)

  6. #5
    Super Moderator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    2,143
    Thanks
    101
    Thanked 580 Times in 464 Posts
    Quote Originally Posted by LaurieN
    I tried to disable or hide OneDrive per MS instructions, but they didn't work maybe because OneDrive settings have changed? I'm using Windows 10 Home anniversary update.
    There are 2 ways of doing this without using gpedit.msc.

    Method 1 - System-wide
    Use the method described by Shawn Brink on TenForums in his How to Enable or Disable OneDrive Integration in Windows 10 article. As you are using a Home edition you won't have access to gpedit.msc so would need to use the Registry Editor method (Option Two in the article).

    PROS - Works system-wide (i.e. HKEY_LOCAL_MACHINE) so disables OneDrive for all users. Just merge a .reg file and reboot.
    CONS - To re-able integration, you need to merge a .reg file, reboot then sign in to OneDrive.

    Method 2 - Per user
    The second method is to use the Registry Editor and amend different keys to those in the TenForums article above. This does a very similar job to the first method.

    PROS - Is easily reversible without having to sign in to OneDrive. Just merge a .reg file and re-boot.
    CONS - Disables on a per user basis, so amendments need to be carried out for each account. i.e. merge a .reg file for each user.

    In this second method, you need to know whether you are using a 64-bit and 32-bit version. Right-click on Start, choose System from the Power menu then, on the right-hand side, look at the value for System type. For example:

    system_info.png
    Click to enlarge

    I've attached a OneDrive.zip file containing the .reg files for both methods (and for undoing the changes... just in case ).

    OneDrive_zip.png
    Click to enlarge

    You'll note that there is no .reg file for Method 2 - OneDrive - Start OneDrive running at Startup. This is because it's a per user setting and I have no idea what account names you use.

    Note: When you install Windows, the first account created during installation is made a member of the Administrators group, so can double-click on .reg files that affect both HKEY_CURRENT_USER (per user) and HKEY_LOCAL_MACHINE (system-wide) hives in the Windows registry. Subsequent accounts that are created may be either standard or added to the Administrators group. Standard users cannot double-click on .reg files that affect the HKEY_LOCAL_MACHINE hive because this would affect the device system-wide, i.e. all accounts. As a result, you may need to use the Registry Editor in 'elevated' mode:

    1. In Cortana's input box, type regedit.

    2. When regedit appears (with Run command underneath), right-click on the result and choose the Run as administrator option.
    regedit_run_as_admin.png

    3. Click on the Yes button in the User Account Control dialog to accept.
    regedit_UAC.png

    4. Use File > Merge to import the .reg files you want then close the Registry Editor.

    Hope this helps...
    Attached Files Attached Files

  7. The Following User Says Thank You to Rick Corbett For This Useful Post:

    LaurieN (2016-11-30)

  8. #6
    New Lounger
    Join Date
    Aug 2015
    Posts
    14
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Rick (and others who posted suggestions), I was about to try these suggestions when I found that OneDrive is no longer one of the hidden icons in the taskbar. Then I remembered that it didn't bug me yesterday or today. Don't know why. But if it starts bugging me again, I'll know how to fix it.

    Thanks for the help, everyone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •