Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Jan 2002
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    probs w/ file opening (office xp pro)

    alright:
    when i try to open an existing office file, such as .doc, .xls etc. i get an error which says:
    CANNOT FIND THE FILE 'D:Planner.xls' (or one of its components. please make sure the path and filename are correct and that all req. libraries are available.

    BUT, i can launch excel or word, and then open the file from there. i just can open it by itself.
    i now this may be a dumb question but this problem is VERY ANNOYING. i haave reinstalled SEVERAL times. PLEASE HELP

  2. #2
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: probs w/ file opening (office xp pro)

    Depending of what version of Windows do you use,
    from Windows Explorer (or "My Computer") click Tools | Folder Options | File Types tab, then choose one of problem types (say, DOC) and find Actions (it's different in different versions of Windows - Customize, Advanced and so on), point to Open command and click Edit button. Make sure that "Use DDE" checkbox is checked and DDE Message is:
    [REM _DDE_Direct][FileOpen("%1")]
    For XLS files DDE message is [FileOpen("%1")];
    For MDB - [SetForeground][ShellOpenDatabase "%1"].

    Another words, make sure that "%1" switch is present and enabled.

  3. #3
    New Lounger
    Join Date
    Jan 2002
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: probs w/ file opening (office xp pro)

    hey thanks for the help. BUT, the %1 swith is already present in the file ext. if it help, im running win2k pro.
    thanks agian for the help
    Attached Files Attached Files

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: probs w/ file opening (office xp pro)

    In your example, the file path/name contains a space, and this is what the " marks around %1 address. If they are missing, the application tries to open a file whose name ends with the character just before the space. Do you have the problem with file paths/names that don't contain a space (as in your original post)? If so, it probably is something else.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •